VCRUNTIME140.dll Error

Haven’t played since September. Today I decided to check out what is new. Game updated. Then, entered the menu. Crash. No error message. I tried it again. Menu. Crash. Same story. A few more times.

Bugged ■■■■. Regret spending money on this.

Faulting application name: FlightSimulator.exe, version:, time stamp: 0x5fda32ba
Faulting module name: VCRUNTIME140.dll, version: 14.28.29231.0, time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset: 0x00000000000012de
Faulting process ID: 0x1044
Faulting application start time: 0x01d6f8c197176bda
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report ID: 1bcb05e1-1a51-4d7e-ae0c-6d5a49176833
Faulting package full name: Microsoft.FlightSimulator_1.12.13.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

really a strange error message :wink:

What you already tried from given hints ?
Mods installed ?
What are your System Specs , Driver versions, etc ?

Specs don’t matter. The sim was working without issues until recently, therefore specs are irrelevant, as the exact same system did run it flawlessly until now. No mods installed. None. No changes in the system were made - apart from automatic Windows updates. If a system runs a software fine yesterday, and the same software suddenly stops working on the same system today, it cannot be the system’s fault. Well, unless the hardware (memory, PSU maybe?) is failing.

All drivers are up-to-date.

Well, if the same software was working fine yesterday, and nothing changed in the software, and it’s not working anymore today, the likely cause is something outside the software.

Windows updates, driver updates, hardware failures etc.

I’ve occasionally had some VCRuntime errors as well. Since I’ve manually set my virtual memory, the problems have stopped (knock on wood).
Maybe you can try that as well.

Finally…Solved CTD issues… for those of us with < 32 GB ram - Self-Service / PC & Hardware - Microsoft Flight Simulator Forums

“September ( assume 2020 )” is same as “Yesterday” ( Feb. 2021 ) :thinking:

You simple not answered the main questions !
As what reason you asking for help in that forum ?

You totally lag when it comes to the point.

Yesterday or September, what does it matter, really? The game worked until the last time, in fact, worked like a charm, it was rock-solid, and delivered high FPS on near max settings. Now, a few months later, after not playing for a while, it crashes to desktop from the menu, from the world map. Not even starting a flight. On all occasions, 100% of the time. The game is fully updated, no hardware is replaced. Got it? If it worked fine the last time on the exact same system, there is no reason not to work on it today since the system is unchanged.


Windows updates and obvious driver updates do happen. Either one of these introduced some incompatibility, or the game did. I’d rule out failing hardware as way too many people are affected.

so, you not asking for help , you just want to say that you get a CTD ?

But anyway… the most important hint gave you already @MortThe2nd .
If you expect other hints, we need informations like I asking for.

I had FS on an older computer. While it ran poorly, it did not ctd (not that I can remember). My new computer is having problems with the VCRuntime140.dll error. This occurs after about 15-30 minutes in the game, every time.

I may have narrowed my (and maybe others’) problem down. My new computer is running a few applications all of the time that the old computer was not. I started by disabling these programs. I have now narrowed it down to one of two programs:

Corsair iCue, or
Logitech G Hub

With both of those programs disabled I just did flights for 3 straight hours - impossible before. I’ll enable them one at a time either tonight or tomorrow and see what happens.

I also note that I am running an AMD 5600xt. I ran with just the driver (uninstalled Adrenaline software) and this did not fix the problem. I have yet to reinstall Adrenaline. If I can get the program causing the CTD nailed down, then next I will reintroduce Adrenaline and see how it goes.

Good luck to all.

Edit: Logitech G Hub did NOT crash the sim

Edit 2: Corsair iCue - CTD

looks like you found the source of your problems then.

Hello everyone, I return to this thread since yesterday I inexplicably had 140.dll-0000000005 again, without having modified anything in FS or the Nvidia control panel. Well, looking at many posts from colleagues, I observe that when you review the events you only see those produced in “Application” but yesterday I realized that in the “system” events there are also errors and the most worrying thing is that in my case they are the ones that They produce the errors in the Application, since they occur a few seconds before. In my case it refers to “nvlddmkm.sys”, I don’t know if this is the case or in other cases other drivers are involved. This kernel is part of the Nvidia driver set in this case. So I wonder, are we not targeting the Application error, when the real culprit is a driver? I say this because I have not seen in the forums anything related to this.
I understand that if an error occurs in a driver that conflicts with something in the simulator, automatic and cascading, other errors occur in the FS application.
Sadly I am not a computer technician how can I find out more about this file. Looking in St.Google and in not very old publications there is something that does not match my configuration, almost all the solutions refer to the location of said file that they follow is in this path C: / Windows / System32 / Drivers, but not I managed to see it there, looking for it on my PC I found it in this path C: / Windows / System32 / Drivers Store / File Repository. Having seen this, I reinstalled the Nvidia drivers again in case there had previously been a bad installation or a corruption in my drivers and the new installation ignored that file again in the path indicated on the internet. I would like if you. you can look at this.

  1. If you get an error of 140.dll or 000000005 not only look in the event viewer in application but also in System.
  2. If the file I refer to, where do you have it located?
    I have installed the 461.40 drivers, I will continue investigating on the internet.

If installing older VC++ redistributables, you should uninstall the later ones first, and then re-install them again afterwards (and use the combined 2015-2019 VC++ redistribs) as they need to be installed in-order.

That’s interesting. I’ve just rebuilt my PC. Didn’t reinstall the the G Hub yet but did install iCUE. Still getting CTD. I’ll try disabling iCUE next.

Hi fellow simmers. I had been struggling with the VCRUNTIME.DLL CTDs for a while. Finally did some digging and found that there were several installations of Microsoft Visual C++ XXXX-XXX Redistributable (x64) packages installed on my system. Like 8 or 9. I finally ended up deleting all of them and reinstalling the latest from the x64 link here

I have now about 20 hours of flying since the changes and no CTDs so far.

Remember that some of the programs you install will also “optionally” try to install a specific VB version because that is what they used to compile the program in. So, you end up with a ton of different versions of VB installed. I know that some of the 3rd party flight sim companion apps that I have installed do this. So, going forward, I will make sure that there is only the latest installed. If the 3rd party app stops working, then so be it. I would rather fly than troubleshoot other programmers’ problems.

Hope this helps!

Nope, never a good idea to uninstall older versions. That is asking for trouble from Windows

1 Like

Anybody still having this problem… Recently started having CTD with VCRUNTIME.DLL started having shortly after RX6800xt upgrade running with i7 7770k 32gb Ram and SSD


Yup, I have RX6800XT and am getting VRRUNTIME140.DLL or D3D11.DLL crash every flight. Running 10850K with 64GB RAM. It happens mostly in VR mode. Lowering the render scale in sim has helped but not a real fix. I think the SIM has a bug in utilizing GPU at max load. I run a waterloop and the hotspot on my 6800XT never rises above 72c. And it happens only with MSFS2020. I hope this will be fixed in the next sim update. This issues has been around since the release, though.


Yeah, definitely something wrong… I’ve spent the day trying to sort it I was finding if I take off from Southampton flying to France it was crashing in the same spot every time… I did the flight 3 times and everytime it crashed, I’d also find it was crashing on flights to airports I hadn’t visited before… So I deleted the cache turned on DATA Limit and done the flight again and this time no crash and I managed to land at the airport… so I’m not sure if this has fixed my problem but gonna try a few new routes and see what happens

1 Like

I’ve open two tickets thus far on this, first ticket came back with the “delete the c++ redistributables and reinstall.” I did and CTD continued to happen no matter where I was flying. Put in second ticket response was “send us your msinfo and dxdiag files” did that and… Nothing back.

I’ve only started having this particular CTD after the UK update. There’s so many “try this, do that” things out there that with so many variables being changed we’ll never know what is truly causing all of these issues. But I get the VCRUNTIME and now .NET errors.

1 Like

Yeah I had another crash… after deleting cache but then realised i turned back on the Text to speech so set that to Windows offline mode and has been ok, but yeah lots of people having this problem in different scenarios, I think it was probably after the UK update I started having trouble, Hopefully, they sort it soon

1 Like

So after you said that Azure was turned back on by the latest update I went and checked and sure enough it did turn Azure back on after I had turned it off back a couple months earlier. Here’s what I did:

  1. Deleted cache AND set the new cache to be saved on my F: drive (which is an SSD and where I have the Steam version of MSFS installed - I don’t know if that makes a difference)
  2. Set “Text-to-speech” to windows offline
  3. Downloaded the “hotfix” yesterday (I know it’s the “flaps” fix but almost a gb to fix a config file? This is suspect)

I changed 3 variables. Afterwards I flew in multiplayer on East Coast server, N. Europe server, used 3rd party aircraft, default aircraft, various weather setting, all for about 5 hours and not a single CTD.

My money is on Azure causing the runtime error. Maybe the cache being what it is but I don’t think so. The “hotfix” maybe if they put something in there they didn’t mention…