Very faulty flight of the L-39 Albatros Robin 1

Please tag your post with #pc and/or #xbox. PC

Are you on Steam or Microsoft Store version? Steam

Are you using Developer Mode or made changes in it? Developr mode

Brief description of the issue:

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

I bought the L-39 Albatros Robin 1 from Marketplace, and it doesn’t fly at all. As soon as it takes off, it is totally uncontrollable. I have tested it several times with the same result.
Starting the flight at altitude, exactly the same thing happens: it begins to rotate simultaneously and violently on its 3 axes and there is no way to control it, neither with flaps nor without flaps.
I guess the whole series will be faulty.
Has anyone else bought this same model of aircraft; if so, please let us know.

Regards: Delfiin

I am having what sounds like a similar issue with the Volocopter. In my case, I saw that it was being caused by wild RPM fluctuations for every motor. In your case, you only have one engine so it probably isn’t that, but it may be a similar coding bug.

Hi @MTFlyimg

Your case is somewhat different and that comes from SU 7, but I bought mine on Marketplace through Steam. This plane is a jet and is part of the team that fly the Reno races.

I immediately deleted and requested a refund (well, the amount stays in my Steam account, which I have problems with them, because they did not read my communication, and a robot answers me saying that they can not cancel me the sale, since it was made in May.The robot interpreted that I wanted to cancel MSFS 2020 completely.

It is curious that very soon after sending my topic to the Forum, they removed the plane I bought, from Marketplace. There used to be 10 of the same profile, now there are only 9 of that series.

I tried the volocopter and apparently it flew well but it was short time.

after this little research.

Here I interrupted this post and went to test again the volovopter,but paying attention to its behavior. I found the following:

1).-Slow ascent (I guess it is normal).

2).- maximum translation speed= 65 knots

3).- very, very slow descent and with engine at minimum power (idle), and I guess this is not normal.

4).- the engine needle does not move, regardless of how fast the engine is accelerated.

    • The rpm of the engines are very uniform.

That’s all I can tell you.

Regards: Delfin

Same, totally unflyable. Help needed.


Check the Flight Model is MODERN !

Hi @Raymond

Thanks Raymond, about an hour ago it was provided to me by “radim17”. I found him in the topic "Reno Air Race: Pack $ 19.99- Cockpit and more" and in a personal message, he was provided to me by “radim17”. Indeed, with this change, I think that all the anomalies of this series of aircraft, are repaired. Mine works correctly.

I never imagined that such a change would be a solution to this problem.

Do they have any special meaning in aviation or aeronautics "legacy and modern?.

Thanks for your help, very timely and appreciated.

Regards: Delfin

1 Like

Glad it’s all fine; did Steam pay the money back? I guess no, since you were able to try, ie you still have the planes.
Legacy is for old FSX planes ported to MSFS. Go in there, the legacy elements are like those in FSX. Greyed in the image above.

All native MSFS planes use Modern.

I didn’t think quickly about this, because I have never changed it: I always have Modern.

I kept searching, because there is always a solution, which is always easy when you know…


What a small world! I was helping him as well; saw his question totally by accident on FB !

Hi @Raymond

I’m surprised Raymond: I just sent you a post in reply, immediately cancelled it, then incorporated something, reattempted the post again, and it was not allowed, claiming it was too similar to the previous one.

Then I tried via personal, and…same response. if you make any small modification to a post just submitted, but immediately delete it, is it not allowed to resubmit with the modification?

1 Like

Hi @Raymond

No, Steam neither refunded my money, nor I think they would refund it if they had not found the solution. They gave me three answers, so absurd that I have already told you something: (pure AI). I replied to the second one with a bit harsher language, and to my answer, finally “a human” answered me. I am literally sending you the answer:

Mensaje enviado por el equipo de Soporte de Steam el 20 NOV a las 23:38 | hace 1 día y 11 horas


Como mencioné previamente, no podemos anular la compra de 9.99 euros, en la cúal son los 40 créditos cuya compra fué realizada en el día de ayer 19 de noviembre, ya que estos créditos fueron usados para la compra de dicho avion.

Por consiguiente no podemos reembolsar, compras realizadas en dentro de la tienda en un juego de terceros.

Cualquier compra de un artículo que hayas realizado dentro del juego usando los 40 créditos que compraste en el día de ayer, Steam no tiene posibilidad de realizar dicho reembolso, ya que la compra fué realizada con Microsoft Flight SImulator directamente y no con Steam. Si deseas que los créditos del juego sean reintegrados, entonces tendrás que ponerte en contacto con el equipo de Microsoft Flight Simulator usando la información de la sección de Soporte oficial y solicitar dicho reembolso con ellos directamente.

Por otra parte, si deseas anular la compra de los 40 créditos en su totalidad, no podemos hacerla hasta que te hayas puesto en contacto con el desarrollador del juego y muestres una captura de pantalla en donde ellos confirmen que tu cuenta de Microsoft Flight Simulator no tendrá ninguna penalidad al realizar el reembolso de esta transacción.

Best Ragards: Luis

¿Que tal te aclaras con mi lengua materna?= How do you get clear with my mother tongue?

Regards: Delfin

Bonjour, M. Raymond Goubet

Comme vous l’avez dit, combien le monde est petit.

That’s right, my dear friend. Where did I find you, well, at your Reno Air Race; there this time participating as a ghost, and not competing with anyone with your red L-39 Albatros. I didn’t know you had bought it. Naturally, I subscribed to your channel, and I clicked you a like (the first one), and there will be as many as your participations in youtube (with your magnificent acrobatic filigrees), you deserve that and much more from me.

You had told me when I informed you that you were competing with others in Reno Air Race, that you had not found the video, I guess you were not referring to this one, indicated by this link:

About the Reno races, I have only one L-39C Albatros Robin 1 airplane, can you go around that circuit having only one airplane? Have you flown it, do you have one or more than one to be able to participate.

I tried with this sequence: activities à Reno Air Races but I couldn’t find the way to enter in the circuit scene. If I can do it, please complete the sequence for me.

Well, I just discovered your new activity on youtube (at least for me), and I congratulate you for it. There you appear with 96 subscribers. I was surprised that after I subscribed, the number of likes increased by one, but not in the number of subscribers who continued to show the 96.

I hope to see that number of subscribers in 1,000, let’s see how long that number takes.

Regards: Delfin

Bonsoir Delfin,

Je parle parfaitement francais, mais je vais rester en anglais, pour ne pas me faire gronder! Oui tout petit…

Yes in the Time trial race, the Ghost is the sim replaying your fastest time trial.

Yes in these videos. I did 4 proper races yesterday, but I kept being hit by racers from behind or underneath, and each time the guilty ones kept going, and I was put backwards ~ 3 seconds! I don’t know how/why the system rewards those who hit from behind. I can’t see them behind!!!

Yes I bought it: £ 49.99 Each plane in each type is different from the others.

Thank you for your compliments and kind words; this is worth more than a billion subscribers! In my videos, I never ask to subscribe. My motto: freedom, people do what they want, whether or not just to watch and/or subscribe. What counts to me is that the few people who watch my videos like what I do.

Yes, I was referring to the ones I did in the Reno beta, 3 weeks ago.
I want to be faster on my own, then I will see. I don’t like this far west madness of idiots ramming from behind. There were several threads about that from the beta!

I don’t know if the Reno scenery is there in normal FS mode, or only in the RAR mode.
The only L-39 I have flown is Pipsqueak, based on the real Pipsqueak, as it’s the fastest, and I find it still too slow! I have not flown L-39C Albatros Robin 1 yet.

Did you buy the whole Reno air race???

I was at 38 subs ~ a year ago, so it’s slow. I don’t make beautiful videos with full of effects, or doing silly crashes and impossible landings, ie landing the Antonov 225 at Courchevel. Lots of people like these, but these videos destroy the reputation of any flight sim, as they are whatever! N’importe quoi!

I like pushing the envelope, doing skilled and daring flying. And there is nothing more ridiculous than those videos where guys develop lots of theory - even real pilots - sound very knowledgeable, because they are, but to make poor landings, and then to always find an excuse for their poor performance.
Theory without practice is worth nothing.
If I have to stay small, so be it!

Did you reload after subbing?

Kind regards,

NB: I sometimes may be slow to answer, because I lost my left hand in an accident when I was 20. I have a stump till the wrist, which is very useful to do anything! But my typing is slow!

NB: something to remember: planes behaves differently in Time Trial and proper races:
Time trial: the fastest in a category is the fastest!
Proper race: all planes have the same performance

Dear friend Raymond

You are going to allow me to express myself to you in this language. Something very special just happened to me 10 minutes ago. It was this:

I connected the PC to the network, I looked in the Forum for your possible answer, an answer that I saw in the icon at the top of the right, there I saw a “1”. When I clicked, I saw your message, I hit it, but my surprise is that there was no message. Then I stared at the screen and noticed the word “replaying” appear.

I continued looking at the screen, and after a while, the text appeared in several paragraphs. I read them 2 times, you ended with a “Kind regards. Raymond.

I stared at the screen for a while and … suddenly, I see this paragraph appear:

“NB: I sometimes may be slow to answer, because I lost my left hand in an accident when I was 20. I have a stump till the wrist, which is very useful to do anything! But my typing is slow! "

I read it again several times, and although its content was perfectly understood, I translated it into Spanish (my language), in case there were any details that I had misunderstood. I assure you that I was looking forward to it! You know: when you do not master a language correctly, there are always words (words) that you do not know). And I hoped that something was not as I thought I understood, but no, I had correctly understood everything that message contained.

I reread it several times, at the same time I felt a kind of chill in my body, in my heart, in my soul? I made some deep aspirations, I needed it, something identical to what invades us when they communicate the loss of a loved one happened to me: you are impressed, hurt, sometimes dejected. I assure you that I was deeply impressed by this news of yours.

I am writing this to you, and I still feel in my neurons, in my sensitive fiber, this kind of pain, of despondency, and I need to take deep breaths to recover from the impact of your state (as if it had happened to you now; really for me, it was exactly like this: you have lost your hand now!

And why was it like that? Well, only I can answer you, and this is strictly the answer:

I am perhaps a very affectionate person. I have seen in you a man who gives himself with conviction in what he does, in what he likes; and this flight activity, you like it very much. Me too. That is why I have connected, I would say more: I have tuned in very well told, and you have responded very widely to everything I have asked you and more things that I have not asked, and that satisfies me and, without consciously realizing it, I took a liking to you . The more posts answered by you, the more my neuranas filled with knowledge (and my soul, with affection for you, recognizing your sacrifice for a person that you will never really know, nor will you see either).

Something as strange as this has never happened to me: feeling for your loss of hand, that … pain !, that emotional impact !, as if you had lost it now. Naturally: for me (who was unaware), you have lost your hand, the moment I read your message.

I was deeply impressed by the news, that you have confessed something so … personal? So intimate?

Well friend Raymond, this is how human beings are, sometimes, as you can see, WE SURPRISE OURSELVES. THAT EXACTLY, JUST HAPPENED TO ME.

It happened to you when you were 20 years old; For me, it has happened to you, when I read your message. Although I don’t know how many years late, I AM VERY, VERY SORRY.

Receive a big hug: Delfin

1 Like

Thank you; that is very kind of you. If you knew the people who called me names, ie “dirty disabled”, or worse. But I should thank them for helping me get a THICK skin!
A few times in the 1990s, I won the top spot at car racing competitions, in arcades / gaming salons…
Once, when the prizes were awarded, there were only 3 people present, on a usually busy evening!

Were there more people like you, the World would be a better place…

Houston, THEY have a Problem!
Houston here… sorry we have no solution… Aha…

Yes I always edit and add things.

I am 55 now, so it’s a long time. And it’s not that intimate, since everybody can see I don’t have a left hand.
It has made me a better fighter, for sure. I go to the gym with a prosthetic, not pretty, but functional.

Yes, when I reply, I try to be useful, otherwise I am just good for the … toilet!

Indeed, I throw myself with conviction in what I do! That is why, I often show my settings (Hard) in my videos. So, we can see: no cheating. If it’s for cheating, then I am out…
As a matter of fact, I had my accident making rocket powder for small rocket solid powder engines.
Because without an engine, there is no rocket!
I saw on TV, a program about rocketeers, but they BUY the engines! This is ridiculous… not making the essential part… Not for me!
Static electricity, and the powders blew up. A flash, a bang, and a mess. Fortunately, I can’t pass out, so I knew straight away: I saw it all, I can remember everything, even after 30+ hours asleep…
“What doesn’t kill you makes you stronger.”

I don’t regret anything… We only learn when we fail: ah I see … it doesn’t work like that.

I am trying a few things in FS…

Big hug Delfin.

I have the exact same problem. Unflyable. It’s not just “difficult to fly”, you have absolutely no control over the aircraft after you reach Vr. Is there a solution to this? My flight model is already set to “Modern”. I have the L39C Sarance Model.

Edit: After I set my Flight Model to “Modern”, I deleted the aircraft from the sim and re-installed it. Now it works properly!!!

The Volocity has a max speed of 59kts or so (VNE?).

On my single throttle axis quadrant, 75 percent is enough to hold altitude. Above that you climb, below that you’ll descend. The closer you get to closing the throttle (minimum power), the faster the descent.

However, these are fixed pitch prop electric engines, and don’t respond in the same way you would expect normally aspirated engines do to power changes - it’s very graceful and probably designed that way since it’s supposed to be a safe (ultimately unmanned except for passengers) vehicle. If you really want an aggressive descent, shut off one or both arm motor Master Switches (the red covered ones). Things get sort of interesting then.

Hi @CasualClick
Thanks for the info, but this flying machine doesn’t keep me awake. I have flown it once, because a colleague from the Forum asked me a question and I wanted to answer him with rigor and knowledge, but Velocity is not of interest to me.
Regards: Delfin

I am having the same issue. Just downloaded and installed the L-39 pack and right out of the gate it is unflyable. Same issue with the Beechcraft 99 download. Nothing I do will remedy the violent oversteering. I can’t believe these downloads are even on the Marketplace as they are far from usable. Total waste of time and money.

Verify exactly this:
regards: Delfin


Has it worked or not, with the information I have provided you?

Regards: Delfin