Very Low FPS with 3070ti

How is this even possible that I am Limited by GPU? 14fps at 1440p resolution with 130 rendering just sitting in EDDF (Frankfurt) with a 3070ti? Rest of the settings is a mix of Ultra and High with LOD at 200

PC Specs:
Ryzen 3700X
32GB Rams @ 3600mhz
RTX 3070ti

There are tons of topics here on FPS. The SIM is CPU limited cause it doesn’t use all cores of your CPU, so it doesn’t matter which 30xx card you have (I know, I have a Strix 3090OC).
Just relax, don’t panic cause things are going to improve tremendously pretty soon, on July 27th when they release the next patch, which will make the SIM utilize most cores on your CPU (you didn’t state what CPU you have, RAM, etc). Asobo demonstrated improvements of 40% or more depending on your system.

1 Like

Tell this to everyone, check your ram speeds. Likely bottleneck is there. Open up Task Manager>Performance>RAM bottom right telemetry should tell you Speed, slots, type. Depending on config, you may not get any, you may get one or all 3. Give it a try. Let us know.

Should look like this:

I understand, but the reason it was saying that I’m limited by GPU made me concerned since how can the GPU be the reason here?

1 Like

Not sure why you are getting fps that low, but why are you setting rendering to 130?

What CPU and Ram do you have?

Ah sorry just spotted it under the pic

2 Likes

I thought to make it look better, but even if I drop to 100% rendering is still low and I see people saying that a 3000 series card should run even at 4K

Well I have a similar setup to you with the same CPU and 32GB Ram at 3600MHz and a 2070 Super @1440p with 100% Render, LOD at 175

I don’t use the jet planes , mainly piper arrow and Cessna 208.

I have locked my FPS at 30 in the Nvidia Ctrl panel and it maintains that almost everywhere and is very smooth.
What FSP would you get there with a more basic plane like the Cessna 152?

I will check this, I do have to say that I replaced my PSU to a 1000W to go with the new 3070ti I got. Will changing the PSU cause a BIOS reset or disable XMP?

No, the motherboard wouldn’t even be aware.
However you should still check that it’s enabled – but it wouldn’t cause you to be GPU limited.

Haven’t seen this issue before IIRC.

I wouldn’t have thought so but it’s pretty easy to check in your BIOS.
Also check you have the latest AMD chipset drivers for your model of chipset. And set the power profile to AMD performance.

With 140 render settings, 1440p resolution, ultra settings you need to get 30-40 FPS. You have a problem …

I thought so too, I don’t know what’s going on

Something is wrong on your end.

i9-10900KF / RTX 3070 / 32 GB DDR4 RAM @ 3200 / SSD / 1440p

I’m maxed out aside from resolution scale at 100 and it’s peachy.

1 Like

Oh man, I wonder if my 3070ti is defective or something :frowning:

1 Like

What kind of FPS are you getting at 100 render scale? If I start bumping it up it starts to suffer. Sure some of the higher-end 30 cards are great for 4K but MSFS is like the Crysis of today. Also, optimization is ongoing.

EDIT: I may have jumped the gun saying something is wrong on your end.

1 Like

But frame rate also depends on the scenery? Cities, landscape, mountains or sea.

How many screens are you running? What was your previous GPU and what fps were you getting with that? What temps are your CPU/GPU running at? Wondering if the GPU is throttling maybe???

1 Like

For best performance and visual quality balance set your render scale at 80. You won’t notice any difference between 80 and 100 but 80 will win you back a decent amount of FPS.

Only the RTX3080 and 3090 will comfortably output the sim at 4K. Its what both those cards were designed for. The 3070 and 3070ti are designed to be high end 1440p GPU’s.

1 Like

Thanks all for the suggestion, I will soon try the different recommendations and report back to see if it helped!

1 Like

80 rendering settings result in a very ugly look. A minimum of 130 ordering settings are required for a beautiful view.