VR Busted after latest MSFS Update

HP Reverb G2
RTX 2080 (461.40 driver)
3.60 gigahertz Intel Core i7-9700K
64GB Ram
Win 10 Pro (all updates)

After the latest MSFS update my VR experience is now COMPLETELY unplayable. I have tried every tip I’ve found in the forums unsuccessfully. I reset all MSFS VR settings to Default. Set OpenXR to Custom Render Scale 100% (tried 70% also). Everything else is default (off). Mixed Reality Portal works perfectly. Tried launching VR before starting a flight. Nothing works!

Now when I launch VR in MSFS I get long (sometimes 1 minute) blackouts on the visuals, popping, audio switching between non-VR and VR. It’s really terrible. The game is frozen when this is happening. MSFS works normally at Ultra settings in non-VR mode.

Everything was working perfectly before the MSFS update that I downloaded yesterday. I would really appreciate you guys helping me fix this issue.

Thanks in advance,



Switch to the 457.30 driver to start.

1 Like

Same problem here, though i specifically updated my OS via in place upgrade due to a stuck kb4601319 issue. Not sure if its the inplace at fault or just the latest update.

In the goggles its a mess now.

I reinstalled 457.30 (did not tweak any nvidia settings yet though, cant recall if i had)

Is everyone with this issue at 19042.804 for windows 10 build + the latest gaming services app 2.50.18001.0, also this latest GS update hoses it to cause the settings to be lost, i had gone through the steps of forcing the older GS and then decided to try to update again, it re-broke that as well, now settings are lost each time.

EDIT: i wonder if steam users who didnt do the windows store version are immune to this issue?

Having major issues with my Oculus Rift S myself. No word from MS/Asobo yet

Same issues here. I was blaming R6900XT I recently bought. I still have 2070S where nothing has changed regarding to performance. Boy, don’t know what to do with the R6900XT, still have one week to go before I can return it to the local shop.

Major performance problems here too, the sim sometimes launches into broken performance, sometimes drops into broken performance when you enter the settings page, and sometimes drops into broken performance when switching into vr mode.

Even the menu animations and transitions are stuttering (in 2d mode) when this happens.

Very occasionally I can start the sim and get into vr mode with everything working at full speed. Literally just exiting to desktop and restarting until it works.

Reinstall didn’t help. Clean windows install didn’t help, now have the exact same issue on 2 different computers including this new build - built for MSFS VR.

This did happen rarely prior to this update, now it’s happening almost everytime. I cannot find a solution. There is a deep issue with the rendering or initialisation of the rendering and this update made it a more frequent occurrence.

1 Like

I have exactly what you describe, and stopped flying for the last 3 days due to this and the flaps bug and mainly the lack of hotfix for all of this. Something is dirty in the Sim initialization and/or during VR switch, and it’s pretty new, at least at this amount of problems. It’s too much to accept.

I think, as an user who switched from the Game Pass to Steam before buying due to the way the MS Store managed the game (badly), that we Steam users are not impacted by the lost of settings. I may have wrong, I didn’t have the will to test anymore like I said, but I didn’t read any Steam users complaining about it


For any Oculus users on here that are still running the Public Test version of the Oculus drivers, you might want to uncheck the checkbox on the beta tab of the oculus home settings.

A new Oculus beta release came out around the same time as the World Update and really messed up the headsets. It causes very frequent flashing for most users, so apologies if this isn’t your problem, but it might still be worth checking, as the stable version of the Oculus drivers are far better.

I’ve just been flying with a CV1 and haven’t noticed any issues, so whether it is the above issue or not, it’s not affecting everyone.

On the contrary, I’ve never enjoyed flying with the Index as much as since WU3!

I’m preparing a post to “My VR Settings - Index” topic but I can now have butter smooth motion smoothing at TAA100 + SS124 (which is 2244 x 2492 pixels rendering!) with clouds HIGH and TLOD 100 around UK with the Citation except around London, and on the ground I have to sometimes reduce clouds to MED.

I’ve also received today my G2 Frankenmask and I’m currently testing it and… well… it is complicated but in short it doesn’t eliminate all the bad things I documented about my G2 (at least mine if not all of them) except it makes the transition between the center disk of clarity and the rest more gradual, but it is still narrower than with the Index (nearly 90% top to bottom, and 80% left to right to me with the Index).

My VR experience has always been pretty all over the place. I’m not sure the latest update has made much difference. One thing I’ve discovered over the last few days is that I’m sure that recent Oculus update mucked up the tray tool. My Quest 2 definitely seems more stable when I don’t use the tray tool now.

Thank you everyone for your replies. At least I know it’s probably not my setup or hardware. Looks like Update 3 works for some people but certainly doesn’t for others. I’m going to stop flying until Microsoft issues a patch. It’s just too painful. They have robbed my joy.

I did roll back my driver to 457.30 and it seemed to help and then the hangs continued as before.

I hope Microsoft reads this thread and issues a hot fix ASAP. I wish there was a way to roll back MSFS to an earlier working version.


1 Like

It’s definitely not your setup, I’m seeing the same exact problem on two different machines. There are enough posts on the forum right now describing the same issue, I’ll gather them into a lengthy zendesk ticket tomorrow and see if I can get anywhere with it.

Generally, it looks to me like the ‘poor performance with good hardware’ posts are hitting this same problem with the game initialising badly and getting into a poor state, and those folks are going round in circles following any number of guides.

1 Like

I had problems after the last update - having had good performance up to then with the GA aircraft and my Index.

I was about to go back to FSX/P3D and Flyinside and wait for improvements before returning, when I remembered about the SteamVR beta update where it’s possible to lock the framerate.

I locked it at what would normally be considered a very low 18fps - and it’s awesome! Seriously, it’s even better than when I was getting around 30fps before the update. I lowered my refresh rate from 120Hz to 90Hz and did the lock - that’s all. So happy now. I think I can even consider upping the quality. I did an hour’s flight in the TBM930 this evening and never enjoyed it so much.

I won’t try it with my Quest 2, though.

Exactly! My Index settings for the last 2 weeks have been:

  • TAA 100 + SS 124 / Motion Smooth. 90Hz / 22.5fps + 22.2ms

Very good experience with these all over UK but London aboard the Citation for example, pushing 2244 x 2492 pixels per view and per frame!

1 Like

I’m running this SteamVR setup too (except SS @ 120) on my Vive Pro with an i7 7700K / 1080ti combo. Couldn’t be happier (well, I can always be happier, but you get what I mean - I hope ).

tbh, I only tried it when I saw you mention it previously. Didn’t believe 22.5fps could possibly ever look smooth, but its great with Motion Smoothing which usually looks like rubbish in my experience. I did have to change some props to be completely transparent in motion though to avoid “flicker” visual anomolies.

1 Like

With the Index LCD panel resolution, I find 124 having positive aliasing properties helping in the clarity of small text for example at the expense of slightly more jaggies. In other words, it is as if at 124 the render resolution and the panel resolution are “in phase” (for lack of other words). The Vive Pro panel res is close but these are OLED in the traditional Bayer pattern I believe and there might be some specific SS resolution values you might want to explore finely between 120 and 130 for this reason alone too.

1 Like

Turned out my issue was the orbx version of eglc with starting off at eglc. I uninstalled eglc and all good

457.30 is a MUST

I will not be that sure now, at least if you’re using an RTXxxxx CPU like mine. Last tests and benchmarks I did right before UK update to compare 457.30 and last drivers showed no more fluctuation on my machine with last version 461.40, Game Mode ON and HAGS ON. My GPU usage in VR was really stable (45fps locked), which I wasn’t able to achieve with other version than 457.30 previously. They could have tweaked some stuffs here…

Yeah, I have to disagree there - while it seems to work better for some, it definitely isn’t the case for others.

I’d always been on the latest drivers and happy(ish) even before the new SteamVR locked rate function - but after the UK update when things went a bit stuttery I switched to the recommended earlier drivers (of which different people recommend different versions, though 446.14 is a popular one) I found that things actually got worse, even after dropping all my settings still worse and even dropping every scale rating to 80%.

Going back to the current driver and using the lock did the stuff. Must admit, though, going back to earlier drivers made DCS World work better - as I’d had issues with that stuttering all of a sudden, too - but again, although the older driver sorted that stutter, with the new SteamVR framerate lock I could use the latest drivers again.

So all good all round.

@SimonJones7660 I would say that you should mention the SteamVR framerate lock and the success people are having with it when you report to zendesk. I’m guessing those with issues are on WMR or Oculus headsets. I’m sure those providers will be keen to implement something similar of their own once it becomes widely accepted what a difference it makes.