VR insight M-Panel working in MSFS2020

Just in case you have one of these laying around.

M Panel

. It Does work with MSFS2020

You will need the M-Panel Software and FSUIPC7b (and maybe the manual) below.
Manual: http://vrinsight.com/devel_shot/Manual/M-Panel/M-panel.pdf
Software: http://vrinsight.com/devel_shot/?ckattempt=1
FSUIPC7b: https://forum.simflight.com/topic/90193-fsuipc7-beta-for-msfs/?tab=comments#comment-546085

Be sure to install the Base Package shown below then the M-Panel module

Once installed:

Plug in the M-Panel
Run the M-Panel software which should find the device, select Microsoft Original Aircraft on the M-Panel tab.

Vrinsight

Run FSUIPC
Run FlightSimulator

The device should Boot and give the following functions:

AUTOPILOT CRTL : HDG, SPD, BARO, ALT, V/S buttons and knobs
AUTOPILOT MODE : NAV, APR, BC, A/T, F/D, Engage Auto-Pilot buttons
Instrument Radio : COM1 & 2, NAV1 & 2, ADF1 & 2, DME1 & 2 with OBS knob
USER MODE : TRIM, GEAR UP/DOWN, FLAP UP/DOWN are set as default
Marker OMI display LED
Gear UP/DOWN toggle switch with LED display
FLAP UP/DOWN toggle switch with LED display

Sorry if I have missed anything here but if you persevere you will get it going. It’s a great bit of kit.

(I have no connection with VR insight or FSUIPC)

5 Likes

I have done a quick video of it working here: https://youtu.be/L-7G2qod-a8

Hi,
I’ve tried my Mpanel and I followed the insctructions… but the Mpanel software doesn’t find FSUIPC7 when I push “Fly Now”
FSUIPC7 is right connected with MSFS…
Have you an idea ?
Thanks in advance
Yvan Muster
Switzerland

Sorry to hear you are having problems…Did you install the “Base package” on the VRinsight page shown above? …That also installs “SerialFP2” which provides the virtual COM port (which was COM3 in my case as shown above) to connect to FSUIPC and FlightSIm. I didn’t have to do anything out of the ordinary to get it working

You may need to allow Firewall access at some point

When you press “Fly Now” there are no obvious signs that anything has happened but once FlightSim has finished loading an aircraft up the Panel should be working.

Hope this helps

Thanks for your help,
I use Mpanel with P3D4.5 and it works very well.
With MSFS2020 Mpanel software can’t connect with FSUIPC7… that’s my problem :frowning:
I have too a COM3 like virtual COM.
I don’t understand why

Mmmm. If it helps there is a definite startup order.

If I Press “Fly Now” before starting FSUIPC I get the following “Flight Simulator Not Running” dialog and the “Fly Now” button does not respond

NoFSUIPC

But if I start FSUIPC before pressing “Fly Now” I get:

withFSUIPC

and everything works fine (This image shows the button after pressing it) you can run FlightSim now.

Here is a screenshot of my Device Manager with COM3 driver details and the SerialFP2 dialog

The SerialFP2 app also requires FSUIPC to be running before it will open …although you don’t need to “run” this program under normal circumstances.

I followed the sequence like you said… but The Mpane software can’t found FSUIPC. I’v reinstalled FSUIPC but it’s the same thing

Thanks for your help :slight_smile:

You mention you are already using FSUIPC and P3D with the panel so I wonder if you using the correct FSUIPC7 distro? This one for MSFS2020

The FSUIPC7.ini file has VRinsight entry:

[VRInsight]
1=com0
2=com3

and my FSUIPC7.log file has entires:

FLT path = “C:\Users…\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState”
and
FS path = “D:\MSFS”

perhaps your FSUIPC is pointing at P3D somehow?

After reinstalled FSUIPC and made like you said before… I have always “FSUIPC not found” :frowning:

Although you have the “FSUIPC not found” dialog I can see that FSUIPC is available.

The VRinsight program says it failed to load the M panel module. Did you install it with this module loader?

hi,
I can’t install with the installer panel because It doesn’t find the MSFS2020 program. I can find with P3D or FSX but not with MSFS2020.
I tried with different directories but I don’t know wich is the well.

Sorry with my english :wink:

Oh I see. Flight Sim is in a folder called “WindowsApps” in the “Program Files” directory on a default install or the location you chose if if not the default. The only trouble is is that you don’t have access to it by default. You need to take ownership of the folder as described here.

I already tried with this folder. But It write “MSFS Folder not found”.

Many thanks to spend your time for me :slight_smile:

“MSFS Folder not found”.

I don’t think this is important… Just click OK and continue.

My “VRiSim.ini” Located at “C:\Program Files (x86)\VRInsight\bin” does not point to my actual FlightSim folder…

[MSFS]
////////////////////////////////////////////////////
// Flifgt Simulator Path
//MSFS_Path = C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\fsx.exe
//MSFS_Path = C:/Program Files (x86)/Microsoft Games/Microsoft Flight Simulator X/fsx.exe
MSFS_Path =

These default Paths are scored out anyway and my actual path is just blank. So I don’t think this value is important. I think VRiSim connects to FSUIPC so doesn’t need to use the Path variable.

I have just done an installation on another PC and it works just fine. I had to load the latest “vc_redist.x64” from Microsoft to get FSUIPC7 to run but apart from that…nothing.

I didn’t specify a Path, just pressed OK and then loaded the M-Panel module.

to get it going I started FSUIPC then VRiSim and it found the M-Panel right away.

I don’t understant wich is my problem… I m very angry :unamused:

It is annoying… I’ve run out of suggesions for now , I’ll come back if I think of anything else to try

Thanks a lot for your help… I ve apprecied… perhaps VRinsight will do a driver update… or with the new FSUIPC payware… I hope :wink:

This is my VRinsight “bin” folder contents…Does yours look like this?

Your Desktop screenshot shows the dialog for the “Inst_Panel” program. I didn’t use that. I just ran the “instal_M-Panel.exe” file that I got here

I have the same folders and files… finally I’ve reinstalled all programm and… Yeeeeeeesssss my Mpanel runs correctly in MSFS :heart_eyes:

Many many many thanks my friend to help me :blush: :blush: :blush: