VR insight M-Panel working in MSFS2020

That is fantastic news!

My MCP Combi (first version) works fine too but I noticed a curious thing.
I installed FSUIPC7 and to make it work I had to use the SerialFP2 program.
Now, doing some tests with Linda, I’m using FSUIPC7 with
the beta license expiring 08 NOV 2020 with full functionality and I found that closing LINDA, FSUIPC7 still recognized different commands of the MCP without the need for other software.
I also tried the A320nx and it works fine too.
Now I would like to integrate the missing commands with Linda, have any of you already tried?
Thanks

1 Like

I haven’t found the need to use Linda at all when using my M-Panel with FSUIPC7 as I described above. To be honest I don’t even know what Linda is for, didn’t need it in my case.

What I understood doing tests with the VRI MCP Combi is that if you use FSUIPC7 not registered you must use SerialFP2.
Instead, using FSUIPC7 registered version the MCP Combi is recognized and it works fine without any other software.
The HDG, ALT and SPD knobs on the MCP Combi (Boeing) can only be pushed while on the A320 they can also be pulled.
What I would like to do with Linda, if it were possible, is to intercept the continuous pressure of the knob and have the FSUIPC->SIM interpret it as if it were the action of pulling the knob.

Did you see This introduction to Linda by Brian747 ?

As i mention above I dont have any experience of Linda but going by Brian747’s very good introduction it seems that you should be able to do what you want with a Lua function although it seems you do need a licensed FSUIPC for Lua functionality.

You have opened my eyes to Linda, it seems pretty cool. Thanks for that. I’ll get it up and running on my PC and see what’s what… I don’t have such a grand panel as you but I might be able to work something out… I’m sure someone can

1 Like

Hi. I have the MCP Combo 1 too. I cannot figure out what I need to do to get it functioning in MSFS. VRINSIGHT does not detect my device. When I run the scan, the MCP does get a signal and the display does change to SPD/100 ————/————
HDG/000 ALT/10000
Radio Panel/Select Function

It is puzzling to me. Do I need another piece of software from VRINSIGHT? I ran the base package and MCP Combo module. I am running the licensed FSUIPC7 and Linda 4.0.3.41

Thanks!

It might be worth uninstalling vrinsight using “Add and remove programs” and deleting the installation folder then starting again with the Base package, making sure that SerialFP2 gets installed and then running the Combo module exe.

I only have the M-Panel which is simpler than yours so I don’t really need to use Linda.

If you look above I posted a screenshot of my Device Manager showing the “port” that SerialFP2 creates. You could check that you have that?

Thanks for the reply. I will take your advice and do a reinstall. My Com1 and Com 3 are the same as yours. This ■■■■ thing makes me feel like I’m taking crazy pills.

From the tests I did, in my opinion to use VRI MCP Combo1 you have two options:

FSUIPC7 not registered + SerialFP2
FSUIPC7 registered and nothing else.
Registered FSUIP7 recognizes and manages the MCP directly without the need for other software, Linda is only useful for configuring extra options.
The important thing is that VRI MCP is correctly configured as a Windows device connected to COM3 that you will need to insert in the FSUIPC7.ini file:

[VRInsight]
1 = com3

Thanks. I am using FSUIPC7 registered. The Com3 is recognized and when I start FSUIPC7 my MCP displays change. When I use “Buttons and Switch Assignments” though, pushing MCP buttons do not register. I have 8 GoFlight modules and they all work fine in FSUIPC7. I had to drop GFDev64.dll into my FSUIPC7 folder though for them to be recognized. Is there a VRInsight .dll required? I know I am sooo close, but missing some minor thing. I think I will make a YouTube video of what I’m experiencing. Please keep pushing anything else you can think of. Thanks again!

Did you run any of the VRInsight base pack or modules initially?

Sure, at the beginning I used the standard SerialFP2 package trying to map the keys with SFP2_MCP_KeyMapper but couldn’t do much.
Then I tried to use Linda but to make it work it was necessary to have FSUIPC7 registered.
Then I found on Pete Dowson’s website a test version with expiration after 10 days and trying the registered version I realized that FSUIPC7 recognize VRI MCP Combo 1 and manage it correctly (more or less), so I decided to buy FSUIPC7
In addition to the Knobs, FUIPC7 also manages the various buttons even if not quite as I would like, but that’s another story.

Should’ve asked this earlier. Which aitctaft are you having luck with? Obviously the A320; any others? With FSUIPC it shouldn’t matter, but trying to exhaust all threads.

I fly practically only with the A320nx where I have done more than 70 hours and I feel good.
These days I installed the A330-300 with the A320nx cockpit and flying from Italy to Brazil (9.30 flight hours) had no problems.
I also tried the MCP doing a circle to land with the 747-800 but I didn’t have a good feeling.
On the other hand, the circle to land with 787-10 gave me good sensations and soon I will do some flights.

Awesome stuff! I am trying to get it working in the G36 Bonanza.

Still no luck. I deleted the VRInsight software and reinstalled. My MCP is recognized by FSUIPC and LINDA, but I cannot assign functions.

Does the VriSim program find the panel? As I’ve mentioned, I only have the M Panel which has always been very straight forward to install and use by using the “base package” and the “M Panel module” from the download page along with FSUIPC. I find I don’t need Linda.

Stupid question first… did you get the correct module for your panel? I see there is a ComboII one as wel.

You mentioned above that you also have 8 GoFlight modules that work OK? (You must have a very nice setup there?) are they all plugged into a USB hub or something, do you think you are getting enough power?

Maybe there is a limit on connected devices.

Sorry but today I did other tests and I must say that, contrary to what I said a few days ago, using only FSUIPC7 also by inserting COM3: in the .INI file the VRI MCP Combi IS NOT managed.
Only by installing LINDA in the FSUIP7 folder is it possible to use VRI MCP Combi with FS 2020.

I wondered about about that. I asked Pete Dowson about what FSUIPC does here. You may like to see what he said?

I imagine this applies to the Combo panels too…

I am continuing to test precisely because the interaction between VRI MCP Combo, FSUIPC7 and Linda is not clear to me. I have never read the document “Lua Plugins for VRInsight Devices.pdf” but I have never found it. Let’s see what Pete replies.
Anyways, when I removed Linda from inside FSUIPC7 folder my VRI MCP Combo where not more managed.