VR issues - Oculus Rift S

In the Oculus app go to Settings, Beta and then toggle Public test channel and it’ll start downloading the beta version. It worked perfectly for me as well.

1 Like

I’m on a 1080ti/8700k 4.7ghz
Your settings are solid this seriously needs to be made a sticky!
The simmer above knows what he or she is are doing!:beers:

2 Likes

Thanks for the reply, I will check this out now. Happy Christmas, Martin Portsmouth UK. ( oh the re-entering thing with space bar and oculus panel) How about you guys, another subject, I love the Rift S don’t get me wrong, but I’m gutted to read about the HP G2 with HP getting the controllers so very wrong. That and the fact that this uses WMR scuppered any thoughts of upgrading my HMD. I love the Rift S that has connectivity issues with usb 3.0 but once I faffed about a bit it works like a charm.

Hi All, Am i missing something, I have msfs vr on my Oculus quest 2 but getting a side by side view, anyone know what setting I need to change?

I got there in the end, I was at first only using the OXR ( open VR ) wrongly mapped, Re mapping in the registry sorted my side by side view out, and using oculus application, not steam vr. The instructions are above. In Upper posts how to do that.

Got there at last, set a middle mouse to reset view, and it’s now running happily, I don’t know how to get a frame counter on screen, but it’s running really smoothly I estimate 45 to 50 fps might be more, no noticable hiccups with full traffic and scenery on, so happy ATM. I have ( not the best but prettygood) a homebuilt system , RTX 2080 ti i9 9900k and good fast 32 GB ddr4 Rift s

Hi all,

I am having an issue getting my Rift S to be noticed in FS. I have followed the OpenXR install, set the ActiveRunTime to locate OpenXR, downloaded the latest version of MSFS, updated my 1080ti drivers and windows 10 is up to date. When I go into Options\General I do not see the VR Graphics Tab. The VR Mode tab is present but when I open it there is only one active area to select which is Switch to VR. I click on Switch to VR and I get an ERROR window indicating that No headset is detected.

Any help is greatly appreciated.

Hi, did you ever find a solution? I had my Rift S working yesterday but when I try to go into VR this morning it doesn’t detect my headset.

Not yet! Never got it working at all. At least you had that!

Make sure your oculus software is up to date (set beta tab on for the laterst relaese version 24 or higher)
check your register settings that they are pointing to the oculus software path (fix find it elsware)
The graphic (and traffic) tab is in graphic (traffic) settings (zet pc at the top of this screen to VR)
There is no more a seperate tab…
This behavior is already mentioned many times in the forum (use the search function…)

Thanks. Where do you find the latest release in Beta tab? Don’t see it. I don have Public Test Channel enabled.

Also, need help with where to find the registry settings.

I updated everything yesterday and was flying with my Rift S. I went to bed and now msfs doesn’t detect the headset. It’s only msfs - all my other vr games work fine.

Rift S VR positioning
I have to walk to the back of the room to see the cockpit. Spacebar either crashes FS or leaves me behind the dashboard or even in the red girders of the plane. Cannot get myself in a usable position to play the game. Standing on a chair helps :smiley:

Set Public Test Channel to on and the software updates.
The register pad is
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1
Use regedit to change the openxr pad. Check where your oculus software is installed…;
For me it is;
d:\Oculus\Support\oculus-runtime\oculus_openxr_64.json

Restart your comnputer after the reg change

Hi all!
I love seeing all the feedback and suggestions in here! Reminds me of the alpha days! Anyhow, It seems to be working on on my end with the Rift S with one small item and i was wondering if anyone else is seeing this. When flying, my field of view on the right side will sometimes narrow from the right as I move my head. This worsens over time until I go back to the main menu, toggle from VR to display, and go back to VR mode again and it sort of resets. FOV seems to be about 170 degrees and goes into about a 90 over time…Anyone else see this?

Fixed It!! This (originally posted by wielxp) worked.
Set Public Test Channel to on and the software updates.
The register pad is
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1
Use regedit to change the openxr pad. Check where your oculus software is installed…;
For me it is;
d:\Oculus\Support\oculus-runtime\oculus_openxr_64.json

Restart your comnputer after the reg change

1 Like

You need to change registry settings. There is a good explaination under “known issues”. I was having the same issue until 10 minutes ago! Cheers!

You have to change the FOV setting each time you restart your computer.

That’s odd that spacebar is not working for you. I have found that if windows loses focus of the game it won’t work. If that happens I just click the mouse somewhere on the screen and it works again. Do the arrow keys on the keyboard not work for you? You can use them to reposition yourself as well.

I had the re-centering problem, and the stencil thing. Oculus have updated the software
V 24.0.0.42.393. now it works for me. the graphics are a bit blurry same as X Plane 11, suppose it’s just Oculus Rift S. Don’t think it is the best one to use.