VR Mode Smooth, Until The Headset Activates! Quest 2 Stuttering Badly, Regardless of Headroom

Having performance issues with my Quest 2 and I’m pulling out my hair at this point. 3060 Ti OC with a system to match, and the problem seems to center around the headset itself being active.

In 2D/pancake, the framerate is flawless, no hitching, smooth as butter. VR is another story entirely. When I’m playing with the HMD, every few moments there’s a hitch, a break out of a smooth framerate and it happens no matter how much headroom I have: even if I have over 50% headroom and use a 0.1 SS override, the hitching occurs, with the framerate dipping below the Hz rate over and over again. Even stranger is that this is happening in the menus, too. Without even getting into the map I can pull up the debug tool and see the framerate jogging around, or alternatively I can see ASW dropping frames a half a dozen at a time. In the MENU. It makes no sense, and I’ve tried everything I know of to fix it.

Additionally, and this is perhaps even more frustrating, is that I can see the game performing perfectly when the VR mode has simply been activated, but without putting the headset on: the framerate is consistent and smooth, etc. But the moment I put the HMD on, or even activate it with my thumb? Stuttering everywhere. I’ve tried differing between Link and Airlink, adjusting settings, everything I can think of, no difference: the stuttering only begins when the HMD activates: not in 2D, not with VR mode on.

Can you help a guy out? I’m completely out of ideas on this one and would just love to have a flight without stuttering all over the place.

Try virtual desktop. Best way to go.
Stopped using ocolus software…

1 Like

I´m following. Very interested, as I see the same here. Matter of fact, some days it runs smoother than others, with no clue of what I did differently.

@RobedBadge93725 Would you mind to explain this beginner how to use virtual desktop, and why it can perform better than oculus software?

@RobedBadge93725, do you recommend using the Steam/wired version or the Quest/wireless version?

Depend on how far you are to an accespoint.
I am connected at 866Mbps and work wireless.

I had a 3060TI so first of all that will work.
Played almost all in Ultra at 2700/2800 resolution.
Youre Quest needs to be connected at an accespoint at 5g.
Install VD and make sure that you set it to72fps and medium quality.aswp auto.
And runs like a charm.
There are also tuturials on you tube.
Been testing lots of things but still end up with this. Highly recommended.
Dont forget to let steam be youre open XR is instead of Ocolus software


Holy cow. Installed VD, the difference is STAGGERING. No more hitching and performance is far more predictable. Not sure what it’s doing differently from Air Link but this is definitely the way I’m going with MSFS.

Only challenge now is figuring out the absurd amount of resolution modifiers. There’s the streaming quality in VD, SteamVR resolution, OpenXR resolution, in-game resolution… simply too many variables! It’s difficult to know whether I’m hitting the sweet spot between the streaming resolution and game resolution, wanting to make sure the streaming res quality is at or slightly higher than the game res quality. Any recommendations here?

1 Like

So I’ve try VD and cannot get it to work properly… When going into the sim in VD, I can only get the “Pancake” screen and it will NOT enter VR… Don’t know what I am doing wrong, but I have followed ALL the help and videos out there… Maybe I am still missing something???

EDIT: Sorry need to Add, had it smooth as silk until Windows11 Broke OculusLink, so now using AirLink, which isn’t too bad, but bad studders when panning or turning the aircraft. :frowning: And worse yet… I can turn on set up the sim with airline the same way everytime, and will have completely different results from one session to the next… Ugh.

It’s different from what you do typically, but still easy enough. Before you do anything, make sure SteamXR is your active OpenXR runtime; don’t mess with the registry, just go to your SteamVR settings > Developer > Current OpenXR Runtime, and select SteamVR. You can close Steam down for now.

Now you can start up VD and FS like normal. Queue up the flight, and then inside of your headset, click “Launch SteamVR.” It should load you into the Steam launcher room. Now you can flip over and activate VR mode inside of FS, and you’ll be good to go.

After many attempts, I managed to make it work, but I still don’t know exactly how. Sometimes I see a curved double-images FS screen, and sometimes it goes full VR. First thing I noticed is that I lost photogrammetry, but it can be due to hight band load in this update 7 day. I was able to fly my Bell 47 around for a while, but when I went back to the map to start in another place, everything started to go messy and I couldn’t connect anymore. I’ll try again tomorrow, starting with boot, let´s see how it goes. So far I couldn’t figure out if it’s better or worst.

Whats youre spec?

I’m running a Ryzen 5 3600x, 3060 Ti OC Edition, 16GB RAM.

Ok in rhe quest headset set the qualitty to medium. Turn asw on automatic.
Set VR settings video on what they advise. This brings you closest to what you can run.
3060TI is ok I guess you can run 2700/2800 resolution round about.

I tryed it again, and its still inconclusive. The main problem is that the VD sees my hands and reads them as controllers, creating two intrusive pointers inside the cockpit all the time. The mouse doesn’t work when it thinks I’m using the “controls”. I couldn’t find a way to turn this off. Also the connection is dropping frequently, as much as it did with Oculus Link. I also couldn’t find the menu to change ASW settings. Any help would be appreciated.

In VD, disable the option that allows the touch controllers to interact with the screen. Same thing with the hand tracking option. Once those are off, you should have a much easier time.

1 Like

Well, I did as @HazedBlue told, and it’s true. Very stable and smooth. I’d say it´s as smooth as the better flights I had using Oculus App, if not better. I tryed to use ASW, but couldn’t see any difference. Is there a way to try reprojection with VD, or it´s for the G2 only? Anyone knows?

VD has its own brand of reprojection called synchronous spacewarp. Functions differently so there are advantages and disadvantages. ASW is only functional when going through the Oculus runtime, so you’ll want to enable SSpacewarp in the VD menu.

1 Like

Excellent! Thanks again, Nathaniel!

My pleasure!

Also, related development, and you have GOT to be kidding me with this one: I had not used Air Link since SU7, and tried it while sorting some things out yesterday. With SU7 installed, there is no more stutter with Air Link and ASW. Besides installing VD, I haven’t changed a single thing, but it is absolutely, without a doubt running better than it ever has been with virtually zero hitching.

1 Like