Warning: Your graphics device has encountered a problem

First thing to do is a clean install of Nvidia’s drivers preferably after performing a DDU. If the problem persists then a reinstall / repair of MSFS and/or Navigraph might be needed. At least for the time being empty or delete your MSFS rolling cache. Also if your graphics card is already factory overclocked the memory clock might need reducing a little.

1 Like

Already done mate. Old hand at this stuff:-) Card isnt overclocked. Could be just luck on that flight but we’ll see over the next few days.

Have Asobo said they are still looking into this or do they still think the problem is “solved” as indicated by Seedy in this thread?

Of course they are looking into it but it is sure to need collaboration with Nvidia and that means a lot of to-ing and fro-ing.

At least that’s what I think and ‘solved’ doesn’t mean anything except they have accepted there’s possibly a problem. Not Asobos fault, Zendesk have claimed that it’s baked into their software and can’t be changed.

I have done all of the above, and lowered the not overclocked speed of my GPU, and probably more, but ever since I closed out my flight with the Navigraph window detached, uninstalling that solves the problem, with the side effect of not having the Navigraph toolbar thingy. But even reinstalling it (ALL of ALL Navigraph apps, not just using the utility to ‘uninstall’ the toolbar thingy), it still crashes 100% of the time, at the exact moment I hit “fly now” when, in theory, that pop-up that I left detached would pop itself up like I left it.

It seems to be more related to “pop-up” and/or “pop out” sub-windows than Navigraph directly, though I wouldn’t bet the house on that.

If the issue is truly memory consumption then Asobo needs to add a VRAM consumption bar to the graphics options menu like some other games have (GTA V comes to mind). It needs to go red when your configured options exceed your VRAM and yellow when you get close.


The error occured at my system after replacement of my RTX 2070 by a RTX 4080. There are no addons installed. But the error only occured if frame generation was enabled within flight simulator, otherwise it run fine. Underclocking wasn’t a solution in my case. But a new installation of gpu driver with checked option “perform clean installation” did the trick in my case. Now the simulator runs perfectly again.

1 Like

Well, just tried another flight. Still with Navigraph removed and also with an undervolt and slight underclock. Got the crash again :frowning:

Only reason I bought the 4070ti is for MSFS and DLSS3.

Hope it’s not the frame insertion (as suggested above) that’s causing it.

It also a bit worrying that this this thread is still marked as “Solved”. It very definitely isn’t.

Just to add - the error code in the EventViewer is 0x80000003 (The Breakpoint error)

The error happened after I opened the GSX window. I wonder if it has anything to do with the popout mechanism. More testing

1 Like

I just replicated the problem by forgetting to reattach a detached window that caused my next attempted flight to crash. This time, however, it was the ATC window. So even though I got the same error for the same reason, unlike with the Navigraph window being detached, I was able to close the ATC window before hitting the “OK” button on the error screen which triggered the crash.

My next two attempts, first in safe mode and then not, worked properly.

I am absolutely convinced that detaching anything from the contiguous single-screen display can and always does (at least in my experience) cause this bug to trigger. The difference between the one I was able to ‘repair’ (the ATC window) and the one I was not (Navigraph) is that Navigraph is an add-on, whereas the ATC window is stock.

1 Like

What appears to have got rid of the error for me is turning off Frame Generation:-(

Not what you want to be doing when you’ve just splashed out on an over expensive card.

That sounds “solved” to me … well at least until you return there by accident :grin: :wink:

Jumping in here a couple of times a week to read topics that seem to master this bug. Still havent found one so I´m getting more and more unintrested in this sim. Sad to say that is…Before SU9 I loved this sim even though it was a little up and down due to different updates. But after SU9 (for me) its going down the drain…

Has anyone tried just switching to DX12 (beta)?

Without changing anything else, that seems to have resolved the issue for me. Although that still means there is an issue, lol.

What “it” refers to & cant be changed?

1 Like

I have used DX12 beta for a long time and have had absolutely no problems.


so… have my new system running. There are still strange issues with that gigabyte mainboard, but at least system runs now with a 40xx card without running direct into bsod ( with some workarounds ) - but anyway, thats not MSFS related.

What I want to mention is: also with the new system I not seen these popup till now. I noticed other little things related to the in-game vsync-setting ( and a 40xx card ), but no popup, no crash. Thus, completly new hardware, win11 now, and problem is still not reproducable.

Happy new Hardware,

sometimes i wonder why we cant electricate this bug such we do with the other bugs, LOL.

1 Like

Has anybody tested this?

Set your sound device (in the sound settings) to a specific device.
DO NOT USE system default. Set a specific device in both options.

I did, it does not solve the problem for me. The only thing that woks is to switch HAGS (and frame generation) off. But that is not why I bought a rtx4090 for!

1 Like

I have to ask, why do you want HAGS on?

It’s been being recommend both on and off since it’s inception in 2004

In newer testing like 3 out of 40 games do better with HAGS on (maximum of 7% for Wolfenstien Youngblood) but many games loose percentages, some upto 50%

I know it has a cool name and sounds like it does things you want but really usually it doesn’t.

Because he has a 4090 and you need HAGS on to use Frame generation

1 Like