Warning: Your graphics device has encountered a problem

I’m sorry this didn’t resolve your issue. We probably don’t have the same error. However were you able to identify the error which precedes the CTD of FS in the Windows event viewer. This is valuable information to know exactly the cause of the crash. Is everything okay in DX11?

1 Like


I think I found a reliable fix (hopefully works for you too).

I was getting this error every ■■■■■■■ session… Never had this issue before.

4090, 13900k 5.5ghz, 32gb 7200mhz ram, z790.

Using Reverb G2 v2 and always have played in VR without an issue.

SO ANYWAY DOWN TO THE FIX. ( after literally trying ■■■■■■■ everything since the world update.)

SWITCHED TO SIM WORLD 14 BETA having read there are a lot of bug fixes. BAM no problems at all. I just had an hour session and I toggled in and out of VR multiple times, as well used a window overlay to watch youtube in the cockpit. Before it would crash either in menu, on start, or in cockpit when i toggle out of VR (would have to start entire session in VR from menu for it to work).

Anyway thought I would share this in hopes that it helps you guys too!


Have now flown 5 sessions successfully without any hitch, where as before it would CTD with hung message every single time. Switching the world sim 14 beta 100% fixed the issue for me anyway.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?


Provide extra information to complete the original description of the issue:

Did all the steps as mentioned before, still doesn’t work.

Are you using DX12?


Are you using DLSS?


If relevant, provide additional screenshots/video:

I have an update.

Firstly, i found what was causing my sim to crash when i turned off the display. It was one of my USB devices. There are many posts on this specific as well, in terms of USB devices crashing the sim, hearing the disconnect sound, causing long freezes etc. For me it my headset so i have switched to a bluetooth one for the time being and so far so good.

Now regarding the error, i started getting it again and i think i found my problem. Despite thinking my undervolt/clock on my GPU was stable, well it wasn’t. That is what is causing this crash for me and i suspect that is what is causing it for a lot of people out there.

My advice if you have overclocked/undervolted etc. Be true to yourself, test the sim with it removed (yes your temps may be sky high and thermal throttle etc but see if it crashes)

Or run something better to test your clock such as timespy stress test and a timespy benchmark!

I came to this conclusion because the sim started crashing on what i thought was the most stable driver. After messing with my overclock for hours on end again i realised it wasn’t stable so i have re-tweaked the profile and now with ultra pre-set, lod at 300 on a 3090 and 787 going to/from heathrow, i am back to error free. I have also tried 2 different drives and both have been fine, though for performance i am now finding 536.99 to be good. I have yet to try the latest drives, i didn’t want to change too many things in case it crashed again but i am fairly sure that it was my GPU settings all long.

Again, if you have been messing, reset MSI, lower your settings to compensate, test for a little while!


I am very happy to know that everything is fine on your part now.
Thanks for sharing and I hope this can help many people.
As you say, all this has already been mentioned on other occasions but it is good to remember it and share the sensation of another user.
Thank you again for sharing and I hope and pray that this helps many more.
Happy flights!!!

1 Like