When will 1.13.16 be available for eastern USA?

I see the UK World Update in my Marketplace, but one cannot download it without the latest update. 1:44 EST here now and still no update!

What platform? Update was released some hour ago worldwide both platforms

Having the same issue. I think it might be a more fundamental problem. Same as some people had with Japan apparently:


Sent a ticket to Zendesk.

Using the MS Store, no Steam or disks.

Log out of the store and back in, see if that triggers the launcher update

Hey, was able to download the update from the Store, then launched the sim and it downloaded the update. But when you go to Marketplace inside the sim, the Buy and Buy & Download buttons are grayed out.

If I recall correctly; close the sim, log out of the xbox app, restart (optional but recommended), log back into the xbox app, start the sim. I belive this fixes it. Or that was another issue, in that case I’m sorry but I don’t know

Will give it a shot, appreciate the suggestion!

No dice…

I tried launching FS2020 multiple times with no luck, then I restarted my computer. When I went back into FS2020, I was told to go to the store and update, and the update was available.

I did not see the 1.13.16 Update in the Store, only the UK/Ireland, which requires 1.13.16. I still have only 1.12.13, tried signing out and back in with no luck either. Just wait I guess.

You have to download the current update through the Windows store, not the MSFS marketplace. Once that is done, open MSFS and update once you are notified to do so. After this is done, go to the marketplace and download the UK/Ireland update along with checking for any updates in your content manager. Once you have everything downloaded and installed, exit MSFS before starting any flights… That should take care of the update process.

Germany here. Can’t download the World Update because it keeps telling me that it needs version 1.13.16. but both the Microsoft Store and the Update Check when starting the sim come up empty. No update possible.

Updated through the store, and if I go to Marketplace the Buy and Buy & Download buttons are grayed out. Can’t click them.

I know you tried logging out of the xbox app, but did you also try logging out in MSFS and signing back in after restarting MSFS?

Restarting Windows did it for me. After doing so the update was prompted. Strange.

Mine worked fine when I started about 11am CT. But the speeds were atrocious after a while. Maybe they locked out some people who jumped in later in the day to keep the servers from exploding?

That did the trick. For others, do a Restart to your PC, then load MSFS.

1 Like