White dot constant for Xbox controller on a pc

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Brief description of the issue:
The problem is that there is a constant white dot when we look around in the cockpit . This is when we use a Xbox controller in the pc version.
It may look helpful to know where the centre is but it’s more distracting than helpful. Prior to su11 beta we could remove it by pressing a dpad button.
Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hello,
As you are reporting an unexpected change that happened, please don’t use General Discussion. I have moved your topic.

This has been a problem for many months. Surely an option to turn it off doesn’t require ages to find a solution. Most bizarre.

2 Likes

Hi there I have just tested this out myself on the first load into the hanger screen the white dot will be showing, but when you press on the d pad controls the white mouse cursor should vanish, Also im using the the legacy option for cockpit interactions system, Also if you scroll down a bit further you will see D pad navigation I have that set to on by defult


3 Likes

Wow, thank you so much for the tip! It’s gone :smiley:

1 Like

Was having the same problem, i was able to “kill” the white dot by pressing Dpad but wasn’t working anymore since the update (XBOX)… Gonna try ANDY’s trick and see if it works for me. Thanks guys.

Edit: It seems like i don’t have access to the “Cockpit Interaction system” on Xbox, so if anyone find this topic, it’s not working for us Xbox simmers. Sad.

3 Likes

Came here just to post this issue, but on Xbox Series X. The white dot can’t be removed anymore! This is insanely frustrating.

What I found is that, if I press the left analog stick in order to deliberately show the cursor, and then press any directional button in order to hide it, it will finally be hidden. But the complete cursor will again show up immediately when moving the left analog stick to control the aircraft.

In other words, there’s no way to get rid of it!

2 Likes

We also don’t have the D button navigation setting, as shown above.

Being able to quickly navigate menus using directional button is great, but if this means I can’t get rid of the white dot, I really would personally prefer to completely disable this new feature without any doubt!

Please, Asobo, give us Xbox users these options too!

1 Like

I have found a workaround on Xbox to get rid of the white dot. I’ve created a topic about that. Take a look and give it a try! Definitely works for me!

I am sure that this is done due to the New Dpad / keyboard arrows navigation accessibility feature. And for this however nice feature I won’t be able to enjoy my flights.
Moreover today for some reason I can’t control the aircraft with the left analog stick, which does nothing now but with the dpad…
Why I mean why do they do that with the continuous introduction of new features that keep ruining our experience ? However this is a beta and I hope that they will read this post.

2 Likes

Dear Asobo this is with what we are flying constantly… Does this kill our immersion? What do you think?
My eyes keep watching the dot instead of anything else.

1 Like

Please add to title > “for Xbox controller on a PC”.

Thanks.

1 Like

I’m hugely surprised and also worried about how many few people are complaining here about this.

Maybe most even doesn’t know it’s possible to hide the white dot using directional button, so aren’t bothered now?

I can imagine even the developers themselves annoyed by this issue now, because it’s not only immersion breaking, but it also mess up directly the GAMEPLAY.

2 Likes

After su11 beta update its not possible to hide it with directional buttons…

1 Like

The issue persists even after 1.29.25.0 build update.

So frustrating.

1 Like

Hiding it is not a solution. Having to hide it every time you move camera etc. This is part of the whole immersion breaking experience.

It’s needs to stop appearing. Simple as.

1 Like

We need the dot for aiming at an instrument but this should be easily disabled with a simple toggle. I can’t believe it’s been like this since the game’s release.

It also appears in VR, if you move the mouse and then your head, you’ll end up with a huge white dot on the middle of the face.

Please Asobo, do something about it.

2 Likes

Yes. The thing is, although there’s the workaround described either here on in another thread, as soon as you interact with the cockpit with the mouse, the white dot reappears. Being on a PC, using the mouse for switches and knobs is a lot more precise than with the controller.

2 Likes

Absolutely.

And the dot is always in the centre of the screen. It’s really not “needed”. You know where the centre of your screen is hopefully.

But anyway. Just please allow us the option to turn the thing off.

That is all.

1 Like

Don’t remove the feature…just give the option to use or not…

2 Likes