Why is the localizer not holding on ILS

Today approach on EBBR and EHAM.
Both where capturing the ILS perfectly !!!
But both approaches where not able to hold the LOC at all…
Is it me …
It drives me crazy
Any Idea ?


Do you have some screenshots? wich runway? wich aircraft? At some airports the LOC has an offset, some airports are buggy with LOCs offsets of a few miles.

Edit: No standard offsets at EBBR and EHAM.

At the last screenshot you can see its loosing the localizer.

The test scenario and issues I wrote here.
Tried again this morming same again.

1 Like

This has been an issue, we have been reporting on, on here since launch. Certain airfields, even though they have ILS don’t seem to function properly. Or at all. This is also the same for ATC who don’t talk out of some airfileds either. I put in a complaint to Zendesk and that now is ‘solved.’ When very obviously it is not.

Tried again EHAM.
The closer you get to the airport the more the purple diamond drifts to the right landing the A320N left of the runway.

The glideslope however works correct.

Best chance for you is a zendesk report.

I’ve filed 2.

The first was about the “cockpit poltergeist” that activates stuff randomly. They closed it and marked it as “Solved” immediately. Yet this problem is NOT solved and still plagues many of us.

The second was about another issue with the last patch 6 days ago. It hasn’t been looked at or acknowledged yet.

So yeah, I’m not overly optimistic about the effectiveness of filing a ticket.

Well I tried another Airport LOWW ILS29.

Capturing the glideslope perfectly (and holding the glideslope)
Capturing the localizer perfectly.

And again coming closer to the airfield the purple diamond (LOC) is drifting to the right !!!
Ending up on the left side of the runway. (again left side)

What I am doing wrong… It drives me nuts…

See images:

If you try to land using ILS24 at CYTR (Canadian Forces Base Trenton), it will bring you down on the taxiway instead of the runway running parallel to it.

First time I did this was low vis during a storm. THought perhaps I had done something wrong so went and tried it again. And yeah, it wasn’t me. The airfield is messed up.

Was the purple diamond also off center?

Everything was as it was supposed to be. ILS landing looked great. Course was correct according to the approach plate. But it takes me down on the taxiway.

It’s not the only one I found. If you follow the RNAV glide path on one nearby airport, it touches you down about 1 mile past the end of the runway in the middle of Lake Ontario.

They still have some issues to iron out in this game.

Maybe someone is able to see on the latest screenshots (ILS on EBBR) if it’s me doing something wrong.

EHAM ILS 18C / 18R

I don’t believe al those airports are not correct.
So it must be me.
But I have no idea.

See page two from this topic:


I’m wondering if this airport may have had a runway change in recent years where that taxiway used to be a runway and that the sim is using old data for ILS.

I’ve found data that’s at least 10 years old in terms of satellite imagery in my area. I know the 2 aren’t related directly, but still wondering if this could be the case for airport data as well where they got their hands on some out of date data.

Could be.
But I have the same issues for example on:

EHAM and EBBR etc…
I am out of ideas

According to Wikipedia…

" The third runway is planned to be parallel to and south of the existing runway 11/29. It will be designated 11R/29L, with the existing runway being renamed 11L/29R. The new runway is planned to be 3680 m long and 60 m wide, and equipped with a category III [instrument landing system]"

This happened in 2018. So if MS / Asobo’s data is more than 2 years old, that could explain the issue.

Perhaps you could check it out for the other airports.

Thanks for helping me.

However I see this also at EHAM and EBBR for example.
Other don’t have these issues (not capturing the LOC) at EBBR or EHAM

The isturments also shows that I am on the left side of the runway (see images I posted on avsim)
It’s just not responding to the LOC at all it seems

Nothing helps.
Will do a fresh install of FS2020 (8 x DvD’s) etc…
if it’s still the same after the fresh install then I give up.

Maybe go back to P3D or just try in a couple of months.

I tried almost every airport in the EU with Cat III ILS and never ever the LOC is captured at all.
Glideslope is

How about just installing from the online installer instead of DVDs. Regardless, you’re still going to have to download all the updates, etc which will be almost as big as what’s on those discs. You could just install the most current buggy code once this way, rather than installing buggy code and then patching it with more buggy code.

You do know that “solved” doesn’t mean it’s fixed.
Per the FAQ
Ticket Statuses Explained (Bug Reports)

Open: The report is in the queue. A bug report will remain open until it’s updated or marked as solved.
Awaiting your reply: Our team contacted you to request more information and is waiting for your reply.
Solved: The bug report has been handled—our team has recorded the bug in our internal bug and issue tracker. Please note this does not mean you will see the bug fixed in the next update, but has been recorded and prioritized accordingly.

I reported bugs and you closed the ticket but the bug isn’t solved in the sim, why?

Because bugs and issues are tracked in our internal tracker, the status of your ticket does not necessarily reflect the status of the bug in-game. For a list of bug fixes, please refer to the patch notes.

1 Like

Well when flight dynamics are set on legacy (instead of modern) the ILS approach and LOC capture are perfect.
However when flaps are set the plane wants to go to the moon…(Will climb as an idiot)

I will just stop testing and playing for now.
Will check in a month and see what is fixed