Win 11 Update causing stutters?

Thanks for posting this. will give it a try and report back…
Wait. is this the graphics driver or geforce experience software? I don’t use or run GeForce experience.

I don’t use VR and am experiencing something similar. I’m getting 70fps looking straight ahead. as soon as i turn my head to looks left or right, fps drops to lke 5fps and it’s a slide show till i freeze my head, then the fps goes back up as long as I’m still. I use trackhat. Or the same thing happens when i right click mouse to look around. instant stutter slide show.

IT WORKED!!.. No idea how. I don’t even use g-force experience. I loaded the beta up amd my stutters are gone. Back to butter. It must be disabling some sort of gpu feature that was causing the issue.

I tried the Studiodriver and it kinda worked in VR. Didnt have to shut down the Holographicshell anymore to get rid of stutters, but Studidriver introduced lots of stutters in Edge browser when scrolling on web pages.

What surprises and annoys me is that I, and others, who were then in the Windows 11 beta program came across and reported this stutter problem when we updated to 22H2 beta back in March …6 months ago … so I assume the problem wasn’t even looked at by MS and/or Nvidia until now.

Totally agree, it’s an absolute shambles that it hasn’t been address, insiders have been reporting this for 5 months.

I can confirm that MatalaWedge’s advice worked for me as well.

Downgrading from 22H2 to 21H2 did fix the stuttering issue for me, but then I decided to see what would happen if I installed the nVidia Studio Driver (rather than the Game Ready version, which is what I’ve always used previously). I then subsequently re-upgraded to 22H2.

I’m very happy to report that 22H2 now runs fine, no stutters, and I’m even giving DX12 (beta) a try as well, which also seems to be performing quite well on my system.

Thank you for the tip, MatalaWedge - everyone should give the nVidia Studio Driver a try!

PS - I’ve only tested with the PMDG 738 so far …

Where can I switch off the nVidia game overlay?
Is this the option find in Steam Settings for the game? Or do I switch this off somewhere else?

My problems caused by the windows update 22H2 were fixed by the new Nvidia driver GR 517.48. i9-9900K, 32 GB Ram, RTX 2060 Super mit 8 GB VRAM, DX11, DLSS, Reverb G2

1 Like

Yes, after this update i face the same problems

You need to go in GeForce Experience and on the little wheel on the top right corner. Then you can deactivate the overlay functionality

1 Like

Several days ago I experienced significant stuttering in VR with 22H2 update. I then went back to the previous build and all was well. After reading about the Nvidia driver update, I decided to try it. The updated driver worked fine with the 21H2 windows 11. I then updated to 22H2. The stuttering is back, not quite as bad but not very happy. So I returned to 21H2.

Beware , on my system anyway, the problem persists.

1 Like

Exactly the same experience with my 3080TI, 5800X. Maybe it is time to go back to Windows 10…

Update: disabling HolographicShell cured it for 22H2 and new GR drivers…for now

1 Like

The 517.48 driver did not resolve the problem for me. Still stutters with DX11 if HolographicShell trace is running. DX12 is fine.

1 Like

Hey guys,

I was searching everywhere since I had extreme stutters with an AMD 5800X3D and 3090ti, recent drivers, and windows update installed.

I have disabled the Nvidia Game Overlay and that fixed it for me, in VR and 2D, now I am enjoying DX12 with DLSS and works like a charm.

1 Like

So that means, people without Geforce installed are not affected already?

Ou yes, we are very affected, worst laggy than never, and without having Geforce Experience, how does we disable Nvidia Game Overlay?

How to Disable or Turn Off the GeForce Overlay on Windows.


I repeat, without Geforce Experience installed, how do I disable the Overlay? how do I solve the giant stutters and lag? I do not want to install that bloatware, thanks.

This is in VR or flaterth.

Apart I am reverting to the former W11 version with a full OS backup with Easeus TODO.

If you don’t have GeForce Experience installed, what overlay are you even talking about. I didn’t think it was possible to have that without GE being installed to be honest.