Wireless Mouse Works - Until it Doesn't

I’m hoping someone can help with a mouse issue I’m having. I’m on Xbox Series X, and have connected a wireless Logitech mouse. Everything works okay at startup, but I soon lose my cursor and can’t select anything. In a cockpit, I can still hold the right button and move the camera around, but I can’t select anything on the instrument panel because there is no cursor, so it IS recognizing the mouse.

Any ideas? Being able to move the camera around is a huge improvement to the limited camera movement with my Hotas, but if I can’t select anything in the cockpit, it’s useless.

I do have a Hotas One connected to the front USB port, and a controller charging station plugged into the second USB port in the back.

I have the Logitech M575 Bluetooth wireless mouse. All the time cursor disappears after 2-3 seconds, constantly using the CTRL key to get cursor back. Mine is supposed to self-calibrate, but that takes a day or so, control was in beginning horrible, it’s better now. Windows has setting for mouse checkbox to use CTRL key to get cursor back. Logitech SW writes over the windows settings. Don’t remember how it was in Windows 11, ASUS keyboard then was issue. Going to wait 6 months before W11. Like the mouse but hate the software. Filled a support ticket on the configuration/control issue, nothing on the cursor disappearing after 3 seconds. And spell check has also changed. In MS programs, right click on misspelled word, to get list of correct ones, in every other website, it’s the left mouse button, not sure if it’s a window or Logitech issue. PIA.

Is this what you are experiencing?

Just jump out of the game to another, then quick resume and it will come back. Works for my Logitech the odd occasion it disappears

Thanks to everyone for your replies. I tried moving the unifying receiver to the front USB slot and my Hotas to the back. I flew around for 20 minutes or so to test it out and it worked okay until I exited out to the menus, at which point I lost the cursor. I had to turn on the Xbox controller to finish exiting the game.

@TONYDARKZERO Thanks, I’ll try this out tonight.

I also have a wireless mouse - two in fact - mouse issues come and go. I found that quitting the game and re-stating is the ‘best’ way to get back a ‘frozen’ mouse.

Still having issues with both wired and wireless mouse not being able to be used. Cursor is visible and moves, but mouse does not respond to clicks. Anyone else with this same issue and any fixes? I tried start/restart and all the others resolutions but no joy with anything. Thanks in advance.

Experienced this last night. For the first time, it didn’t respond positively to any of the fixes that worked before. I ended up turning off the sim and had a double whiskey.

Yeah, I’ve been having this with my wired mouse since the last update. I found that waiting a few minutes (few = varies) the application will eventually respond to mouse events. Seems to me like the application is “busy” doing other things and won’t give the mouse the time of day during initial startup. However, once inside the cockpit of an aircraft, this is no longer an issue. Very annoying.