Working Title CJ4 Discussion Thread

Hi all,

Feel free to post here about the Working Title CJ4 FMS available from the links below.

You can find us on our Discord at Working Title Simulations

Available from the Working Title Aero Site:

https://www.workingtitle.aero/packages/cj4/

or

Github:

This version remains an Open Beta, so you may encounter issues. Please report any issues you find to our GitHub issues page.

Feature Demonstration Videos

FROM Waypoint Edit & Interception - Working Title CJ4 FROM Waypoint Edit and Interception - YouTube
Lat/Lon Entry - Working Title CJ4 Latitude and Longitude Entry - YouTube
Point Bearing Distance Waypoints - Working Title CJ4 Point Bearing Distance Waypoints - YouTube
Along-Track Offset Waypoints- Working Title CJ4 Along-Track Offset Waypoints - YouTube
Holds - Working Title CJ4 Holding Procedures - YouTube

New Operator’s Guide

We have a new 36 page WIP Operator’s Guide, available here: Working Title CJ4 User Guide v0.12.13 - Google Docs

Special thanks to all our awesome folks on the QA team (Slip, Sean, dihedral, Windhover, Blanco) for their amazing contributions.

Installation

Installation is easy, simply copy the workingtitle-aircraft-cj4 folder inside the zip file to your MSFS Community folder.

Important: We recommend that you fully delete the previous workingtitle-aircraft-cj4 folder before copying this release.

Default Livery Conflicts

The alternate default liveries that now ship with MSFS are not compatible with the CJ4 yet at this time. They currently ship with panel.cfg files that do not include our FADEC module. Please use the standard livery or a known compatible 3rd party or community livery.

Remarks to flight plan synchronization between the Game and FMS

The FP SYNC option is one way: it updates the simulator flight plan from the FMC. To load a plan into the FMS you can either enter it manually or use the FPLN RECALL (GAME/SB) option in IDX → PAGE2 → ROUTE MENU

Due to the increased accuracy and capabilities of the FMC managed flight plan, you may find that the sync to the game does not always work as expected or does not reflect the FMC flight plan exactly.

KEY FEATURES

  • Added Cross Pointers flight director
  • Flight director now works with AP off, including lateral guidance
  • Added Takeoff Go-Around (TOGA) mode
  • Holds functionality and autopilot, including proper entry types and exit arming
  • Course intercept, Point/Bearing/Distance fixes, Point/Distance fixes, Lat/Lon fixes
  • Completely overhauled Flight Model (WIP) (Credit: Metzgergva)
  • Com 2 can now be used to transmit and receive.

Mod Edit: cleaned up notes, title and revised links to latest versions.

26 Likes

hello anybody can give me a hand on figuring out why i cant see the cj4 even tho its in the contents? default or the mod

Have you Liveries installed? Just disable them. Most likly they have a old panel.cfg that could brake the whole thing and it won´t show up.

I have no Radios, anyone else having issues?

I’ve got my throttle mapped to my X-56 but the actual levers in VR cockpit don’t move but the throttle is working.

Just made a flight from LMML to LSZH, everything worked perfect, took the default livery.
Thank you for this perfect mod!
regards

All radios there. Press the TUN button on the CDU (FMS) to set them.

I had CTDs until using 0.8.3b-Beta6. Should I stay with B6 for the moment or should I try 0.9.0?

Same issue here with the Honeycomb Bravo

0.8.3 CTD a lot, try 0.9.0.
I tried 2 flights and have no problems.

Hi both,

Please ensure you are using a compatible livery. Many liveries ship with a panel.cfg that overwrites our FADEC, rendering the throttles unresponsive as you describe.

-Matt

1 Like

Ah ok, flew in the new MSFS livery. So apparently that one does not support it. Thanks!

Anyone know why I can’t seem to get Vspeeds to calculate? I have the departure runway entered as well as wind.

I probably was very unlucky with wording: Radios are here and show up in FMS, but they have no power, so I cannot tune or talk to ATC via ATC UI Window.

This happened to me yesterday. I had not completed the DEP/ARR page on the FMC.

Make sure the avionics switch is on (up) and not in Dispatch (down). In Dispatch only com1 works.

I just want to say a quick thank you! Did two flights - no problems :slight_smile: The holding function and the possibility to define waypoints is a huge step! Also, that the appropriate entry procedure into the holding is detected and executed, is fantastic!

Has nothing to do with the avionics switch. If it’s on, ATC still doesn’t work. It’s a bug. They’ve acknowledged in on their Discord.

Ok, just a thought.

Does the problem only occur with in game ATC, or also when flying on Vatsim?