X52 - impossible to invert Z/throttle axis

Hi when i try to invert my Z axis it doesn’t apply even after saving.


Seems good on my X55 - have you tried to unbind it, save, restart game and bind again?

yeah all of that i tried to plug/unplug, restart game / pc, when i apply the invert on the axis it indicate that its working correctly but after saving and coming back on the menu or in a session the axis aren’t inverted.

I have the X52 also and it was a bit of a pain to set up in the Alpha (I’m going to have to do it all again in a few hours after it downloads). If you go to “Game Controller Settings” in the OS, does it work correctly? I ended up uninstalling all the Saitek software and it worked when I used the standard windows driver etc.

yeah the throttle axis is working correctly, just when i push forward it’s at 0% and backward at 100%, and in game i can’t invert the axis, i didn’t find any way to invert it with the X-52 software or on windows, otherwise everything seem ok so far. it’s just a bit hard to fly with inverted gas :frowning:

I’ll need to check it once my download is finished, (4 hours) but I did have it working in the Alpha and Beta. I’ll check in the morning and let you know.

I’m having the same problem with my logitech g pro flight throttle quadrant. It will work fine in the configurator, I save it and go back to my flight and poof it reverts back to the original setting.

Same issue with Saitek Throttle Quadrant. I can set it to invert in settings and it works fine. Apply and save and switch to a different controller config tab and come back and the invert no longer applies.
This happens anytime I try to invert any axis on any controller

1 Like

I filed a bug last night but I’m also having this problem with the X52.

1 Like

Glad that i am not the only one with this issue, if you guys found a solution, or have an answer from the support team feel free to share your info here, i don’t think it’s hardware related but that the invert config isn’t saved correctly.

1 Like

Did you guys found a solution or had an answer from the support ?

the reverse Z axis still not working for me it checked the box but doesn’t have effect, only solution i found is to physically put the throttle in the other direction …

Ye I got it working, ill show you how when I get home!


Hi all - I’ve got an X52 and none of the defaults are showing for me so I’ll have to setup the whole thing from scratch. Can anyone list their recommended layout for me…? I’m stumped as to where to put everything and would love to have a tried and tested layout.

Much appreciated

SilvRav - I am also use the X55 and battle with the sensitivity setup - Is there a problem with it because I can’t get to work - it is the stick an the throttle.

oh thx if it works i just pass 4 hour tryin to change the registry with no sucess :frowning:

i also tried to find where the binding file is but without any success.

well you should bind what suit you but basic stuff are :

joystic axis to go up down left right and rudder

throtlle for gas

upper left hat on joystick for trim(UP and down nose and left right trim)
center stick hat are camera setting (put what suit you)
“C button” is used for landing camera
and then i bind the lower switch on the bottom of the stick for flap landing gear and parking break

i use a button on the throttle for break
and use the slider on the throttle to enable reverse throttle

you still have some button left for whatever you want (spoiler etc…)

1 Like

See this I posted recently:


thanks for the tip, i don’t find the input folder in my directory (Microsoft store installation), but i don’t know if it’s the same issue, our joy seem to be recognize normally and work perfectly we just cannot revert axes :confused:

Mine seems all good. Are you using the in game or windows setup?

this is how i got my x52 fine