X52 PRO - Predefined setup

The standard X52 PRO predefined setup was working perfectly on my first flight, but now has vanished when I went to make a few adjustments and I’ll need to populate it again. Does anyone have a profile they can share?

Also setting everything back to default still leaves the predefined setup blank.



I have the same issue, default bindings are blank. Not sure where they are stored either, tried re-installing which took 90 minutes and the bindings are still blank :frowning:

1 Like

same issue

1 Like

Ok, lets fill out some bug reports

1 Like

I have the X52 basic (non pro), so assume I am going to have the same issue

I’ve opened a ticket on Zendesk.

Me too. No pre set buttons.

When I tried to configure on my own, there is no gradual moves, its either off or on.

X52 original (blue)

1 Like

I’ve tried the old turn it off and back on again, uninstall and reinstall of both game, Saitek software and drivers. I’m going to assume this is a day 1 bug they will patch or give guidance on soon.

I have a problem with my X52 pro bindings not being visible / configurable at all.
It still recognizes that I have X52 (new, logitech one) but the bindings are not there.
I tried to tinker with the config xml files in the input folder but I’m getting access denied messages on them. I have a game pass version of the sim.

1 Like

Thank God it’s not just me, I was about to lose my mind. Keyboard and mouse for me I guess

1 Like

yep same here!

yea same here its annoying

How was this not fixed if it was an alpha thing aswell? seriously?


Same here.

X52 Pro here.
Default bindings are blank but I can configure it fine manually. Still annoying.


Same issue X52 Pro

1 Like

I have to confirm the same issue with my X52 Pro Hotas :frowning:

And again with the X52Pro

Joystick is detected but bindings are blank :frowning:

Are they just filtered to show only assigned? I have no default bindings, but I’m able to assign them on my x52 pro.