Xbox: Xbox controller in Cursor Mode controlling the aircraft?

nop. Still there.

Juan, it works for me now. I can now use the cursor to adjust the instruments and controls in all the cockpit views without the stick movements also being applied to the aircraft control surfaces.

The issue is still present for me, instrument view cursor mode still manipulates the control surfaces.

Well, then it would be interesting to know what is different in my configuration. Because if I put the view on “panel view” (RB + cross down/right) and in cursor mode, when I move the left stick, the airplane elevator and ailerons, moves at the same time.

I believe you guys so I don’t know how I got so lucky because its definitely fixed for me after the updates. My FS version is “premium deluxe” and after the main update, I saw it do updates for that above the standard update. There were also many scenery updates that dropped at the same time which I did but I don’t that would have any relevance. The only other thing I can think of is try deleting your rolling cache and recreating it. I always used to get weird behavior in updates due to the rolling cache. I’ve learned to delete it and disable it before applying any updates and then re-create it after the updates have completed. Good luck.

I don’t have mods (xbox player) and have the rolling cache disabled since SU7. It has to be something else.

with me the error was also not fixed with sux. the curious thing is that it happens sporadically. i can do things in the cockpit for minutes (concorde) without problems and then all of a sudden “bang” the plane drifts in one direction. i must first click in the “space” so that the plane comes back on track

“when I move the left stick, the airplane elevator and ailerons, moves at the same time.”

Juan, I am not at home to where I can try this but I am pretty sure I use the “right stick” to move the cursor? Left stick press to go in and out of cursor mode and right stick to move the cursor. Not totally sure - I will try tonight when I get home.

mmmm interesting. Did you move the cursor with the right stick (while the camera stills on position) or you move the camera with the right stick (and the cursor stills on position)?

Because the second one is the work arround we have beind using. Lets see when you check at home.

Nope sorry, you are right. I forgot the right stick is what rotates the camera around. So yeah, I use the left stick to move the cursor and the bug is fixed for me. Still not sure how I got lucky? Maybe it works in some aircraft but not others? I almost always fly the A320 and I think that is the only aircraft I’ve been using since the update. Someone above mentioned that it is fixed for him in the Concorde but re-appears after “minutes.” That might explain why I don’t see the problem because I am usually popping into cursor mode to adjust an altitude or speed setting or make some other quick adjustments and then I pop back out so I would never get to see if the problem starts re-appearing minutes later.

See:

1 Like

Juan, I’m curious, what plane are you flying to try this? Wondering if some planes work now and some don’t?

Never used to happen to me, but after SU10, it certainly does now, in all the aircraft I’ve tried(A320, A321, A319, King Air, Embraer 170-195)got to be a update bug for xbox…

Sorry for the delayed response. It happens with any plane, I have tried recently with: C172, C208, A320.
All Asobo airplanes, no mods (XBOX series X).

This bug on XboX was one of the reasons I have dropped this game around year ago.
I reinstalled it yesterday and this bug is still there.

I enjoy flying manually but everytime I set all things (speed, trim, height etc.) on my plane and then enter cursor mode to check map or change something, then SI replace all my plane settings with some random stufdf. I said random because plane starts to acting VERY weird.

There is even a message pop up on screen when you first time (after game installation I guess) switch to cursor mode that from now on SI will take over a plane. So it’s definitely there and this is default game behaviour.
Please fix this problem.

I’m assuming SI is an autocorrected or mistyped AI?

Have you just tried turning all the AI and Assistances in the sim completely off? What you’re describing, specifically, sounds like the “AI Piloting in Cursor Mode” is on, which I believe is so by default.

Honestly, when I first got the sim I turned all that AI business off. I cannot see the point of any of it (unless you need help due to accessibility limitations), and as you describe it makes a mess of your flight.

I would tell anyone starting out with the sim to just learn to fly the aircraft without any of the AI/assistance affecting the aircraft’s controls. Sure, use the AI to give you taxi ribbons or, if you’re a real beginner, the landing path in the sky, but leave all the AI concerned with actual control of the plane off.

This is just one of many bugs which still exists since the release of the Console version. Another extreme annoying bug is the intstrument view, where you can’t move to the previous/next insturment with the DPad Lef/Right. This will move the camera out of the Instrument view and does a fast looking right/left, instead moving the instrument view to the next instruments as documented.

It’s a shame they don’t fix this annoying bugs and give any attention to the console users with gamepad.

1 Like