Stutters again!

The last update gave us a smooth sim = happy. This new patch has ruined this = unhappy. Jolly old stutters again !


Continuing the discussion from Stutters again!:

The same … yesterday 50FPS … this morning it is updated and does not exceed 20fps.


i went from 39 - 40 to 48-50 FPS on a gtx1080Ti with 3 screens 5910x1080

1 Like

I’m not looking at the frame rate but I have the stutters after the patch. GForce RTX 2080S.

i’m testing with first flight while i type , no stutters at all , so far…
did have sound failure 2 times…

I read in other posts on this forum that people seem to get stutters depending on the time of day. Could this be the case in your case as well?

That’s interesting. Will monitor this. Before this patch is was reliably smooth.

Confirmed … in a while it returned to normal.

Performance gone right down for me after this latest patch.

1 Like

I posted in the general 1.15.8 topic that I’m still getting that weird micro stuttering, almost once per second, even with FPS of 45.
It does to me seem related to multi-player, as I could see a gamertag flickering, and bizarrely in time with the stutters.
Just one tag. All other tags seemed to be ok.
The thing I noticed is that this flickering tag was also showing the player’s model and altitude. The others weren’t.

Once their aircraft went ‘far enough away?’ (after about 5 minutes) the flickering stopped and so did the micro stutters.

I see lots of players around, but they have no altitude details, and I have no micro stutters.

Related? Guess work? Coincidence? Who knows!

1 Like

Seems it is related:

I had to change my vsync setting in nvidia control panel from force off to force on. Stutters gone.


Stutters returned after latest updates for me too and been trying to adjust them out with no real success. I tried the forcing V-sync ON in NVIDIA control panel with V-sync ON at 60fps in the sim and this was an instant fix for me too. Been turning things back up and still running smooth on mostly ultra settings. When sim, NVIDIA and Windows updates all happen at same time it’s sometimes hard to discern what caused what.


The same here, i have an LG 34in wide monitor 144hz, I turned off the FreeSync/G-Sync on the display software control and it helped, flying without any lag in multiplayer mode and all my graphic settings still being the same.
Let´s see what the future reserves now.

Temporary solution: Disable MULTIPLAYER functionality

1 Like

Yep stutters for me since the last patch as well! Nice and smooth before!

1 Like

While photogrammetry is on when you fly towards the city seeing the skyline of it reduce the slider in graphics ui msfs of the terrain back to 150 or less, and detail slider to 100 or less when entertainment the skies around or above the city photogrammetry loads in faster with less apocalyptic looks and less stutters and smoothness.
Unfortunately for cranes and some objects they don’t load so well, but i think they should be replaced
For me this method is acceptable. It was even possible for me to performance a stutter free looping with good acceleration and decelleration.
This was above London.

I mean give it a try and send some reply

My frame rate is okay, even around (and inside) Class B airspace. No stutters to speak of.

What I do get are solid three-to-five second freezes: the screen freezes solid and the sound stutters badly. In the past this behavior was almost always followed by a CTD event. Now, it sorts itself out and returns to “normal.”

No flights have been longer than three hours so far - all in the Mooney and this morning in the C182T - but all have been into or around Class B airspace. (KSFO, KSAN, KPHX) Even landing, with dense traffic - both on the ground and in the pattern - has been smooth.

Ya, something is definitly wrong. This solid every 2-seconds freezes never happened before.
Before version 1.15.7 all was smooth. Have not flown on V1.15.7. Spent today some time on V1.15.8.
I was probably a little to eager posting that enabling/disabling dev mode helped. It seemed to be the solution in the first flight today (Take off from EDLP) It did not help in the next flights (Paris). Hence the withdrawal of my first post. Enabling/disabling V-Sync did not help. Not going to tweak the sim (All on Ultra and it stays that way) or look into the radeon driver.


That is my guess as well