1.29.30.0 "Missing Essential Packages"

I did the update and now when I launch I can’t get passed this. Launcher is build 1.29.30.0.

I’ve seen a few others on the Discord community support channel also now starting to get this issue.

Anyone else?

MS Store PC user.

Several people are having this issue including myself. Don’t think it’s anything on our end.

There are a couple of other threads if you do a search for it. Here’s a link to the one I have been looking at.

1 Like

Thanks it was after I did a clean install and did the beta update so thought it was related to that but seems more widespread. Cheers!

Hi everyone,

I’m trying to collect more information to help Asobo troubleshoot this issue. Am I understanding correctly that it is only occurring for new, fresh installs? Has anyone gotten this error when updating an existing MSFS installation?

Thanks,
MSFS Team

1 Like

Hi Seedy,

I did a clean install of my simulator, and I’m in the beta via Insider Hub. So the initial install was the base sim, and it loaded up to the menu just fine and then it detected the new beta build 1.29.30.0 and said I should quit to update.

After doing so, I downloaded the launcher update from the MS Store/Xbox App and upon launching it prompted the roughly 1.4GB sim update. It was after this point that every time I try and launch it I get the error.

So, I’m not certain it’s solely beta related, but yes, I did do a clean sim install early this morning (via MS Store).

Cheers!

That was my experience.

Everything was fine until FS started updating to the latest beta build. Once it had finally completed and loaded into the sim the first time I got the error.

Did a clean reinstall and same situation.

Doing a 2nd clean install, will be done in a short while, I’ll let you know if anything changes.

Hi Seedy,

I did a test and removed a folder from the Official folder. It allowed the sim to boot up, and gave me the option to install the missing package or ignore (this is at the main sim menu). Clicking ignore allows you to sim without issue (in my case I had removed the Caravan folder from Official). However, clicking install will take you back to the checking for updates missing essential packages screen.

So, if I’m understanding correctly, it seems to be something in the download/install process that’s having a hiccup.

Cheers

I can confirm this, removed a folder cited in another thread and was able to load into the sim, but once into the UI it asked for the mandatory update again and forced me to quit.

For what it’s worth, I just finished a second reinstall. No change in the error status.

Might be totally unrelated but I’ll pass it along anyway. After the install finished and I got into the UI I was met with the Essential Packages missing error as before.

This time I chose the Install Later option instead of the Update option. I then loaded into a flight at KATL. Once in I noticed that there was a lot of AI traffic. Went into settings and RealTime Air Traffic was turned on (I had it off) and the Ground Density slider was set to 50.

I turned off the traffic and set the slide back to 0. Resumed the flight but the AI was still there. Restarted the flight and no change. The AI was still active (I did recheck the options and they were Off and 0).

Jumped out and closed the sim. Restarted and now it is requiring the update and forcing a quit as before.

Just thought I’d put it out there.

Thank God i wasnt the only one with this issue :')

A post was split to a new topic: Latest Beta Versions Installing and Working Well

same error message here

Ensure you have read the banner at the top of the forum page!

My install was working fine. I had msfs installed in a 2nd drive. I needed that drive for something else, so I formatted it and attempted to install on a new drive and like everyone else I received the error. I have completed a new fresh installation of Windows and was going attempt a reinstall of msfs again.
That doesn’t look promising from reading the rest of the comments so I’m going to sit tight and wait.
One note : during my attempted “fixes” I uninstalled the Xbox app and now it won’t reinstall. I just keep getting there’s an error on our end try again

Hey all, (@SeedyL3205)

Not sure what information will help with this issue, but I’ve just encountered it.

I had just cloned my hard drive and changed to a 2TB SSD, on launch most of 40th Anniversary content was missing. All new aircraft minus the calibri heli.

I unenrolled from Beta, rebooted, went to MS store which downloaded (MS store) files. No change in sim, booted with no update required but some missing 40th Anniversary content.

I re-enrolled in beta, and downloaded (MS store) files again, rebooted, but still same issue.

The sim is installed in a custom path (C:\MSFS) and is MS store version.

To force update the sim I renamed the old OneStore folder to force the sim to re-download the missing files. After completing I then encountered the ‘Missing Essential Packages’ message.

It might be worth noting that I can’t repair the files through the windows settings menu either.

Not sure hardware stats helpful but just in case…

  • Intel i9-9900K on a Aorus Z390 I Pro Wifi motherboard
  • 32GB Corsair Vengeance Ram, 2x16, 3200mhz DDR4
  • RTX3070 Gigabyte, Eagle OC 8GB
  • Samsung 970 EVO Plus 2 TB PCIe NVMe M.2
  • 2x LG QHD Monitors, (27QN600)
  • Windows 11 22H2 22621.819

Happy to provide any other info, files lists, logs etc. I can also setup a remote desktop session for Devs if they want to interrogate a machine with the issue directly.

1 Like

Happening to me . Did a fresh pc build and windows 11, did a fresh install and this issue. I will just wait until we have a fix for this. Can you update us to when when we can update the sim or install it ? Thanks

Not sure if the issue has been officially resolved but the sim appears to be loading and working normally on my system this morning at least.

Thank you Asobo.

My sim is working again, however I don’t have any helipad scenery. Anyone know why?

Yes @SeedyL3205 ! Fresh installation and it is a big problem for us that are developing :smiley:

I checked the event viewer and i dont see anything inside.

If you want to run one shot (but after you ll have the same issue the next time you ll run the MSFS) is to delete a OneStore PAckage and re-run … but it is weird to do

I m also available for a Team Viewer session

I just tried to reinstall MSFS again. Now I get an error message in the MS Store.