A whole month of CTDs

Hi guys, I have been using MSFS since its beta version and had random CTD from time to time. Anyways, from the very end of December I am getting lots of CTDs (let’s say, I succeed in completing just 2 flights in 10!).
I have read a lot of posts regarding CTD and tried all the solution suggested by many of you, yet without any result. My CTD happen at any stage of the flight (taxing, taking off, cruising, approaching, taxing after landing!) and happen regardless of the 3rd party addons (happen also with totally empty Community folder) and of real time traffic and weather (happen also with preset weather and no AI traffic). I have no overclocking, I have updated and rolled back GPU drivers, disabled rolling cache, repaired the MSFS app, set English (USA) as my Windows default language, updated my Windows 10, increased my virtual memory pagefile. I really don’t know what to do next.

Here are my pc specs:
CPU: Intel® Core™ i7-7700K CPU @ 4.20GHz, 4201 Mhz, 4 Core(s), 8 Logical Processor(s)
OS: Microsoft Windows 10 Pro, 10.0.19042 Build 19042
RAM: 32 GB (4 x 8 GB DDR4 3200 Mhz)
GPU: NVIDIA GeForce GTX 1070
MB: ASRock Z270 Pro4
SSD: M2 500 GB (dedicated exclusively to MSFS)

Hope you can give me some new suggestion. Thanks in advance.

Not sure what eye candy you use but turning down Volumetric Clouds to medium solved my issues

Ok, I’ll give it a try. Thanks

who tell you that ?

Recommended is the EN Lang Pack, but you not need to set your PC to ENG :slight_smile:

You wrote “since a month”. So you mean “since 1.12.13.0”?
In case: have you already used the forum-search-function with this term ?

As Example checked already the network relevant settings ?

I might have misunderstood what Asobo suggested regarding language :slight_smile:

Yes, I’ve tried a lot of possible solutions. Anyways, I’ll try to read again the whole thread, I hope I missed something :wink:

hmmm… also tried the depicted other settings ( Text2Speach… ) ?

It’s of course a try and that you got allready CTD before 1.12.13.0 makes the differentiation not easier :slight_smile:

I assume with the 1070 you should use the latest nvidia drivers.
Related to overcloacking: dont forget that many users have issues with the RAM if XMP mode is enabled, thus a test without xmp-mode on might be it worth.

Hi, I’ve tried to investigate the XMP issue but can’t figure it out. In my bios, there is no option to activate or deactivate XMP, but just allows to create some sort of profiles. Here are a couple of pictures. How can I change those settings in order to optimize for MSFS? Thanks

141560793_915128025963134_2681812391007595515_n 141673748_2584393638519929_8342609297357182092_n

You should be able to reset to defaults in the exit menu (F10 I believe). Give that a try if you haven’t already and see if that works. Good luck!

I guess those are the default values…I’ve never changed anything in BIOS

Ah gotcha. There should be a way to turn off the XMP profile in the DRAM config or at the start screen of the BIOS. Worst case scenario, maybe resetting the CMOS by pulling the battery for 30 seconds and putting it back in may work.

Hi,

oh… it’s realy hard to see at the pictures.

It looks like (left image) you have choose “Profile 1” ( if the Light Blue is the selected ) which is not the XMP Profile ( what I can see :wink: ), thus should be fine. But I can be wrong… hard to see.

To be sure you can also re-check this with tools like CPU-Z . In it you can see the SPD profiles and the current memory settings.

If already no XMP mode, then we have to search issue on other side.

PS.: you can also see what the XMP mode try to do. It bring the memory out of JEDEC standard frequency 3200 and overvoltage the RAM from 1.2 -> 1.35V ( what my eyes guess from that picture )

Here are the settings applied by Profile 1:

Freq 3200
Voltage 1.35V
tCL 16
tRCD 18
tRP 18
tRAS 38
tRFC 560
tRRD_L 8
tRRD_S 6
fFAW 39

this is XMP_Profile_1 … if this is used you use XMP mode :slight_smile:

I thought the JEDED_Profile_1 is used ( 2666 ? ).

JEDEC is:
Freq 2133
Voltage 1.20V
tCL 15
tRCD 15
tRP 15
tRAS 36
tRFC 374
tRRD_L 6
tRRD_S 4
fFAW 23

the idea for the “test” is just to use a NONE-XMP-Profile.

I assume all Profiles with a voltage level of 1.20V are NONE-XMP-Profiles. Just choose from these JEDED Profiles the fastest and do a test run.

Or, if you not sure… please download and run CPU-Z and give us screenshots from SPD and memory tabs.

( do nothing within the BIOS if you are not sure )

Considering that there is no way to set XMP to OFF but just allows Profile 1 or Auto option, I set it to Auto. Here are the screenshots from CPU-Z

Screenshot (1106)

yes… it’s ON if you choose the XMP Profile :slight_smile:

But it looks like you use your RAM within the JEDEC Specs (DDR4-2133) and you not use XMP Profile. It is the 15clock setting, instead the 16clock but should be okay.

So… I assume no issue from this side… ( which is good, and not good together :wink: )

Let’s consider that before the Profile 1 setting was selected…so let’s hope that turning it to Auto will solve my CTD…let’s hope! :pray: :crossed_fingers:

What does the Windows event display show?

What kind of power supply? Is it running properly?

I’ve already heard about some of them have a BTD here and there, but I haven’t heard / seen anything as bad as yours.

There must be a bigger problem somewhere. It’s not the RAM, unless one of the bolts is defective? Hope you find a solution … I would set traffic to OFF, also no AI, and let’s see if it works better. When it was released, that helped me immediately and I ran out of BTDs. In the lost 4 months i have not one BTD.