A workaround for FPS drop after a long flight

I know some people include me have been experiencing sudden drop of FPS after one or two hour straight flying. Some says it’s because of the memory leak, inefficient memory management of this sim. Although recent SU 5 significantly improved the performance, FPS drop by just flying long time is still there for me.
Regard this, what I found is changing sound output from the VR headphone to the computer speaker rebounds the once slow-downed FPS again. To test longevity of this change, I kept flying two hours more and haven’t experienced the unusual slowdown again at that flight. I’m not sure my workaround can be effective for every similar case but it is simple and worth to try. My headset is Quest 2 and the connection is via a genuine Link cable.

1 Like

I’m experiencing this issues, will try. Thank you!

Thank you. I have experienced jittery motion after a few hours flight although I did not measure fps. Do you then switch the sound back to the headset or keep it on the computer?

I haven’t tried yet. I just kept that setting till the end of that flight. I changed it back to headphone on the main screen.

1 Like

OK thank you. I will bear it in mind.

I´m also experiencing this for the first time after SU5+HF2.

4.5 hours long flight from LIPZ to GCTS with the A32NX, latest developement version, and frame rate goes down to 15 fps.

Certainly, it is not because of a lack of resources: Ryzen 9 3900x, 64 GB RAM, RTX 3080 (40" 4K, everything ultra). Memory usage is very low, and both GPU and CPU usage are also much lower than normal.

If I restart the flight, everything comes back to normal.

1 Like

Same here it’s a msfs memory leak or so so it’s not our system.

In this post:

Chemic3l gave me the solution:

During flight, I paused, went to options and turned off and then back on again AI traffic. My frame-rate jumped instantly from 15 to 50 and I finished my flight with perfectly smooth frame rates.

Hope this also works for you.

1 Like

Yea I will limit my FPS to 60 in Nvidia panel too and see

And I have already turned AI TRAFFIC off etc so yea

lol I tried to change the audio output and it works…

■■■

1 Like

Were you able to change the output back to your headset? Or did you have to leave it on your speakers for the rest of the flight?

Recently I solely fly short distance bush trips and haven’t had a chance to test the effect of rolling back to headset output. I’ll try later when I have a long flight enough to encounter this fps drop.

I experienced the drop today,not because of a long flight but I had other things to do.I just left the sim on the main screen (2hrs) and then set up a ridge soaring flight.By the time I reached my destination forty minutes later,I found myself landing with 6 fps.Oh the agony…

Did my first really long flight in the Salty 747 today and also experienced the frame rate drop I usually get 45-55 at Ultra (and a solid locked 30). GPU and CPU were both running well under capacity. If it happens again I’ll try turning the AI traffic on and off again and also the sound output.

Turned out to be an eventful flight - simbrief’s fuel calculation was well off and I had 3 engines suffer fuel starvation with 210nm to go. After topping up with some gas cans we kept in the cargo hold (ahem…), and working out that I needed the APU on to restart them (I thought of Sully!), I then discovered that Asobo were not lying about reactivating wind gusts as I flew through some serious convective weather east of KORD. (2000fpm updrafts - actually quite handy when you are only on 1 engine) Heavy icing was then, well, the icing on the cake. So the FPS drop was really the least of it.

Still, I landed OK. Didn’t mention any of this to the 347 passengers in the back…