After playing a few hours, FPS drops from 40 to 5FPS

Or maybe also they tell us if they also experiencing the issue?!? Because some people are pretending that they dont have this issue and everything works fine. It would be also fine if we also get this confirmation from Asobo.

1 Like

loading screen loves to ■■■■ me off lol

image

1 Like

For me A330-900, B787 give solid performance, FBW on the other hand is a bit problematic in terms of performance. I guess I’ll be flying with A330-900 and B787.

I am having this same issue. Posted here:

3 Likes

MSFS keep becoming WORST with each update. I don’t understand Asobo is fixing something or making it more and more useless.

I was one of the BIGGEST fan of MSFS but since SU7 my sim is becoming useless.

Recent Bug after SU8 is, I start flight and gets 50-60FPS. Within 1.5 to 2 hours of flight my FPS drops to 15-20. In my last flight i was getting 5-10 FPS. I do live streams so anyone can check on YouTube.

Seems like Asobo is ignoring the fact that for every machine MSFS2020 responds differently. My sim ran 100% for 1st year after launch when most of the community was facing issues. But now I am experiencing hard time with SIM.

Please Asobo, look into basic issues as well.

6 Likes

So guys and girls…did some testing after the NDU hack. 2 flights in latest dev FBW A32N FRA-TFS-FRA and both have their fps degradation but not that bad. I have fps locked to 48, first flight to TFS I ended with ~33 fps, followed by restarting the sim and landing back in FRA with ~20 fps. Today I did 1 flight in B748 Salty FRA-DXB and landed with ~45 fps and one in B78X HD YYZ-LHR and landed with ~42 fps…I am impressed

2 Likes

Having the same problem. After 2 hours of flight, the FPS dropped to 10 frames. This was last sunday. A shorter time flight of an hour did not make this problem occur.

2 Likes

Got the same problem after SU8, but it happened to me after 10 or so minutes into the game. I thought it had to do with a Nvidea graphic card driver update from January at about the same time as SU8. So I downgraded my graphic card driver to two lower versions (dec. 2021), and played again. Since then I don’t have that issue no more. Maybe it’ s a coincidence. I upgraded recently to a 1 higher version of my graphic card driver (still not the latest version) and it still seems to be working fine. Especially after latest small update.

1 Like

Could you maybe tell which exact version you use? Did you simply run the installer of the driver or have you uninstalled the old one using DDU or some other fancy tool?

there is no pretending there, not everyone has that issue, there are many factors in play.

1 Like

I can definitely confirm that with A330-900 and B787 FPS drops never occur. In fact the performance is amazing in my case too, possibly over 60 FPS during cruise.

1 Like

Did another flight in B748 Salty from JFK to FRA, no FPS drop at all. Well excluding super badly optimised FRA when arriving on a stand…apart from that stable ~45 FPS from start-up at JFK to taxi-in at FRA

2 Likes

I downloaded version 497.29-desktop-win10-win11-64bit-international-dch-whql.exe of the NVIDIA website (not easy to find) which is, i believe, a december version. Just by running the exe-file it installs the older version over my latsest installed version.
Rollback to previous version didn’t work through the NVIDIA GeForce Experience app, so I tried the way I described above. That did it for me.
After playing a couple of times with that driver installed, I downloaded the next version (still not the latest) 511.23-desktop-win10-win11-64bit-international-dch-whql.exe file and installed that.
That is the driver that works for me, so I’ll keep it at that.

1 Like

Thanks. I am using the same but it didn’t really improve something for me. Glad it worked for you.

1 Like

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes I have DevMode on, but I didn’t made changes in it.

Brief description of the issue:

On longhaul flights, after about 4 or 5 hours, the game starts stuttering and the framerate drops. I noticed that CoherentGTDraw and CoherentGTUIThread are all over the place, though I don’t know what it is. This bug makes longhaul flights impossible to execute. After a restart of the game, it performs just as it should.

In the performance tab of the Task Manager, I didn’t notice any glitches. Please notice that my GPU usage is lower than it should, because I use popout panels and the popout performance bug isn’t fixed for me yet.

2 weeks ago I performed a clean install of the game. I use a lot of hardware in my homecockpit (3 NVidea surround monitors, 2x 17 inch monitors, the Thrustmaster joystick and throtthle quadrant + addon, 2 Streamdecks, 2 Saitek radio panels and 1 Saitek multipanel), but since this bug only occurs after a couple of hours I’m convinced it’s not caused by the hardware.

Also I use a couple of third party applications (Self Loading Cargo/PAX, Volanta, Spad.next, Navigraph Simlink, Navigraph data and vPilot). It’s all up to date and I didn’t encounter any bugs related to this software.

Provide Screenshot(s)/video(s) of the issue encountered:

  1. IMG 5698 - YouTube (In game stutter and low framerate)
  1. IMG 5699 - YouTube (Task Manager, performance tab)
  2. IMG 5697 - YouTube (FPS counter and game performance)

Detailed steps to reproduce the issue encountered:

  1. Start a flight, load the cargo and fuel, set up the FMS with a full programmed route.
  1. Takeoff, climb, enter cruise
  2. After a couple of hours the game starts stuttering and performance drops.

PC specs and/or peripheral set up if relevant:

Intel Core i5 9600K, NVidia Geforce RTX 2070, 32 GB RAM, 1 TB SSD, 3x 24 inch monitors (Surround, HDMI/DP), 2x 17 inch portable monitors (on USB-C 3.0 plugged into the motherboard video output), Thrustmaster Joystick, Throttle Quadrant and Throttle Addon Airbus edition, 2x StreamDeck XL, 2 Saitek radio panels, 1 Saitek multipanel, Corsair mouse and keyboard, one Lenovo tablet with USB-C 3.0 and DualDisplay as a 6th monitor.

Build Version # when you first started experiencing this issue:

1.23.12.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

welcome to the party

As I have mentioned elsewhere, I have found, in my case, that toggling the vsync setting returns the sim to full performance. I can then re-enable it for the rest of the flight. It’s as tho some sort of backlog builds up over time, and toggling vSync releases the pressure. It works for me when approaching my destination and things slow down.

I still have performance degradation after the fix.

When i toggle photogrammetry in flight it’s good again for a while.

1 Like

Flybywire seems to have found the cause for the degradation over time.

Workaround is ro start the MCDU server even when not using it.
Don’t know if it’s working only for the FBW Airbus

Thanks everyone for the testing. We found what causes degradation and are working to report it to Asobo to get it investigated.

@FinalLight [Z+1] @Letreiv @Glitched

4 Likes

Umm how do we do this actually? Thanks!

1 Like