After playing a few hours, FPS drops from 40 to 5FPS

Have y’all tried disabling HPET in windows via cmd or task manager? It worked for me on long flights.

Edit: I meant to say Device manager… NOT task manager…

I did it in the Device Manager along with the NDU registry hack….I do see fewer studders and my fps is decent with no drops over time. It’s still not the same performance as I was getting pre SU9 and I can’t run the same terrain or object lod (now at 125, was at 200) and I can’t run the same AI traffic either (now at 15 down from 50). So, the HPET and NdU hacks may have helped some but the root cause of the reduced performance in SU9 has not been addressed clearly yet by Asobo and these hacks are workarounds that may lower the cpu load a bit for some modest help but are not fixing the core problem.


This bug is getting odd. Cannot finish the LFBD-KSEA flight. After around 6 hours it stutters and always crashes.
No Matter which Plane, Safe or Normal Mode.

1 Like

I admittedly haven’t read all 2800 replies to this topic, but wanted to say that I just had this happen over the weekend myself. I went from a solid 30 fps to 4. I ended up closing the AIG traffic controller and it shot right back up to 30. Anyone else try that?

Yesterday evening, i found a stuttering problem coming from an fTPM Bios Bug. Then i checked for a bios updated and found there is a new update (ASUS X470 Pro - AMD 5800x in my case). Afterwards i started the LFDB-KSEA Flight overnight and this morning it’s still flying without stuttering :O. So maybe, at least for AMD you can try this bios fTPM fix. Workaround would be to change to discrete TPM in Bios.

Tried installing the latest drivers for my RTX3080, hoping that it would improve things. No luck. My GPU now will not run at 100% all the time as it did in the past when I got smooth performance. It is typical, now, to see it hovering around the 50 - 60% mark and that’s when performance tanks. The only other thing I did was apply the PHET ‘hack’ but I restored the default settings when I had the unrelated game loading issue related to the servers being down a couple nights ago. I have been slowly reducing my graphics settings in FS to maintain playability, but this is not the answer. I’m starting to lose my enjoyment of the sim as it’s turning into an exercize in tweaking attempts.

1 Like

I have had this happen several times, the fix for me has always been to ddu the driver and resinstall it and the 100% GPU usage will return. I never figured out why it all of a sudden did this but it has and does. So try doing a clean install of your nvidia drivers and see it that doesnt fix things.

1 Like

I rolled back my NVIDIA drivers to 511.72, removed all boat/ferries traffic and was able to complete a 10 hour-flight with no noticeable FPS drop.

FPS drop on the MEX-BCN route in the Captain Sim 777-300ER was 100% reproduceable.

Just 1 data point…

Total frame rate drop crash to desk top after todays update. Honda Jet freezes screen at takeoff from SanFranciso Intl. . This did not happen before update. Great I cant believe this


Tried with dx12 and with dx11, same thing.

1 Like

Has anyone tried lowering the cache? I think a big issue is that caching takes up too much RAM, but you want to at least have some of the caching.

Just used the Geforce Experience app to launch MSFS and fps almost back to where it was before update. Honda Jet does not cause program to crash loading in at San Fran intl

And caching doesn’t work, but there is an improvement by removing vehicles.

Sorry to complain and I know it’s not helpful but It’s wild to me that Asobo hasn’t even acknowledged this issue and made it a priority to fix. They really need to get their ■■■■ together. At this point i would recommend anybody into simming to avoid MSFS until this is fixed

Kinda wish I’d gone with a different simulator at this point myself :weary:

I had it working for a while in the salty747 but it seems to randomly work sometimes (no degradation after 5+ hours) and other times it will die (5 FPS and sim crash after 3 hours).


I had same issue since last Sim update, no before.
Before my sim just crashed after some hours of flight.
Anyone had solutions, we should just hope that Asobo will fix that rapidly.

1 Like

I desactivated cache, nothing change.

I will try and give you a feedback.

Why? I don’t have this issue. Do you really expect me to stop using it? Oh, you mean affected users, right?

1 Like

I’m on a VA discord of 200~ simmers and everyone has this issue with MSFS, consider yourself lucky if you don’t have it


They acknowledge it awhile back, but also said that they couldnt reproduce it…