After SimUpdate 5 & 6: Kepler GPUs with mesh/coast bug

A similar problem GTX 770 4Gb

Thank you @MistakenEnte for adding the information. Hopefully more Kepler users will quickly find out why they are seeing these mesh issues.

Although there was the flashing cloud bug back in late 2020 (which actually took two months to get fixed), I don’t think it’s very much related to this one because it also affected Maxwell 1.0 GPUs, and pretty much any GPU that did not support Direct3D feature level 12_0.

It may have to do with NVIDIA not supporting Kepler in their drivers anymore, and as such Asobo could use this as an excuse to update their system requirements and not fix the issue. Although sometimes old GPUs have to become obsolete in order to let the engine move forward, right now is not a good time with the hardware shortages and everything, so I hope they will consider fixing this.

I will stress again that reporting to Zendesk is a crucial step to help them acknowledge the bug. The flickering clouds were tended to only after tons of users started sending reports.

Yes, the cloud bug affected much more users then this here. I am only giving it a chance, because it is a new bug. If that would have been there from the initial release, it would have been a different story.

I think I might have found a fix, but I don’t know why it worked :

  • Enable Developper mode ;
  • In “Option/Rendering/Ground”, untick “Enable water flattening”.

Please tell us if it’s working for you too.

3 Likes

Yes, it works.
When turned on, when approaching the ground, holes appear.
When turned off, after moving away and approaching the ground, there are no holes.

1 Like

Enabled

1 Like

Congrats, @Keiharde and thanks for sharing! It’s an easy workaround in the meantime. :+1:

1 Like

This fix worked for me too. GTX760. Thanks!!

Thank you @Keiharde !
This fix worked for me too (GTX 770).

1 Like

thank you very much!!! :smiling_face_with_three_hearts:

1 Like

Please, whoever has this problem, send a bug report to the developers. And also vote at the beginning of the topic.
The more of us there are, the faster the developers will notice us and solve the problem.
https://flightsimulator.zendesk.com/hc/en-us/requests/new

1 Like

Yes tk fix work!!! but no more flat water next to land…

Because by default is turned off.

Nvidia GTX 770 with the same issue. These are so big at you can often fly into them.

1 Like

YES developer mode fix worked for me using GTX770

1 Like

The developer mode and the proposed solution also worked for me GTX760

Absolute legend !! Been tearing what’s left of my hair out trying find an answer to this. Titan GTX.
Very happy camper again. Thanks!!!

1 Like

While “workarounds” do help they are not “fixes”. Let’s not get too excited about a “workaround” as we expect it to be fixed and often times if a workaround is acceptable by the end user a fix will be put on the back burner if ever fixed.

Remember this broke when they offloaded CPU usage to the GPU for Update 5 trying to increase performance “for all”. This was intended on increasing the framerate “for all”.

At the time I knew they were sacrificing older GPUs for the sake of increasing performance for newer GPUs. Logic tells you that if you are going to add more work to the already struggling Minimal Required GPU by offloading CPU work to the GPU as they specified then how do you think it will affect these lower-end GPUs which were already struggling?

It was a sacrifice IMHO.

Worked for me GTX760 thank’s for this workaround

1 Like

The “Enable Water Flattening” option under OPTIONS>GROUND in the Developer Mode seems to have been removed. So for me, holes in the ground are back :frowning: