AI Control Aircraft - AI Pilot is broken, no longer works as expect

Use this feature all the time where you switch AI Control Aircraft in the menu where you select AI control radio messages.

It used to work as expected, take off, climb, turn and follow waypoints until reaching cruise etc. Then descending properly and turning to line up for landing, and actually succeeding at landing.

Currently, the behavior is as follows, take off in a broken kind of way (not really pulling up, just lifting off because of airspeed), and climb… that’s it, it never turns or follows the waypoints, the AI just flies off in a straight line. Broken.

I love that you are fixing stuff and adding new stuff, but I (as I’m sure much of the community would agree) would prefer it if you didn’t break stuff that was previously working when you implement bug fixes and other new features. Personally I would be prioritising getting everything working that was initially released before focusing on adding new content and making things worse.

It is botched for me as well.

6 Likes

Yes same problem here and it’s very frustrating. They fix some bugs but at the same time create new ones. I know it’s a work in progress but why market it before it’s totally useable ?

4 Likes

Same…
Takes off… Crooked.
Then flies straight. No turns towards destination.

Although… 1 out of 10 times it works as normal.

1 Like

me too regards me

me too. ignores any flight plan. one time it was flying in the right direction after disabling / enabling many times and half way of the flight plan it turned and was flying back to departure airport :slight_smile:

3 Likes

Same here. also the AI (co-pilot) will maxthrust and max climb the aircraft causing overspeed . Wont follow ATC commands either even though the Co-pilot responds to them via coms. Wont use flaps on take off nor landing but will if they are already out. will also land the plane but cant line up right in most cases will go around ot land somewhere else all together

5 Likes

same here.

Same.
Version 1.9.3

Same for me, use this often while doing other things or just enjoying other aspects of the sim. Please fix the control aircraft feature so we have our copilot back.

1 Like

and was it ever working ‘as expected’? The only one time I’ve used it to check if it can taxi to the gate it went straight into a building.

That’s right the auto pilot not work in the same manner not follow the routes establish in flight plan another bug

It worked pretty good in most places. Not perfect but it worked.

1 Like

I dont think it ever worked 100% but it kinda works when screens go black

Same for me. Auto pilot was working fine before the latest update - taking off, following waypoints, and descending/landing reasonably well most of the time (unless the flight path went through a hill but that’s another matter). Now it just goes anywhere - take off from Invercargill, New Zealand, to go to Dunedin, New Zealand (hometown) the plane will turn around if taking off south but then just keep going straight northwards, without following flight plan. I’ve also noticed the traffic pattern / landing guide rectangles have disappeared. I’m often using FS2020 just to let the AI fly round whilst I look at the scenery but can no longer do that. Disappointed; hope they fix it soon. (Not mentioning the giant buildings that have appeared in small NZ towns with the latest update!)

2 Likes

I noticed before it broke that on landing the copilot would be off to the left but once over the runway straighten out. It didn’t look as good but it at least worked and landings were successful 90 % of the time for me to witness.

Hope this gets fixed soon and we are adding it as a bug report to zendesk.

Well, are they addressing this issue?

No acknowledgement whatsoever. It has not made the front page of known issues. In manner of fact we have heard nothing from the developers since the last patch. It seems like they released the patch and went on a Club Med vacation.

This happened to me after the last patch. AI issues.
Then it seemed ok for a short while before this patch.
Then broke again.

So… now Im not sure it was ever fixed.

1 Like

same here. was nice to just let AI fly and tour areas. after latest update, ai takeoff bounces on the runway a few times and then flies to nowhere specific. please fix.

1 Like