Aircraft animations freeze after tabbing out to long

I think we all sometimes are going to do something else on our computer, while we are cruising on a mid/long haule flight.

Sometimes I tab out to long (I do use the windows key, I’ve seen the tab out bug, this is not the same case). When I tab in FS2020 again my aircraft animations no longer work. This happens time to time, sometimes it does, sometimes it doesn’t.
What I mean with the aircraft animations no longer work for example, is that the engines don’t spin anymore, I can click buttons, but there is no animation and the displays are also frozen so I don’t know what the autopilot is doing and also I don’t know if I actually do make a change in the aircraftsystem.

The aircraft does fly, it’s not like the engines are turnt off and the aircraft falls out of the sky. It’s just that the aircraft is no longer animated and becomes a static aircraft, but it does remain it’s path/course I said it to.

It’s frustrating because your instruments are basically frozen and no longer usefull. It also looks very odd that your engines no longer spin. The only solution I have is to reload the flight on the location that I already was, but that is just demotivating.

I haven’t seen anyone talk about this so I don’t know if this is a bug, but I do hope so, so it can be fixed :). I also hope it’s clear what I mean, if not please don’t hesitate to ask which part is unclear and I’ll try to explain it even better.

P.S I don’t know if this is the right section to put this problem, so apoligies if that’s the case I thought this was the most logical place to put it in.

Thanks in advance, M.

Hello there, as they say, Welcome Aboard!

This is a fairly well known issue.

I have read posts saying this simconnect issue could be corrected with the WorldUpdate 3, due tomorrow.

Just FYI, the moderators are a bit strict on posting in the Bugs & Issues section, as per the site rules, so you should search all the other sections of the forum that may pertain to your issue before you post here.
This section of the forum is for proven bugs that you can’t find a solution elsewhere on the forum or aren’t already in this section. (If they are, vote them up!)

Hi there, thank you for replying.

I’ve looked at the link u sent me. But that’s not the problem I am refering to. I do not crash to desktop and the Simulator does not freeze. It works fine, but the aircraft becomes a static thing that just flies to it’s destanation I put in. It’s just that I can’t click any buttons and all the instruments don’t update. It’s like the aircraft becomes corrupt.
If the problem reoccurs I’ll try to record it, because it’s just impossible to explain.

The perfmon.exe certainly looks interesting, I’ll try that.
Let’s hope world update 3 fixes it, do you maybe have a source of that?
I’ve had this issue (on and off) since the beginning of december, so I do hope an update fixes it.

Since then I’ve looked at the forum, searched for someone to have this bug. Didn’t see anything about it. I know the moderators are strict, but I did do my research about this topic. And as a customer I do have the right to post/ask something, if something with the product is not right.
Again, I am sorry if this isn’t the right section. If so, please redirect me to the right one.

Thanks again for your help, but in global, I am afraid it doesn’t solve my problem. Because the issue you were refering to isn’t what I am talking about.

Greetings :slight_smile:

Yes, your rig is probably powerful enough, or set up well enough, to mitigate the CTD.
The cockpit display button freezes and such are the first symptoms.
For others it then goes to a sim freeze or CTD.

ASOBO has been very quiet on the issue.
(I suspect they don’t really want to broadcast it)
but there are a few threads from ASOBO people as far back as December acknowledging it, absolutely nothing I can find with a firm release date for the fix.
The most info I got on the subject was from Pete and John Dawson’s FSUIPC7 forum.
They have been in communication with ASOBO on the issue, and hinted at its release with the World Update 3.
It wouldn’t surprise me that is so, as ASOBO does keep an eye on the forums a lot, and it is very well posted about, as it is affecting a lot of users.

1 Like

Thank you for answering. I think we are on one line now :smiley: .

We’ll have to see and wait for the fix to happen. Hopefully we’ll see results already tomorrow in the next world update.

Thank you very much for your time!

Kind regards

1 Like

Happened to me today, not sure if it was result of tabbing out - I did from time to time - the flight was ~10h long already.

(internal state, some displays update but most of the cockpit is not)

1 Like