Analog caravan & CTD

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

using it with 0 change

Have you disabled/removed all your mods and addons?

yes occured once l install and get in the analog caravan

Brief description of the issue:

tried 3 flight from OINN to OIII into c208 analog, arriving above Tehran got a CTD each time, so tryied to finish a 4th flight with a landing to OIIG spawning in the air , didn’t reach the start flight buttom my mfsf crashed to deskop that s why l came to the point to think it wasn’t pc crash but geolocalisation bug

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

flying west europe server, with a gtx1070 (last nvidia driver 516.94), intel i7 4770k, 16Gb ram, win10, dx 11

If ,on PC, Fault Bucket ID - Instructions here - Please type in just the Fault Bucket ID # rather than a screenshot for privacy reasons:

Détecteur d’erreurs 1871396378550809644, type 4
for all crash seem to be same number

Build Version # when you first started experiencing this issue:

SU9 01 september 2022

Edit : well did many try today with the Asobo c208, everything was fine , look like the problem is related to a mod :-/
Edit2 : tried all mod 1by1, it came from analog caravan , then ll report this to black square once l got more solid capture of the problem , maybe should l try using addon linker in the futur, apologize if the post is on the wrong section

you can change the heading and move the post into:

maybe it’s interesting for other users too then.

A question: can you share the Error Message from Windows Event Log too ?

since l received an answer from JustFlight to my ticket that clearly show an automatic response illustrating they didn’t took time to read my ticket
(respond was like : try removing all add on, while l said l did many 1 mod tweak to find out wich one cause the crashes, then told me to update my gpu driver even if l mentioned running the 516.94 nvidias driver ,or avoid DX12 wich l never turn on, ask me to verify my pc spec to be sure they are above the minimum requirement … -_- ) in fact l sent them the same text more or less than the initial post
l will move this post so …

the error event l got is the following

Détecteur d’erreurs 1871396378550809644, type 4
Nom d’événement : APPCRASH
Réponse : Non disponible
ID de CAB : 0

Signature du problème :
P1 : FlightSimulator.exe
P2 : 1.26.5.0
P3 : 00000000
P4 : FlightSimulator.exe
P5 : 1.26.5.0
P6 : 00000000
P7 : c0000005
P8 : 0000000000b8a832

l found another airport l can easly fly around with the Asobo caravan , but once l get into the analog, make my sim CTD it s the KEWR, also made some short video msfs OIII constant ctd - YouTube (OIII) + KEWR CTD analog c208 - YouTube (KEWR) + KEWR default vs analog caravan - YouTube
l tried to roll back to an old nividia driver , didn’t change anything, maybe should l try to go on SU10 beta as JF mail suggest me … wait for some user experience to see what s the best option, btw l know blacksquare are actually working on a patch, dunno if this ll fix my little problem (in fact l flew a lot , since the launch without problem but those days l met one problematic place, then a second … )

1 Like

dont change to much at same time :slight_smile:

My little hope was, that you see in your error message something like ) grammar.pggmod or b) vcruntime.dll … Both happens allways on same coords , but have different cause ( a) map issue , b) possible vcruntime update helps ). These text should you can find above the “Signature du problème :” and is the more interesting one ( e.g. Faulting module name , Faulting module path, ).

Then it would not be the caravan, or may it cause it only indirectly. But if you only get the usually info “… 00005 and FlightSimulator.exe” , it is hard to find and it can be realy the mod.

1 Like

well since those crash occured with only 1 folder in my community folder (the bksq-aircraft-analogcaravan ) l can ‘t blame other mods :-/ and made a video showing l have 0 problem with Asobo plane ( third link l just added few minute ago in my previous post) :’( even if those CTD are very rare (l mean it s not yolo, but the places where this happen arn’t common dunno if it s due to the urban area, airport radios etc) l m very sad to be scared each time l reach a airport like “does he ll let me land ?” cause l love so much this plane

2 Likes

having same problem CTD in black square caravan at Adelaide airport YPAD landing and spawning into YPAD

1 Like

a guess is may be one of the mentioned “improvements” cause that, may be avionics ? Did you use the default garmin ?

Note: This product is an INTERIOR AND SYSTEMS OVERHAUL ONLY that makes use of the default MSFS Caravan exterior visual model. Improvements have been made to almost all aspects of the aircraft, except the visual appearance of the exterior. All default Caravan liveries are compatible with this product.
( source: https://dxhb0it26is40.cloudfront.net/manuals/BKSQ_AnalogCaravanManual.pdf )

Not sure about the post you linked, but I asumme whats meant is " a cleanup of cache , etc." . I copy paste what I mentioned sometime in forum:

you can remove folders and files like:

%AppData%\Microsoft Flight Simulator\SceneryCache , SceneryIndex, DCE, content.xml, ROLLINGCACHE ( or at the location where you moved it ) ?

( for rolling cache, check later on that msfs recreated it in correct folder you choose and not in default, in case you setup a different location )

PS: I should have a look at these mod too :slight_smile:


@rolymal9 YPAD is may be a different issue… in special if you own the mod…
as example: Reproducible CTD at Impulse Simulations YPAD Adelaide Airport ( but there are other reports )

1 Like
id you use the default garmin ?

when flying the Asobo l have the Nxi G1000 , l really don’t know if it s part of avionics, ll try with twin otter & c414 to see if it can be the gns530 or gtn750 even if l fly only with 2 KX-155B other avionics are loaded since there is a switch to change avionics in game, even if l doubt it s the issue cause l tried without those mod in community folder ( " New kap140" ,“ms50 gns530” , “pms50-instrument-gtn750” ) and had crashes , then ll try your tip , should be concerned about rollingcache file if l set my game without caching file ? can’t find him

edit : twin otter and c414 succeful spawned at KEWR so it s not gtn750 or gns530 fault kp140 either , l tried with lowering quality setting and photogrametry off and default livery of analog = crashed , it s now my new way to quit the sim :stuck_out_tongue:

1 Like

well l have been able to load and take off from KEWR once after doing those steps
“deleting the cache (in the game)
Then deleting the content inside the scenery indexes folder
Then deleting the content.xml file
( + DCE inside s file as suggested )
Relaunch with no addons in the community folder and test”
Then closed and added the analog plane
unfortunately OIII as CTD , l think at this point l ll stop my tweaks, continue flying and wait to see what the coming updates (analog one & SU10) ll change

edit 06 september : l crached twice trying to spawn OIZB , so the third time l cleared my cache from the menu and tryed switching from europe west server to north america East server = no CTD …

1 Like

Same problem, only with the analog C208.

1 Like

wich server are you flying in ? hope with in coming release su10 ll get rid off those CTD, l had no problem during 1st month (as far as l remember) it started at same moment than many people reported ntdll crash issue & memory could not be read issues

80% of the crashes I’ve had in the past week have been in this. I don’t think it’s a coincidence. It’s conflicting with something, I just don’t know what. I am concerned it might be the TDS 750NXI but I’m not sure yet.

1 Like

l had ctd with 0 AP and 0 avionics installed, l flew other gtn750 planes with no problem maybe something wrong with weather radar module … it can be so much stuff so l doubt it s gtn750 fault

1 Like

I had a much similar experience a couple of weeks ago - I started to have repeatable CTDs while approaching KJFK with any airplane I have. Oddly enough the CTDs did not happen while approaching smaller airports with less traffic (I do not use live traffic btw, only offline traffic mode). Long story short, with the 50 in / 50 out method of checking addons in Community folder, I identified the analogue 208 as the culprit. Removed it, no more CTDs when approaching KJFK. Noted that the CTDs occurred always when I was at approximately half mile distance from the airport. I suspect at this distance the game starts placing and rendering the aircraft on ground and maybe there is something in the analogue 208 that conflicts with the Asobo 208? Could the rendering engine being unable to ‘choose’ between the two? Just my 2 cents…

2 Likes

Might be on to something there perhaps.

1 Like

Moved to #third-party-addon-discussion:aircraft as mod is involved.

1 Like

similar scenario here, CTD after launching MSFS right at that white screen. Removed the whole community folder, left only the analog Caravan, CTD again. Removed the Caravan, loaded the whole community folder - no CTD. So these CTD’s are clearly coming from the Caravan. Also removed all the different AP and avionic mods, to no avail. Submitted support ticket to JF but don’t expect too much. Sad, flew exceptionally well the first day and now unusable
RTX3080ti/i7-12700/Win11

3 Likes

l suggest you to try another server, l get to the point l noticed server had impact on the crashes (on top right corner close your xbox game ID you can easly switch )

1 Like

Interesting advice, thanks!
I checked my server status within MSFS that was set as ‘Auto’, changed it to a different server the ‘apply and save’, just after that I switched back to ‘Auto’ (noted the now selecter server was different from the initial one)
Then I tried the same flight that was provoking CTDs before (from La Guardia to KJFK flying over downtown NYC, with multiplayer off) and this time no CTD
I made several low altitude passes over KJFK without CTDs, then took the analogue 208 for a series of short hops in San Diego area, no CTDs
So far so good (crossing fingers)
Maybe my CTDs approaching KJFK were indeed due to MS server unable to stream into MSFS all the needed data

1 Like

no mods used and its been happening at 4 other airports in Australia as well for me and other players i fly with, thanks

1 Like