[ANNOUNCEMENT] FlightSim Studio Embraer 175

Let me check and revert.

You are 100% correct. I removed all the addon liveries and tried it with only the ■■■ default livery. Works perfectly fine.

1 Like

The update notes for tomorrows scheduled update look pretty solid. Also now shows will be update on the 7th of Feb so hopefully cranking these consistent updates just keeps improving.

Yes, the NAV source is on VOR. I tried a flight today at PANC with the Cessna 172 G1000, Runway 7L, and it worked. So then I loaded the FSS Embraer 175 (Alaska), also at PANC, Runway 7L, and today it also worked correctly. Not sure what my problem was last night. After I landed, I did not get the blue arrows to guide me to the gate like normal. Decided to try using Little Navmap to see if I could use it to get to the right gate. Surprised to find I could actually do this.

Looking forward to the next update tomorrow. I always look forward to reading your comments on this forum.

how about the last update? Is it worth paying for the product?

Update is good but still a lot to fix of course.
FPS are significantly better (but the problem that some have with lag spike might still exist… Dont know…)

So is it worth buying? To me: Yes. To you: Nobody can tell.
When money is an issue: probably wait till it’s finished.
When money is not an issue but you expect your moneys worth from the get-go: probably wait till it’s finished.
When money is not an issue and you can live with its flaws and even want to help testing it: Go for it.

I’ve had a little issue with the right engine turning itself off mid-flight in my past two flights. Seems to happen while in autothrust mode when the plane is transitioning from climb (i.e. FLC mode) to level flight. The autothrottle pulls back the left engine thrust to maintain the dialed-in speed, but turns off the right engine. Not a big problem to restart (the big thing to remember for me is to pull the throttle back to idle), but strange…

My experience was that it is about a button mapping which has to be removed (it‘s described somewhere in the release notes).
Had engine 2 cut off at first flight>corrected mapping>since then it works.

Been flying the Aerosoft CRJ700 a lot lately which is well done but the plane design itself with the small screens was never my fav as it’s really hard for me to read. I waited for the latest update before buying the E175 and of course there are many issues with EA but for me anyway I’ve found it totally flyable with full in-game checklists and fps not too bad. Lack of vnav not a big deal at this point as I can just fly ils approaches.

The biggest thing I’d like to see is the custom FMC which I know is being worked on. There is a great real life video on Just Planes yt channel (Piloting Embraer 175 from klga) as I wanted to see what the real plane was like and seems like fss is on the right rack. They are providing lots of detail on their website about planned updates/fixes.

In short, I found it completely worth it at this early stage knowing it is incomplete. I won’t fly it too often yet but trust the dev will keep with regular updates. It’s nice to have alternative RJ to the crj.

I love it when a developer makes a big box that appears in your sim when their product can’t connect to whatever to verify something and stops you from doing anything other than force closing your sim. Not sure why now it wants to check my activation when I’ve had the aircraft for a short while.

I like this plane, please sort out your activation error box!

2 Likes

Are you sure this is related to the E175? It looks like a MSFS error based on the screen shot and that it looks to have happened on the home screen for MSFS… I’ve not had any issues with the E175, but I also noticed that Aerosoft had a patch update on their application yesterday.

The Aerosoft One App got an update wich had to do with activation of the E175. Is the App already updated?

1 Like

It is related to the E175 as clicking the support link opens up their website. It only appears once I load into that aircraft also. My version on Aerosoft One shows as 0.9.2rev1.

I’ll try a reinstall.

Meanwhile I get the same error. First this one:

And then same as above in Brunleas post.

2 Likes

Although work in progress I am surprised by how much i actually enjoy flyling the little jet. Flying only in VR I really like the cockpit, big windows, beautiful displays. This could become my favorite short haul jet in the sim, really hope they will continue the development. Many big airlines consider updating their fleet with the Embraer.

1 Like

I’m getting that also now. I tried reinstalling. I’ve sent two tickets. Not sure if they have got them as you don’t get an email to let you know they have received your ticket.

I got an answer from Aerosoft support:

Hello,

we are sorry for the inconvenience.
Can you do the following:

  1. Close the MSFS if it is currently running and start it again. Wait until you are at the main menu.
  2. Navigate to “Community\aerosoft-one-msfs-utilities\utilities” and start the “Aerosoft One MSFS Utilities.exe” manually. This will not be visible, as the program runs in the background.
  3. Start a flight with the E175 and see if it is working now.

Kind regards,
Aerosoft Customer Support

It works for me so it could work You as well.

1 Like

You’re a legend, Sir @Grogaholic . That appears to have worked for me also. Thank you for letting us all know how to resolve it.

I’ve also just had an update (0.9.3rev1) to the E-175 via Aerosoft One.

1 Like

Good to hear it works for You as well. Yes V0.93 is out but for me the “activation failed” screen was less frustrating than this update. Maybe it works better for You.
cheers…

1 Like

I also had the ‘activation failed’ problem, but the update to 0.9.3 rev1 via Aerosoft One has resolved it. This aircraft keeps getting better, and I am enjoying it. Currently flying from Unalakleet, AK to Anchorage, AK.