Assistance Options Not Saving

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?
Microsoft Store

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes, but tested this and found the same problem with an empty Community Folder

Are you using Developer Mode or made changes in it?

Brief description of the issue:
In the Assistance Options menu for things like AI Piloting and Navigation Assistance, I have those items set to Custom with my preferences. However, every time I start the sim, it defaults to Easy for the many options in that section, and I have to fix them every time to get back my settings, They are not saving despite my clicking Save. The settings work will work for that sim session, but then when I restart the sim they all default back to Easy. This is odd/buggy because other things like the Graphics Settings work fine and save in the cloud no problem. This happens with multiplayer off or on. I also do not use live weather or live traffic but that should be unrelated to these user defined settings. Are the settings stored locally in a file that might be corrupted that I could delete or are they stored in the cloud? It’s a pain to have to fix this every time I start the sim. Thank you.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
See description above

PC specs for those who want to assist (if not entered in your profile)
I9 10900k
64gb ram

Build Version # when you first started experiencing this issue:
Started happening after WU6

Are you on the Steam or Microsoft Store version?
MS Store

Did you submit this to Zendesk? If so, what is your ticket #?
I filed a zendesk ticket and the closed it with no reply about any resolution nor did the acknowledge if it could be recreated on their end. The reply looked like an auto reply or bot and I could not tell what the reply was trying to say.

Try to see if you can start, setup the assistance to the way you want. Save and Apply. Then exit MSFS.
Then start MSFS again, check the assist settings, do they still get reset after this?

I’m wondering if the assist settings get reset if you’re flying at some of the flight modes other than free-flight.

Ok so I tried you suggestion and it worked! I will now fly a flight or two and then exit and restart the sim to see if the settings hold or revert back to Easy. I’ll report back in a while after flying….

Ok it worked and kept my custom settings. So that’s the way to do it when you change something, save setting, completely exit the sim and then restart the sim. Thank you for the suggestion.

Spoke too soon. Exited and restarted and it defaulted back to Easy settings again! Ugh.


I have the problem that everytime I do a landing challenge the “ATC handled by ai” option activates itself.

Agreed its only started recently resetting the options to EASY , though it left my custom one alone

More testing required

Well, this problem keeps happening and it’s random…some days the Assistance Options are find just as I left them from the prior session, other days I boot up and it’s all back to the Easy Default. It’s random. I have logged out of and back into MS Store and the XBox app…upgraded to Windows 11…it’s clear that a config file of some kind is not getting updated cleanly or is corrupted. If I was able to delete the config file I would, but unlike the graphics settings file I don’t think the Assistance Options are stored on your local machine, it’s in the cloud somewhere. Even after SU6 recently this problem keeps happening. I am just about to do a complete re-install of the entire sim (or I suppose I could just uninstall the base game and leave the 100+gb data files) to see if a re-install of the sim corrects it. It only takes a few seconds to re-set these options every time if defaults but it’s annoying, especially when all other settings save no problem for graphics, data, traffic, controls, etc, etc.


Oh FFS this just happened after the update and it took me about 20 failed landing challenges to figure out what in the heck was going wrong.

Every time I make a change in Content Manager, settings reset to easy.


It seems to be a clue. After the initial reset to all easy my settings have been persistent until I have upgraded Enhanced Airport Graphics from the content manager. I though it was because I had started a new flight not cold & dark as usual, but maybe the content manager interaction is the problem.

1 Like

It seems random. After SU update all assistance settings were restored to easy. Restored my settings, flown, closed msfs, restarted pc, msfs and my settings were there. I played with reno race and after it, settings were back to easy on the next flight. Very annoying…

1 Like

VERY annoying indeed!
It seems that after uninstalling or installing planes or other stuff,
the assistance settings reverts to easy.
I am having this issue only after the latest Version:

I have the same problem and also couldnt find out a workaround. Do you?
What I know is that I have the issue only since the last update.

No, I have not found a workaround or seen anyone else post about finding one either.

1 Like

Just to chime in and say that I’m on Series S and just started getting this issue exactly as you guys as described. The weird thing is I never got it before the latest update.

1 Like

Just the same here both on Xbox series X and laptop. Only noticed it since SU7 update, most annoying and inconvenient.
They are all too busy screwing around with the funfair races game instead of getting all the other relative issues sorted.
I’m going to try dumping everything out of the community folder and a few MS add-ons first, otherwise it’s another full day of hell downloading the whole show again.
Will report back if any progress.
11th gen Intel i7-11800H
Nvidia RTX 3070 8GB

1 Like

Have had this happen twice since su7.

But I also noticed it only happened after changing to an aircraft NOT flown in su7 yet.

Haven’t had it happen on any aircraft, after reseting it.

Could be coincidence and need to check further…

1 Like

I’m having this problem with SU7. This is the 1st time I’ve had this problem. Remembers for a few times then reverts back to easy. No pattern found.

Same happening to me.

It didn’t happened 1st few days after SU7, but now it happenes every time.

It is not big problem, but it is annoying to make changes on every sim or flight load, very annoying.