ATIS message still plays after changing frequency

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Sometimes while in flight, your currently tuned COMM 1 frequency may become in range of an airport ATIS message. When you attempt to change the frequency to anything else. The ATIS broadcast message repeats itself, no matter how many times you change the frequency. You must listen to the entire broadcast AND be on a different frequency for the ATIS message to stop repeating.

Provide Screenshot(s)/video(s) of the issue encountered:

None

Detailed steps to reproduce the issue encountered:

Not sure if you can replicate by manually tuning an ATIS frequency or if you must have one automatically begin playing as you fly within range of the station. In either case, once you have an ATIS broadcast message playing, try to change frequencies during the playback. If the issue exists, the ATIS message will repeat itself from the beginning. This will occur as many times as you change frequencies. The remedy is to change frequencies, listen to the entire broadcast and then the ATIS message will stop repeating.

PC specs and/or peripheral set up if relevant:

Not relevant

Build Version # when you first started experiencing this issue:

1.25.9.0 but have seen this behavior in prior versions.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I’ve noticed that too- I have to switch freqs during the second broadcast to get it to stop.

2 Likes

I’ve also noticed this. And I agree that trying to replicate this is difficult. It’s not easily replicated.

1 Like

I’ve had this happening since the beginning. For me it’s if I switch frequencies during the pause between message play.

If I switch it while it’s playing it’s fine.

This is in P2A but it’s the sim itself doing it.

1 Like

This has only begun for me since SU9. I did the beta and didn’t notice it but it has happened several times since it’s release. It is intermittent. Sometimes it does it - sometimes it doesn’t- so it will be hard to replicate.

1 Like

This has always happened to me, since SU7 when I started. I find it quite common. In particular when I tune ATIS into com 2 manually for airliners I’ve had it break like this quite often. I’ve also had it in GA with only one com receiver.

2 Likes

I experienced it in the Fenix A320 and even after turning off the radios, the ATIS message still played.

At least on the C172 with the steam gauges, the Bendix King KMA-26 is a softkey solution.

In theory, if the ATIS is on COM2, (and the led is showing COM2 as RX Monitoring), just click on the button to deselect and the light should extinguish. It’s a weird configuration how the sim works the active channel (personally I would prefer to have a hardware option that emulates the KMA-26 (and works with the logictech radio panels) and not have to rely on the ATC popup window to switch COM1 and COM2

I am experiencing this when I enter the airspace around Washington DC. I didn’t know this bug report existed until today, but can confirm that it also occurs at my end.

2 Likes

I too have been having the non-stop ATIS issue. I’ve tried about every means of getting rid of it and it repeats incessantly regardless of if I try to change frequencies or stop it in the middle or the quiet part of the transmission. What is odd is that the ATIS is local for roughly my area at an airport 90 miles away and the frequencies do NOT show that ATIS to be tuned in anywhere. I actually hold a PPL (albeit a rusty one) and know this is NOT normal.

I used to see this happen occasionally for no particular reason that I can trace in previous distributions, but seems more pronounced in the last beta distribution 1.27.14.

1 Like

Regardless what frequency I choose, ATIS keep displayed at the bottom of the ATC window…
The plane is new Bonanza.


I can replicate this anytime around the Bay Area USA. Takeoff from KSFO and It should happen. In the fenix A320 I’m able to end the repeating cycle by changing the “active” com radio select button on the radio management panel.

After digging into this further I found that the frequency set in the simulator “automagically” corresponded to a small obscure airport of which I was unaware at 47 miles out. The sectional indicated the CTAF to be 122.8, but the airport information indicates an AWOS broadcast on that same frequency. Apparently in comes into range according to the simulator at about 15 feet off the runway at KAAA Logan County and starts blaring away. If I get it “untuned” the other “automagic” frequency is KCMI, Champaign rather than the closer KSPI, in Springfield, IL.

Part of the problem appears to be that the stations are just in range and there is no immediate response from the simulator to attempts to shut off COM1 a/o COM2.

To others having this problem, I suggest you check to see if you are seeing similar frequency issues. It still does not solve the problem of the COM buttons not shutting the broadcast down immediately, but it does help explain in part what is going on. Maybe this is by design, but it is not how things work IRL.

The issue you are describing is different than the one in the OP, a bug report exists for that:

I’m still getting this issue where the ATIS keeps taking to me after I’ve changed the channel away from it. Usually if I retune to the ATIS, wait for it to restart it’s transmission and then tune away it will stop.

1 Like