Bad performance (Low FPS) with World Update 3 and new London photogrammetry - possible memory leaks

Someone mentioned on AMD turning off virtualization options in the BIOS will help it use a core to the fullest. At least 1 core should be maxed out when running normal.

No wonder people are having issuses over London ultra settings 100 scale 1080p monitor . My 3090 is showing 15.5 gig vram and 16.7 ram on a clear day . This is sitting at London city airport Orbx. turn on VR rises to 17 gig vram.

Hi,

as already said, check the commited memory :wink: … use resource manager.
You will possible "surprised ".

1 Like

But not just, especially with a 3090:

I happen to get CTD’s after having MSFS open for more than 3-4 hours plus. No error messages…

  • I fly the A32NX by FlyByWire
  • I use liveries from ProjectMegaPack
  • I fly with PacX for passengers
  • I use Volanta to track my flights
  • I use FSUIPC 7 to make tracking with SimConnect possible for applications such as ACARS and/or PacX, etc.
    • I have made sure that FSUIPC 7 doesn’t track AI data with the following line: “ProvideAIdata=No”. This is because issues occured with SimConnect and FSUIPC 7 for some time ago, don’t know if this issue is still present, but it reduces the stress on SimConnect.
  • I use Navigraph Simlink, to track my aircraft on Navigraph charts application.

I never had any issues before the World Update 3. And never any CTD’s. I could always fly with the A32NX and all the above addons without any issues, but since the latest update from MSFS, I can’t any longer.

My specs are:

  • i7-4790
  • 16 GB ram
  • RTX 2060 Super 8 GB

I get this in the event viewer log:

  • FlightSimulator.exe
    • 1.13.16.0
      602a34d1
      CoherentUIGT.dll
      2.9.5.0
      5fc6aa59
      c0000005
      000000000013f507
      2f94
      01d70b80417ea623
      D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
      D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\CoherentUIGT.dll
      966e80b6-e14e-47fe-bdd8-b01f68439587

Also I get this error in the FSUIPC 7 log:

  • 501922 Planned flight from EKCH to GCLP
    • 501922 C:\USERS\SSUPE\APPDATA\ROAMING\MICROSOFT FLIGHT SIMULATOR\MISSIONS\CUSTOM\CUSTOMFLIGHT\CUSTOMFLIGHT.PLN
      502110 C:\Users\ssupe\AppData\Roaming\Microsoft Flight Simulator\MISSIONS\Custom\CustomFlight\CustomFlight.FLT
      13598938 Failed on SimConnect_CallDispatch for Message, return = 0xC000014B
      13601579 MSFS no longer running - exiting
      13601579 === Hot key unregistered
      13601579 === Stop called …
      13601579 === Closing external processes we started …
      13602594 === About to kill any Lua plug-ins still running …
      13603735 === About to kill my timers …
      13603735 === Restoring window procs …
      13603735 === Unloading libraries …
      13603735 === stopping other threads …
      13603735 === … Button scanning …
      13603844 === … Axis scanning …
      13603938 === Releasing joystick devices …
      13603938 === Freeing macro memory
      13603938 === Removing any offset overrides
      13603938 === Clearing any displays left
      13603938 === Calling SimConnect_Close …
      13604047 === SimConnect_Close done!
      13604047 === AI slots deleted!
      13604047 === Freeing button memory …
      13604047 === Closing my Windows …
      13604047 === Freeing FS libraries …
      13605047 === Closing devices …
      13605047 === Closing the Log … Bye Bye! …
      13605047 System time = 25/02/2021 18:59:07
      13605047 *** FSUIPC log file being closed
      Minimum frame rate was 19.0 fps, Maximum was 110.7 fps
      Average frame rate for running time of 13385 secs = 32.4 fps
      Memory managed: 2 Allocs, 1 Freed
      ********* FSUIPC Log file closed ***********

this is a performance topic :wink:

because users often forget to read the README-FIRST :slight_smile:

for the core sim (not mods or 3rd party content)

and again the sentence from my clipboard:

have you checked your windows virtual memory setting as we described it some hundred times ?! ( also FAQ mention it )

I have a high end system and never seen frame rates fall to less than 30FPS (driving a 4k monitor) with graphics on “Ultra”, generally they’re in the 40 to 55 range wherever I fly in the world. The issue started with World Update 3, and is not only in the London area. This morning I was on a 2-1/2 hour flight (Clear Skies) from EGPK to EGLI and FPS started as usual in the 40-55 range. After about 30 minutes the GPU load would drop randomly from 100% to 60-70% and the FPS drop down to the mid 20’s. After a few minutes they would return to normal. As the flight progressed these GPU load drops increased in duration and frequency and the FPS dropped even lower. For the last 30 minutes of the flight the simulator was stable with the GPU load at around 40% and the FPS pegged at 17 -almost unflyable. My system is:

  • Intel Core i9-10900K 10-Core 3.7 GHz CPU
  • Corsair Dominator Platinum RGB 64GB (4x16GB) DDR4 3466
  • ASUS ROG Strix GeForce RTX3090 O24G
  • nVidia GeForce Driver V461.72

After quiting FS2020 and rebooting the PC everything was back to the usual 100% GPU load @ around 45FPS. However after 15 minutes of flight the cycle of random GPU load and FPS drops has started again…

Voted

If you are experiencing this issue, please vote to bring it to Asobo’s attention.

1 Like

Glad to see that its not an AMD /Intel thing. This is exactly what i was describing in a previous thread happening to me.

My system
Ryzen 5900x
32 GB Gskill Trident Z Neo DDR4 3600
Powercolor Red Devil 6800XT
Radeon Software 21.2.2

I have voted!

I’m amazed nobody has replied to you on this yet.

How did you turn on mesh mode? This seems like it would be a really good tool to hunt down, screenshot and report reversed faces (is there a mode to enable face-fill or similar?) and other nasty stuff like janky lines and generally just triangles where they don’t belong, etc.

Granted, everything looks scary in wireframe mode, but looking at just this screenshot you posted, I can see buildings which should absolutely have FLAT roofs, consisting of maybe 2 triangles, that look like they have a weird central point of elevation on them and thus many more triangles than probably makes sense…am I seeing things or do you see that too?

1 Like

I don’t know why, but I’m glad you’re asking!

You just need to enable Developer mode and navigate in the View menu. I’ll update this post later with the exact label if you don’t find it.

I can see indeed poorly optimized polygons leading to displaying more than necessary in general, more than necessary even more in the distance, and other errors related to flatness indeed.

What I really don’t get at all with FS2020 3D modeling and optimizations, is that Microsoft has purchased a company specialized in this tech and they are not using it for FS2020.

The company is Simplygon and I’ve already mentioned it in a few posts:

LOD problems - Trees Fix Revisited - #92 by CptLucky8

Landmarks shifting up and down + Half of them not loading correctly (still not fixed in 1.13.16.0) - #42 by CptLucky8

With Simplygon they could in theory among other things:

  • Reduce LOD model complexity while PRESERVING the overall shape (aka anti melted buildings)
  • Generate impostors in the distance preserving details and transparency.
  • Automatically bake AO in the cockpit and save pixel shader resources for the rest.
  • And much more.

I’ve no doubt Asobo’s engine is already doing some of these things, but there are definitely cases we can see in the game where the mesh and polygons could benefit more from this technology (on paper at least, maybe it is not this much effective in practice).

PS: don’t miss PG mesh holes as well:
[World Update 3] London Photogrammetry Mesh Holes

1 Like

This appears to me to be the same issue as the thread below:

They should be linked together and the Votes combined.

Haven’t had this problem since the launch until the world update 3. For the past 2 flights over 1:30 hour, this annoying problem hit back.

I also experience random drops in framerate, where the frames suddenly drops from 30 fps (v-sync on) in 4k to 15 fps for 10 seconds up to one minute before it recovers back to 30 fps again. During this period the “manipulator” in developer mode is heavily impacted, and the graphics card almost idles at 30 to 50 percent performance.
I suspect it relates to a data / cpu issue, however I haven’t had this problem until world update 3. The drop in frames seems to happen at random, however maybe when flying close to ground, near an airport, and also flying over area with no photogrametry.
I have tried updating bios and reinstalling the entire computer, however the problem is still there.
My specs are:
Ryzen 9 3900X
Asus TUF RTX 3090 OC
Corsair 4x 16GB 3200 MHz ram
1TB Seagate FireCuda 520, PCIe gen 4
ASUS ROG Crosshair VIII Hero
Corsair RM 1000W power supply

1 Like

Hey, I experience similar issues with the A32NX, and am not sure if it is the airplane or the sim yet. Can you try seeing if you get the same fps drop and rebound at the same location again? Also, do you have custom scenery installed in the areas where the drop occurs?

1 Like

Yes i also found Out that custom scenery ist causing more chances of slowdowns. For example Drzewieckis Chicago Landmarks. I still think its a vram leak.

1 Like

Hi, I am currently checking the drop out using dev mode. The fps drops from 50 to 18 consistently, not any lower not higher. Then comes back up in a minute or so. During this time, the “manipulator” frametime and the mainthread frametime is excessively high (>50ms) from around 10ms during normal ops. This happens on the A32NX custom FBW mode.

It seem to me random and no, I havn’t sceneries installed.

I am also getting dreadful performance when flying low through London only. Not getting this with new york or any of my other dense 3rd party addons. I have to believe this is the result of 2 things. 1) High density in London. Many many buildings and structures. 2) Poor optimization. I don’t think Osobo has enough time to optimize the scenery as the 3rd party creators do. I would love to have this optomized. I love the city, but the drastic drop in fps ruins it for me.

1 Like

Something is definitely wrong with this update I ran my game on ultra before and had steady fps 35-40 now I’m getting low 20s

I’ve changed all settings and the only thing that makes a difference is the Terrain Level Of Detail something is definitely bugged with it. My sliders were both set to 100 before the last update. When I drop the slider for terrain level of detail the fps go back to what I was getting before

But when flying the terrain looks terrible my fps was perfect before the latest update I don’t get it