Bad performance (Low FPS) with World Update 3 and new London photogrammetry - possible memory leaks

Which might relate to what I’ve written here:

I have the same issue becuase of i had and have at big Airports,Citys and Airplanes low Fps between 15 - 20 FPS… My Gpu is bored at 6% and my CPU runs at 30 - 41%.

FPS at FL360: 33 -35

MY System

Msi Rtx 2070 Super
Ryzen 3 3600
16 Gb 3200 Mhz Ram

in the Air near EDDF

at the Ground in EDDF

performance ground eddf 25c

regards Legendsy

a note: please don’t trust this GPU counter within wihtin the taskmanger without checking this thread:

Beside of these are “big” airports just “big airports” and without the knowing of your resolution / in-game settings (LOD,etc) / etc. nobody can compare your numbers :slight_smile:

EDIT : and here possible for interesst … what we already say’d

If it is confirmed; I’ll ugrade from 32gb to 48 or 64 if it’s possible.

I think the application have to be optimized related to memory consumption ( e.g. memory usage depend on existing RAM ) . But for a gaming-pc is an upgrade from 16 to 32GIG allways a good idea, at least for a application like MSFS.

16GB yes. But my Ram usage in London is never more than 26-27 of my 32… so i guess an Upgrade would bring nothing…

Problem is the VRAM for me as the 8 GB of my 3070 (■■■■ you Nvidia) is almost full all the time…

Playing with i7 9700k and RTX 3070, 32 GB RAM

I found that disabling many startup programs resolved a lot of stuttering.

I went to System Configuration (msconfig), disabled (uninstalled) CCleaner, Adobe’s CCXProcess, and OneDrive. I only manually update to OneDrive, and I no longer subscribe to Adobe products, so I axed both of those. And I deleted CCleaner as I have an Asus mobo w/AI Suite 3 which does a great job keeping my machine clean and helps with updating BIOS too.

Also so to msinfo32 to see what programs may still may be launching. After disabling Adobe CCX Process and OneDrive, I found it was still launching at startup. Google for info on how to completely disable those, but be careful.

Flying out of London City Airport and over London Landmarks, I get about 30-40 fps with rare stutters, and the same with ORBX’s Cityscapes Sydney Australia Landmarks - about 38-42 fps. On a side note, if you don’t already own Cityscapes Sydney, get it and fly about 45 minutes before sunrise! ■■■■■■■ unbelievable work!

~ Frank
i9 3.70GHZ | 32GB DDR4 3000 RAM | NVidia Geforce RTX 2060 Super 8GB GDDR6 | 1TB WD Blue SSD M.2 | Asus Z490-V ATX Mobo | Intel WI-FI 6 AX201 5GHZ | WIN 10 64

1 Like

Someone mentioned on AMD turning off virtualization options in the BIOS will help it use a core to the fullest. At least 1 core should be maxed out when running normal.

No wonder people are having issuses over London ultra settings 100 scale 1080p monitor . My 3090 is showing 15.5 gig vram and 16.7 ram on a clear day . This is sitting at London city airport Orbx. turn on VR rises to 17 gig vram.

Hi,

as already said, check the commited memory :wink: … use resource manager.
You will possible "surprised ".

1 Like

But not just, especially with a 3090:

I happen to get CTD’s after having MSFS open for more than 3-4 hours plus. No error messages…

  • I fly the A32NX by FlyByWire
  • I use liveries from ProjectMegaPack
  • I fly with PacX for passengers
  • I use Volanta to track my flights
  • I use FSUIPC 7 to make tracking with SimConnect possible for applications such as ACARS and/or PacX, etc.
    • I have made sure that FSUIPC 7 doesn’t track AI data with the following line: “ProvideAIdata=No”. This is because issues occured with SimConnect and FSUIPC 7 for some time ago, don’t know if this issue is still present, but it reduces the stress on SimConnect.
  • I use Navigraph Simlink, to track my aircraft on Navigraph charts application.

I never had any issues before the World Update 3. And never any CTD’s. I could always fly with the A32NX and all the above addons without any issues, but since the latest update from MSFS, I can’t any longer.

My specs are:

  • i7-4790
  • 16 GB ram
  • RTX 2060 Super 8 GB

I get this in the event viewer log:

  • FlightSimulator.exe
    • 1.13.16.0
      602a34d1
      CoherentUIGT.dll
      2.9.5.0
      5fc6aa59
      c0000005
      000000000013f507
      2f94
      01d70b80417ea623
      D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
      D:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\CoherentUIGT.dll
      966e80b6-e14e-47fe-bdd8-b01f68439587

Also I get this error in the FSUIPC 7 log:

  • 501922 Planned flight from EKCH to GCLP
    • 501922 C:\USERS\SSUPE\APPDATA\ROAMING\MICROSOFT FLIGHT SIMULATOR\MISSIONS\CUSTOM\CUSTOMFLIGHT\CUSTOMFLIGHT.PLN
      502110 C:\Users\ssupe\AppData\Roaming\Microsoft Flight Simulator\MISSIONS\Custom\CustomFlight\CustomFlight.FLT
      13598938 Failed on SimConnect_CallDispatch for Message, return = 0xC000014B
      13601579 MSFS no longer running - exiting
      13601579 === Hot key unregistered
      13601579 === Stop called …
      13601579 === Closing external processes we started …
      13602594 === About to kill any Lua plug-ins still running …
      13603735 === About to kill my timers …
      13603735 === Restoring window procs …
      13603735 === Unloading libraries …
      13603735 === stopping other threads …
      13603735 === … Button scanning …
      13603844 === … Axis scanning …
      13603938 === Releasing joystick devices …
      13603938 === Freeing macro memory
      13603938 === Removing any offset overrides
      13603938 === Clearing any displays left
      13603938 === Calling SimConnect_Close …
      13604047 === SimConnect_Close done!
      13604047 === AI slots deleted!
      13604047 === Freeing button memory …
      13604047 === Closing my Windows …
      13604047 === Freeing FS libraries …
      13605047 === Closing devices …
      13605047 === Closing the Log … Bye Bye! …
      13605047 System time = 25/02/2021 18:59:07
      13605047 *** FSUIPC log file being closed
      Minimum frame rate was 19.0 fps, Maximum was 110.7 fps
      Average frame rate for running time of 13385 secs = 32.4 fps
      Memory managed: 2 Allocs, 1 Freed
      ********* FSUIPC Log file closed ***********

this is a performance topic :wink:

because users often forget to read the README-FIRST :slight_smile:

for the core sim (not mods or 3rd party content)

and again the sentence from my clipboard:

have you checked your windows virtual memory setting as we described it some hundred times ?! ( also FAQ mention it )

I have a high end system and never seen frame rates fall to less than 30FPS (driving a 4k monitor) with graphics on “Ultra”, generally they’re in the 40 to 55 range wherever I fly in the world. The issue started with World Update 3, and is not only in the London area. This morning I was on a 2-1/2 hour flight (Clear Skies) from EGPK to EGLI and FPS started as usual in the 40-55 range. After about 30 minutes the GPU load would drop randomly from 100% to 60-70% and the FPS drop down to the mid 20’s. After a few minutes they would return to normal. As the flight progressed these GPU load drops increased in duration and frequency and the FPS dropped even lower. For the last 30 minutes of the flight the simulator was stable with the GPU load at around 40% and the FPS pegged at 17 -almost unflyable. My system is:

  • Intel Core i9-10900K 10-Core 3.7 GHz CPU
  • Corsair Dominator Platinum RGB 64GB (4x16GB) DDR4 3466
  • ASUS ROG Strix GeForce RTX3090 O24G
  • nVidia GeForce Driver V461.72

After quiting FS2020 and rebooting the PC everything was back to the usual 100% GPU load @ around 45FPS. However after 15 minutes of flight the cycle of random GPU load and FPS drops has started again…

Voted

If you are experiencing this issue, please vote to bring it to Asobo’s attention.

1 Like

Glad to see that its not an AMD /Intel thing. This is exactly what i was describing in a previous thread happening to me.

My system
Ryzen 5900x
32 GB Gskill Trident Z Neo DDR4 3600
Powercolor Red Devil 6800XT
Radeon Software 21.2.2

I have voted!

I’m amazed nobody has replied to you on this yet.

How did you turn on mesh mode? This seems like it would be a really good tool to hunt down, screenshot and report reversed faces (is there a mode to enable face-fill or similar?) and other nasty stuff like janky lines and generally just triangles where they don’t belong, etc.

Granted, everything looks scary in wireframe mode, but looking at just this screenshot you posted, I can see buildings which should absolutely have FLAT roofs, consisting of maybe 2 triangles, that look like they have a weird central point of elevation on them and thus many more triangles than probably makes sense…am I seeing things or do you see that too?

1 Like

I don’t know why, but I’m glad you’re asking!

You just need to enable Developer mode and navigate in the View menu. I’ll update this post later with the exact label if you don’t find it.

I can see indeed poorly optimized polygons leading to displaying more than necessary in general, more than necessary even more in the distance, and other errors related to flatness indeed.

What I really don’t get at all with FS2020 3D modeling and optimizations, is that Microsoft has purchased a company specialized in this tech and they are not using it for FS2020.

The company is Simplygon and I’ve already mentioned it in a few posts:

LOD problems - Trees Fix Revisited - #92 by CptLucky8

Landmarks shifting up and down + Half of them not loading correctly (still not fixed in 1.13.16.0) - #42 by CptLucky8

With Simplygon they could in theory among other things:

  • Reduce LOD model complexity while PRESERVING the overall shape (aka anti melted buildings)
  • Generate impostors in the distance preserving details and transparency.
  • Automatically bake AO in the cockpit and save pixel shader resources for the rest.
  • And much more.

I’ve no doubt Asobo’s engine is already doing some of these things, but there are definitely cases we can see in the game where the mesh and polygons could benefit more from this technology (on paper at least, maybe it is not this much effective in practice).

PS: don’t miss PG mesh holes as well:
[World Update 3] London Photogrammetry Mesh Holes

1 Like

This appears to me to be the same issue as the thread below:

They should be linked together and the Votes combined.

Haven’t had this problem since the launch until the world update 3. For the past 2 flights over 1:30 hour, this annoying problem hit back.