Blinking clouds after patch 5

Thank you Hester40MT

Same problem here. Tried turning graphics all the way down and issue persists.

My specs:

Windows 10 Pro 64-bit (10.0, Build 19042.630)
Intel® Xeon® E5-1607 v2 @ 3.00 GHz 
128 GB RAM
NVIDIA Quadro K5000 (Kepler)
4 GB GDDR5 RAM
DirectX 12

So that’s it?

We, the few hundreds of people not willing, or not wealthy enough, to buy a new graphic card, have pointed out the bug, have created ZenDesk reports, and here is the answer from developer: “we do not know if/when the flickering issue will be resolved”.

I’m feeling so ripped off and frustrated. I loved to play the game, when it was not broken.

4 Likes

It’s a relatively basic texture flickering problem that Microsoft should have the ability to address.

Given all the launch hype and all the assistance from the community it’s more than disappointing that a hot fix has not been issued to date.

Also yesterday I visited the Microsoft development update on this forum which also has a top bugs …and things like lack of powerlines are listed there …but this epilepsy inducing screen flickering is not listed!

Anyway I would welcome some of the YouTubers who boast about the flight simulator all the time to finally address some of the shortcomings and perhaps something will finally get done about this problem for thousands of people still using NVIDIA Kepler GPU architecture.

3 Likes

yeh, don’t count on that. Those youtubers are most likely running recent hardware.

1 Like

I’m not so optimistic.

I’m conviced that our case, the poor owners of outdated graphic cards/PC unabled to fly with clouds anymore, will be ignored.

We, and I, are insignificant. We, with our ancient outdated PCs, running GTX 770,
represent what? Nothing. 1% of their business, at best. Probably far less.

I guess we are less than 1,000 worldwide users to have the clouds flickering issue.

They won’t fix the problem for us. They have very much important things to do. We are an unfortunate detail.

5 Likes

Rightful but negligible.

Unfortunately the chances of a YouTuber, most of which play their games on bleeding-edge hardware, doing something to bring visibility to the issue, are slim to none, and even if they did, most people would hardly care.

I created a thread about the shifting system requirements issue on the Developer Q&A section to try and get this addressed publicly in the next one, and not only is the amount of votes extremely small compared to everything else, but the first response I got was someone telling me that I should not bother Asobo with my request to dumb-down the game and that I should upgrade my “garbage system”. Some of the posts were so rude they were deleted by a moderator.

People will not care about what is happening to us until it happens to them.

5 Likes

As this issue remains unfixed, the brands Microsoft and Asobo will lose my confidence and will spread the word in Twitter. You can be sure. We should all do the same if this isn’t fixed in the upcoming weeks. I feel I have wasted my money.

No good.

3 Likes

I’ve thought of something. Is anyone affected by this issue playing the Steam version? If yes, I think it might be worth trying out DXVK (DirectX 9/10/11 to Vulkan wrapper) and see if it does anything to resolve the problem.

There is a video on YouTube showing the simulator working on Linux using the wrapper, which means it should work on Windows as well. Unfortunately I have the Microsoft Store version of the game so I cannot try it myself (it does not allow external DLL files to affect the application due to encryption), but anyone with the Steam version should definitely give this a try.

1 Like

I gave it a try - still bad flickering. In fact it looked worse on my test. Thanks for the heads up Chaotic, it was definitely worth a shot and was excited give it a go.

1 Like

Bummer. Thanks for trying it out and the heads-up. I’ve seen it resolve an artifacting texture issue in another game (which affects all NVIDIA GPUs from Maxwell 1.0 and newer) so I was hoping it’d do something in here as well.

I’m still not sure what architectural feature could be causing this issue. Maxwell 2.0 brings support for Direct3D 11.3 and VXGI (voxel global illumination), though I can’t find confirmation regarding the former being supported on GCN 1.0 and the latter seems like an NVIDIA proprietary technology.

I really wish they would just come forward regarding this new cloud rendering system and update the system requirements already. Things like these shouldn’t be glossed over in the patch notes. With evidence that this might be an overlay/window drawing error, we have no idea whether it’s a simple or complex bug fix and whether it would be reasonable to fix this for the affected GPUs.

1 Like

We need to react now !

1 Like

Guys I’m so disappointed and how Asobo ignore the problem is amazing ! F*** that we want to play ! I dont know why I keep my Xbox Game Pass subs, i will cancel it i’m so disappointed about that.

1 Like

I’ve been trying to get a refund on steam but no luck so far.

I have a workaround for this:

  1. Move view away from a window, eg. on a 787 look up towards the upper panels.
  2. Go to the weather toolbar.
  3. Select Clear Skies first.
  4. Select Live Weather.
  5. Try looking out a window at this point.

My specs are:
i7 3610QM
GTX 670m overclocked to 720MHZ to avoid the loading screen crash
16GB RAM

Did not work for me ShellLettuce23. I still end up with what appears to be clear skies. Then if I click other menu items or ESC it starts flashing again. Not only cloud outlines flashing but I can see the outlined shapes of jetways or other items stuck on screen and flashing. Thanks for the suggestion anyway.

BeachBum5691: Yes you do have to redo the whole set of steps again if you go to the pause menu or somewhere where the flashing happens again. So far for me as long as I don’t enter the pause menu, everything is fine.

Regarding steps 3 and 4, might need to switch back and forth multiple times and sometimes switch to other than Clear skies.

How about pepole like me have laptop with GTX 960M and can’t upgrade the GPU Card :pensive: … this is so bad ASOBO

3 Likes

Please VOTE at the top of this thread, if you have not already done. Thanks.

1 Like