Bobbing (Tilting) head up and down in cockpit view (plane's dashboard goes up and down)

In cockpit view when I tilt my head up and down the hole plane seem to go up and down?

Same effect when turning head left and right.

Try it yourself… just a small quick little knod and the plane will seem to move around way to much.


Try selecting reproduction mode in steam vr settings

Oh sorry, I forgot to mention im using hp reverb g2, windows store msfs2020 version, openxr render scale 50% , disabled projections.

I wonder if inside out tracking is picking up incorrect up down translation instead of rotation… something like that.

When I first started with my G2, I had a few similar tracking problems - mostly it would lose translation altogether and just rotate.

After some screaming and yelling and tearing of hair, I calmed down and did some investigation. It seems if you don’t have reasonably uniform room lighting, the G2 can drop tracking. This is one of the ‘features’ that has been attracting some criticism of the unit.

I now use mine in my study with the blinds down and the main room light on. Had no problems with tracking since.

The odd translation like effect only happens inside cockpit. When in the external view or in other games its not an issue.

yep, that’s odd. Not encountered that behavior.

Make a gardian. I had the same problem

You’re right my guardian isn’t setup! Very interesting I will try… thanks

So tried setting up boundary but that did not change anything.

Also tried running openXR app at custom 100% render scale and in msfs2020 graphics 50%. But didn’t have any effect besides looking worse.

It’s like the center point of movement isn’t at your neck, it’s like at the front of the headset

Does not happen in cliff house or anywhere else, only on msfs so far and only in cockpit

9900k, 3090rtx, reverb G2


I noticed this last night too. I hadn’t noticed it before but I think you’re right, the centre of rotation feels wrong.
I wonder if this was caused by the recent updates to the Windows OpenXR runtime?

Do you all use the “Preview OpenXR runtime”?
(I’m working right now :slight_smile: but maybe someone can test using both Preview and Release versions?)

im using preview, but im sure it was the same on current

1 Like

I have exactly the same issue. As if the center of rotation was not on my head. It’s a kind of distortion or parallax issue. It’s not too huge so I’m getting used to it but if it can be fixed it would be clearly better. I’m using the hp reverb g2 with WMR openxr preview runtime (same issue with normal runtime) and have tried different supersampling values without success.


Tried both just to see…but theres no difference

1 Like

Is anyone using (or tried) the SteamVR OpenXR implementation with a G2?

I’ll try this when I get a chance to see if this is any different (i.e. to try to pinpoint Microsoft OpenXR as the culprit - as it sounds like Oculus OpenXR doesn’t suffer with this…)

1 Like

My game wasn’t bought through Steam though.

I can’t say I noticed any issue with it, on either wmr or steam versions of OXR.

The only thing that I can think of is that there is a bug when reprojection is enabled at 50-60ish% OXR resolution there is severe distortion on the current windows OXR runtime. Turning off reprojection stops it.

1 Like

Thanks for letting me know.

I’ve seen the “distortion” bug with reprojection but this isn’t that effect. It’s a bit different.
I still haven’t had a chance to investigate myself (unfortunately real life prevents me from getting much flying time!) but the last time I was flying, I had windows OXR runtime at 90% with reprojection off and I noticed the effect described in this thread, so I don’t think that’s the cause.

Thanks anyway, appreciate you taking the time to reply!

1 Like

Do you get the issue on other games?

Generally most oddities for the G2 come down to varying levels of USB incompatibility in my experience…

I don’t really play many other games - however, I did have a quick play with HL:Alyx and didn’t notice it there.
I also don’t get it in the WMR Cliff House - so it only seems to be when something invokes OpenXR. Thinking about it - one thing I haven’t checked is the OpenXR Demo scene!