[BUG LOGGED] Always "Continue in Safe Mode" message

The same behavior I noticed at the MS Store version. From the Store you can only create a shortcut at the start menu or task bar. If I create a shortcut at the desktop and start MSFS I also get this error message. If I start the sim from the store, task bar or start menu, no error message.

Today perfect startup from desktop icon

Perfect takeoff cyul to kpdx

All aircraft systems worked great

Flight start at 2:00 pm eastern time USA
3:00 pm eastern time USA CTD

Today I received no errors on startup?

Yesterday many reboots with message. “ cannot login ……safe mode”. The CTD is normal since update 5.

No changes to my PC

Same flight Cyul kpdx

Startup on icon and warning “ cannot log in.,…”

Ignored and continued with good startup

Flight start 5:30 pm eastern USA.
Everything looks great works great

6:30 pm CTD. 1 hour again in flight

Both identical flights CTD after 1 hour

1/2 hour flight last evening worked great with no CTD

Disabled real time weather and real time traffic
Flight was successful with no CTD

I removed the Bredok3d 737 Max, restarted, and never got the warning again. Possibly this addon (1.5) is bad, or the “Marketplace” is not installing addons correctly. I only experimented with the 737 Max, possibly other Marketplace addons cause similar problems in SU6.

Several aircraft in the marketplace are waiting for a patch to be ready and by all accounts it’s not a quick process because thorough testing is needed by Microsoft before encryption and release. My only advice is to store your MAX and any others that cause problems in a new folder until there’s a patch available. It is very unlikely they will miraculously just start working without one.

Today’s hotfix seems to address this topic.

  • Safe mode will no longer trigger when a crash occured when closing the program

https://forums.flightsimulator.com/t/hotfix-release-notes-version-1-19-9-0/454525

The funny thing here is that they not fix the cause, but the result… The message has indeed disappeared but if you look in the Windows eventlog the sim is still crashing everytime you exit the sim…

2 Likes

I am using a PC and my game did crash 2 days ago but has been working fine since.
I am using the Microsoft Version from the Microsoft Store.

Now every time I load the game I see this splash screen.
I have tried just loading the game and exiting nicely through the menus then re-loading but I get this message all the time.

This has not been fixed for me… and yet when I click “exit to desktop”, the sim sometimes still crashes… but the times it does NOT crash and just goes back to desktop, I still get this message every time.

I did a fresh install over the weekend, and now I dont get that anymore. Before if I launched from steam (ms store) in otheres cases, it wouldnt do it either loaded just fine.

not fixed for me either

1 Like

It is also not fixed for me… Still getting the safe mode option when starting the sim even after a normal quit

Uninstalling your 3rd party addons and removing all files from community should fix this

It’s baaack! This is messed up. Flew fine yesterday. Started today and system (not aircraft) crashed while loading. Got the dreaded notice. Attempted to load in safe mode and it crashed again. On a whim, tried to load in normal mode and it loaded OK. Go figure. I’ve implemented all the above suggested fixes and this still happens. I’d use stronger language about how messed up this is but don’t want my comments cancelled.

The crash is a trigger, I can repeat it by closing in task manager but why would I? Something with YOUR system or install isn’t quite right but expecting a full diagnostic service is really asking a lot.

OK. When I said “system” I meant MSFS not my win10 OS. And who is expecting full diagnostic services from a forum? Lots of folks appear to have this issue. Something in the last update caused it. What’s the fix?

i have this problem too

I have been getting this since the latest update. I only have one custom in my community folder (Bijan Seasons)… but I also had a Nvidia driver update shortly after the MSFS2020 update. I can tell you if i empty out the community folder- i still get it. If I try to start in normal- I get memory stack overflow threatening that someone can take over my pc shortly before finishing the airport load (after hitting “fly”)… If i don’t hit ok on the error, the program runs to the point of being ready to fly but then I acknowledge the error and the whole thing CTD. I’ve tried my old fix of turning of G-Sync on the nvidia driver and that doesn’t fix it.

I reinstalled and it fixed it. Its not a mod its the sim itself when it closes it kicks a ‘silent’ error, and that causes the popup. If I launched from steam it wouldnt do it, but if I launched from a link on the desktop it would. Eventually I reinstalled the sim (for other reasons not this one) and it was fixed.

1 Like

i am getting the “safe mode” “normal mode” message since SU5, doesnt matter if i close the sim properly or empty my community folder, i still get it.