[BUG LOGGED] CTD caused by Capture One 20 codec

:slight_smile:

the important hint is here mentioned:

CONFLICTS CAUSED BY AUDIO DRIVERS & OTHER APPLICATIONS

  • Capture One
1 Like

Just want to register my account to say thanks to your solution. I have captureOne 20 installed and it randomly crashed on me multiple time, can be within 5 mins to 1 hours flight.

With your dll rename fix, i am no longer experiencing crashes.

The state of modern software is really bad appearantly. This fixed the issue for me! Used to have CTD constantly after about 5 minutes of flight. The fact that a .DLL in Capture One 22 could be the culprit just shows how fragile and utterly bloated modern software has become.

This thing bit me again!

I recently updated to Capture One 22, and I’ve been having CTD in MSFS ever since. Random. Then I remembered this!

Renamed the codec, and so far so good! Thank you again @EmmaPeel7259 !!!

Weridest bug i’ve come across. Thanks for saving me from uninstalling and never playing, because i was about 5 seconds away from doing so

1 Like

Just a quick PSA: there is a new Capture One update out. When you install this, it creates a new DLL that you AGAIN have to rename as per the OP.

I confirm !
I installed the update and had a CTD in MSFS. Checked for the dll, it was back. Renamed it again. Problem solved.

It has unfortunately now become part of my Capture One update process: install C1 update, rename file, carry on. I don’t even go into MSFS before doing that any more.

1 Like

Thanks a million times! I’ve been struggling for years now beeing unable to play the game since it’s release. To think about it i lost so many hours of play not to mention my game pass subscripshion fee.
To finally find out that it there was a solution is such a relief! But also i’m quite disappointed by how MS and Asobo adress common issues. That is outrageous.

I too can confirm this bug. After many hours of suffering CTDs and trying to find the root of the problem, I stumbled upon this thread. Renaming the offending dll seems to be the cure!

This just bit me again :frowning: Installed Capture One 22 just after the latest MSFS update and got loads of CTDs. Reinstalled MSFS from scratch which took about a day, still got CTDs.

Then I remembered that Capture One 20 would cause CTDs, I wondered if Capture One 22 would do the same? And yes it did… renaming the offending dll fixed the problem.

And a big thank you to the OP EmmaPeel7259 for their post 13 months ago! :smiley:

This is a me too post.
Finally it seems I have the solution thanks to EmmaPeel7259.
I’ve used Capture One for years but no more.

A big thanks to EmmaPeel7259 for finding this. I can confirm this has cured my frustrating CTD around London City with MSFS2020. I have CaptureOne22 installed, renaming the dll has worked.

Well… had a lot of CTD’s and really at a loss. Found this thread and been flying over Rio de Janeiro for over an hour, where previously when starting the discovery flight, the CTD was almost instant. What a relief!!

What I don’t understand is that this issue is seemingly pretty well known now and not that new, but zero feedback from Adobe nor a fix? This should be high on their radar no?

the feedback is given in FAQ in list of apps which cause issues. And a fix must come from “capture one” and or “nvidia” ( both play finger-pointing together if you read the linked posts ).

Remember to make this change, once again, if you have now upgraded to CaptureOnePro 23.

2 Likes

Thanks a bunch! It seems like this finally solved the CTD issue I had for the better part of last year. What a random bug…

I’ve only just discovered this topic. For the last year I’ve been exclusively Xbox because every time I try to play the game on PC I get CTD within minutes.

Yesterday I uninstalled Capture One 20 (which I rarely use these days) and ended up flying on PC all day and only had one lockup (and that wasn’t a CTD).

Thanks for discovering this issue.

I can confirm that this fix is also working with Capture One 12, as i only recently installed MSFS 40th ann edition and had on a regular basis these CTD crashes after 10 to 20 minutes of game time. Solved it ever since, following the DLL renaming.

Many Thanks !

Same situation here. I have Capture One 12 installed and the CTD issues that were driving me crazy have not repeated after renaming that file.
Thanks to everyone