[BUG LOGGED] CTD caused by Capture One 20 codec

Hi,
Capture One 22 is out now.
I don’t know if the problem with MSFS persists.
Somebody has bought it or tried it?
Thank you,
Regards

Yes, the problem still persists with Capture One 22. I just tried it today. I moved to new hardware since I originally discovered the problem and Capture One 22 is the first Capture One Version ever installed on this system. So I can exclude that this is caused by any previoulsy installed C1 version.

While this is a little bit disappointing, the good news is that the workarround seems to work also with Capture One 22.

Yup, installed CO 22 and left files alone just to test. Instant CTD on takeoff roll. Renamed the offending file and all is well.

1 Like

Same prob here. I don’t have Capture 1, but still have a CTD on approach. It’s driving me crazy.

You wouldn’t believe this. Santa brought new camera, which came with free Capture One 22. Santa also bought IFE F-35. Of course MSFS Started crashing like never before. Of course it should be F-35.

And I could reproduce CTD at exactly the same place. E.g. TO at Montauk, always CTD in the middle of Long Island. Still thought it is F-35.

Then tried native F-18 - same crash at the same place! Cleared community folder. Same CTD!

Just removed Capture One - seems to be working fine now! Fingers crossed! Just had a full flight with F-35!

C1 version 21 here… and I kept getting CTD since last update. Just wanted to let everyone know, this fixed the problem! Unreal, and by renaming the *.DLL file I did not see any issues with Capture One either, so a win in both cases.

Thanks so much,

Thanks o lot! I have Capture One and I followed your instructions to rename that .dll and sim doesn’t CTD now :smiley:

I will definitely have a look into this. I have the occasional CTD. Yesterday on a Group Flight, I and another member had the exact same CTD at the very same moment and the same location, twice !
A CTD ok, at different locations ok, but at the very same moment and the very same location twice is really weird.
Both of us have Capture One as we do Photography. So I will check this out with great curiosity !

Thanks for the hint

this points more to

May be you can recheck the message from windows error log.

1 Like

I don’t have Capture One however from reading on here I believe a fresh (not upgrade) iso install of Windows 11 would fix this as it has Internet Explorer completely disabled by default, IMO any call for the rogue i.e. dll would just be ignored or could at least be denied.

I will have a look into this ! Thanks a lot for the help

Interesting ! Is there a link between C1 and Internet Explorer ? This might be something to look into indeed

not sure what was meant with “Internet Explorer”… the issue is a ( windows file - ) Explorer extension ( e.g for right-mouse action, preview, etc )… This you can disable in capture one or hardly remove the dll. See the linked post :slight_smile:

1 Like

Excellent ! I’ll check it out. Thanks

Glad I found this post. I had Capture One v21. Renamed the dll, no problems so far. brilliant. Also kind of strange that there would be this dependency

Thank you so much! After many frustrating hours of fruitless searching, this was the solution!
CLW

Quick warning/PSA: the “Capture One 20\WIC\WIC64\P1.WIC.NativeComWrapper.dll” file shows zombie-like (or Phoenix-like) abilities to rise from the dead! I recently started experiencing the odd CTD again out of the blue. And lo and behold, when I went to the new Capture One version 22 folders, there was the dreaded killer DLL! I have now renamed it again: hoping that will again restore my system to its former reliable operation.

Thank you SO much for this, it seems to have solved my CTDs which I was suffering for a few months now without any success on getting rid of them. Crashing on almost every flight…

Can’t believe MS/Asobo did not yet fix this issue even though the number of affected users is not high…

because its just not on here side … the fix must be delivered from capture one :wink: … it affects not only msfs.

I would accept this reasoning if they would at LEAST include this issue in the Known Issues and CTD Troubleshooting guide (which they usually refer people reporting their CTDs via Zendesk).
Since they did neither, I assume they simply ignore this fact for the time being.

It shouldn’t be depending on people randomly stumbling on a forum thread to get this solution…