[BUG LOGGED] CTD on loading - 100% reproducable - Account Issue

,

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version? Steam

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. No

Are you using Developer Mode or made changes in it? No

Brief description of the issue: When online, my friends istallation crashes. When Offline he is able to proceed and play but as soon as he connects to the internet, it crashes. It is 100% not hardware or network (LAN/WAN) related as I will explain (this may help others and Devs to understand the issue).

Provide Screenshot(s)/video(s) of the issue encountered: n/a - standard .exe has stopped working popup.

Detail steps to reproduce the issue encountered: My installation works perfectly with my credentials online. We used only my perfectly working PC to try to help the Devs understand the issue here.

Yesterday, because my good freind of 20 years was not getting anywhare after trying 3 PCs and 2 different networks, he gave me his steam and xbox account credentials as we ‘whatsapped’ for authentication codes etc.

I unlinked my Xbox live account from my perfectly working MSFS WU6 PC installation and logged out of Steam.

I entered his Steam login and launched MSFS2020.

MSFS2020 loaded to the point of Xbox authentication, I entered his credentials and proceeded. The blue bar filled quickly and then CTD at the same point he has been getting to since SU5.

I launched again once cleared, and used the safe mode option and it crashed at the exact same point .

I rebooted and launched again in normal mode when given the choice, it crashed again at the same point.

I logged out of his steam account

I logged into my steam account and launched MSFS2020, it got to the point where it recognised that my friends Xbox account was linked to his steam instance and it logged in with out trouble (offline mode I assume) I logged out of his Xbox account in MSFS and logged back in with my credentials. and the sim works perfectly again.

Conclusion: there is something wrong with the interaction between his Steam Account and his Xbox live account.

PC specs for those who want to assist (if not entered in your profile) n/a - because it is not related to the local installation

Build Version # when you first started experiencing this issue: SU #5

Are you on the Steam or Microsoft Store version? Steam

Did you submit this to Zendesk? If so, what is your ticket #? yes, #118778

Additionally, just for proof, today I gave my friend my credentials and repeated the procedure and he was able load the game, the blue bar took the normal amoun t of time to fill up and then fly no problem on his PC installation.

then he removed my credentials and adding his again… unlinked my Xbox account, logged back in with his credentials when it asked him for his credentials it logged in OK and he was able to fly no problem… we thought it was fixed. BUT, he closed the game down and now when he launches it, CTD at the same point as before!

Hope this helps the Devs workout where it is all going wrong withn his account and maybe others could test by going offline or if they have a good trusted freind, swapping credentials (you have to trust the other party of course!) to verify that the PC and installation is valid.

3 Likes

I feel I have been screaming this for a long time, here’s a vote to you!

I don’t understand whats causing this? I did the disable steam cloud save and delete the folder, I tried logging back into a diffenent xbox account and got the same results. I don’t have another steam account to test but I think it might be some sort of steam → Xbox/Microsoft credentials error rather than the opposite.
I really don’t know but I’m just guessing

Probably something to do with this game insisting on forcing your old settings and profile even if you completely uninstall the game. There is literally no way to do a “clean” re-install unless you made a new Microsoft account and bought the game again.

Eeek… I had something similar happen months and months ago, and the solution was not pretty. Essentially, I had to just write off my entire investment in MSFS, and buy it all again except from the MS Store instead of Steam. What happened to me was 100% Microsoft’s fault, my gamertag somehow got corrupted on my actual physical XBox, however, they kept pointing their finger at Steam, and Steam (rightfully) was pointing their fingers at MS, and I was spending so much time going around in circles that I figured it would cost me less in terms of time just to give up and rebuy everything.

Some might decide to walk away instead of spending money on brand new licenses they already owned, but I’m way too addicted to MSFS to do that. So I bit the bullet and just did it. The good news is that it did work, and I haven’t seen that problem repeat since. Since I no longer have a physical Xbox, and have no intention of doing so, it’s unlikely I’ll experience the same thing, but if somehow I do, at least now MS has nobody to point their fingers at except themselves.

Kev

Although completely unaware of this bug existing in MSFS, the corruption of gamer tag and actually all kinds of micro-issues regarding the MS account and roaming content in relation to and when linked with accounts of other platforms is familiar to me since the dawn of Windows 10 back in 2015.

Even more particular complications arose upon the unveiling on Windows Hello and the password-less authentication (for example the explicit use of PIN code).

I gave this a vote simply because this is one of those silent bugs that is actually not completely on Microsoft, yet it drags on, often taking multiple quarterly iterations of Windows updates as well as partner platforms’ updates to solve - but is just another one adding to the root causes behind so many of these unfortunate reports by users who suffer bizarre issues with updating the simulator, sub-par quality of the streaming data or photogrammetry, issues with the live traffic and weather and all kinds of unusual CTDs.

I shall go astray the topic with this for a moment:
the more able and sophisticated the ecosystem, the more complex the architecture is.
That is why the systematization is so important in 2021, the likes of which I find one of my favorite MSFS team members @Bishop398 works on, writes about and understands all too well.

If I understood correctly you made account-sharing ? I assume account sharing is nothing like a normal situation and related to “licenses” I’am would not sure about to do such things:

But yes, in theory a switch to a different account ( assuming yours ) should may be work if you own that game at both accounts. But not sure about all that account-linking in background.

Are there by any chance any non-ascii characters in your friends account name?

Maybe smth is wrong with steam cloud save data.
https://forums.flightsimulator.com/t/ctd-during-loading-game-even-after-clean-install/386252/6

Also install English (United States) language pack.

It was for a test, thanks for your concern.

@TenPatrol On your first point: No, steam saves are disabled since July for his account.

On your second: No, we are both English and have English US installed… have you read what I wrote? on both mine and his PC the game works OK with my credentials. On both mine and his PC it CTD’s with his credentials.

@Pieter1982NL No, alphanumeric only.

Big thanks to MrPix2020 for all his help on this issue, just to let you all know I have installed the game on 2 other PC’s which resulted in getting the same issue.

I can confirm after testing with a close friend of mine, the same exact thing is happening

My Steam & Xbox Login: CTD on my pc, CTD on my friends pc

His Steam & Xbox Login: Sim works on my pc, Sim (always) works on his pc

I did the disable steam cloud save and also delete, He did the same as well.
Same results as above.
I didn’t even log in onto my friends Xbox App or MS Store (not sure if it matters tbh) and the sim still worked
Like I said before, in terms of this issue there must be something wrong between my Xbox account and steam. EDIT2: Between my xbox & steam account with the MSFS servers**

1 Like

Any lead on a fix? I feel like this is out of our control per-se. This seems like a backend issue.

2 Likes

I really hope the devs take notice, I’ve been troubleshooting this for the last week without any success whatsoever. This is the exact issue I’m having and fixing these kinds of issues should be top-priority.

1 Like

I absolutely agree. I understand there’s a lot of different computers and different reasons as to why bugs/ CTD’s happen but the response I have been getting from Support for the past 2 months makes it seem I can’t do basic troubleshooting and that their system is no way faulty. like no, this is an issue I 100% don’t have control over

2 Likes

Alright guys, guess what? I got it working, just by getting the Game pass version on MS Store instead. Now my steam Premium edition is a complete pile of ■■■■ and I have to pay the same amount again but on MS Store to get access, huzzah!

@Ipreninen the issue is not fixed then, and you didn’t get it working. You worked around it by buying a version that does not require Steam<>MS Xbox Gaming interaction.

If this is the only way around it, at least MS should refund the cost of buying on the store OR make the store version available to thost that have bought it via Steam for free.

I take it you didn’t catch my irony. I have already asked for a refund on my steam version, which probably won’t lead further than to my zendesk ticket.

Imagine having to make your players do the ■■■■ troubleshooting, while the devs keep on sending automated messages to tickets…

Oh, I did catch it, I was just making sure the Dev’s din’t read it as ‘I’ve found a solution’ !!

1 Like