[BUG LOGGED] Elevator trim doesn't work as pre-SU5 and it's impossible to fly

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

No

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Basically one click of elevator trim on my joystick (Saitek X55) moves the elevator trim of the aircraft by a huge amount and it causes the aircraft either to rocket climb or dive.

Before SU5 to make a big movement of the elevator trim, you had to keep the button pressed on the joystick. Now it’s completely the opposite: too exaggerated.

Provide Screenshot(s)/video(s) of the issue encountered:

not needed

Detail steps to reproduce the issue encountered:

Takeoff, try to level the aircraft and see.

PC specs for those who want to assist (if not entered in your profile)

Not needed

Build Version # when you first started experiencing this issue:

1.18.13.0

Are you on the Steam or Microsoft Store version?

Steam

Did you submit this to Zendesk? If so, what is your ticket #?

No

1 Like

Sounds like a similar issues that I have seen on both the Steam Guage 172 and Extra 300

2 Likes

I’ve noticed it’s stronger too. Wouldn’t say it causes the aircraft to rocket or dive but certainly feels like a small click trims more than it used to. So far I’ve tried this on the DA62, 172, DC6, 152. Seems like it’s a base sim change.

Can’t decide whether I like it or not - I think maybe a middle ground between the old and the new would be quite nice.

4 Likes

Can confirm. Voted. The rate at which the elevator trim works definitely needs to be “nerfed”. Pre-SU5 it was almost perfect. Agree with what @BobbyFuzzy said though, that it’s not like the plane is climbing like a rocket or diving like a bomb all of a sudden, but still just a single click of trim seems way too much now.

And the trim button on my Thrustmaster Joystick is also making a weird sound in the sim now every time I click it, which never happened before.

6 Likes

Same here, using a button on my Throttle Quadrant to trim - it is hard to trim the aircraft fine now.
It used to work quite well before the SU5. I noticed that each click moves the elevator by ca 0.1 degree - seems not too much, but the plane lifts or dives too rapidly.

1 Like

I definitely not like it. Before SU5 it was waaaay better.

4 Likes

It seems to depend on the plane, though. The Cessna 152 is way too sensitive for me, but IIRC for example the Citation CJ4 is fine.
One plane I tried yesterday even trimmed a bit too slow, though I absolutely prefer that over being too fast.

You can change this by editing the aircraft .cfg, but I’m not sure that’s a good idea. If so the best way would be to create a mod that lives in the Community folder, but that’s a lot of work for a one-line change.

1 Like

I think it depends on the aircraft but it sounds like they added some sounds for the trim button on the yoke, I noticed that in the 172 last night too.

1 Like

How do they manage to break everything that works when they release the update? This is beyond my comprehension. The current update broke everything in my MSFS.

9 Likes

I can reproduce it easily with Saitek Trim Wheel.

  1. Load a flight in Cub
  2. Look at the trim wheel
  3. Make the slightest move with the trim wheel
  4. The visible trim wheel of the cub immediately “jumps” into a whole different position.

Disconnecting the Saitek Trim Wheel and assigning the trim up/down to button on the yoke works around it.

An issue I believe should be addressed immediately

3 Likes

Yes, I had the same thing happen to me in most GA. The 152 and 172 are almost impossible to trim and fly level. One click in the buttom and the trim wheel moves abruptly. At first I thought this could be the result of an overlooked new game setting that increases or decreases the speed of the trim wheel… but no such thing exists.

I also can’t vote on this thread, seems like I’m limited. Go figure.

5 Likes

Same exact experience here, one quick click of the trim setting on my joystick hat sends the 152/172 into a 500FPM climb/dive. I tried using the mouse to manually move the trim wheel and it’s even worse. Please Asobo, put things back the way they were. The trim system was never perfect, but at least before the update I could trim for level flight.

Also, the clicking sound for the electric trim in the 172 is way too loud and really annoying. I’ve flown planes with electric trims IRL and while the electric trim switch might make a sound when the plane is shut down on the ground you would never hear it over the sound of a running engine.

6 Likes

I noticed the same problem. Hope they fix it soon.

It is no longer possible to trim the default C172S to fly hands off using electric trim or manual trim. This is broken and needs fixed.

1 Like

Same as others. Please revert to pre-su5 settings

1 Like

Same problem here, unable to properly get the 152 into trim whereas pre update this worked flawlessly by doing precise movements on the trim. Have a button assigned on my alpha yoke and visually the trim wheel seems to move ok, the impact of that small movement is now way overdone.

Disagree that pre-SU5 was better. It is more responsive on the trim wheel of the Bravo only needing minor adjustments to trim which is more like RW flying.
Disagree if you wish but, at update 4 people were complaining that a lot of input was needed to trim.
No pleasing everybody.

One more vote.
I only tried the SR22 and just one trim increment or decrement seems to have way too much effect.
And this effect applies too quickly on the aircraft also but that’s another story.

I’m a new Xbox flight simmer. I also find the Cessna trim control to be far too sensitive. I tried to use it in the training mission and even the smallest movement of the right stick ‘trim control’ is far too much.

I only got a B grade because of this… :joy:

1 Like

Same issues here. Trim is completely unresponsive. Tried it on C152, C172, SR22. Nothing. I’ve reset the bindings and the sensitivity to no avail. For the record I bought my MSFS at launch through MS store pre-order (Just saying as a few comments say they bought off steam. Want to make sure it’s clear that it’s not a steam issue). May try disconnecting my yoke and throttle and plug in an Xbox controller. The game seems aimed towards Xbox so maybe that is the cure. :grimacing:

3 Likes