[BUG LOGGED] Elevator trim doesn't work as pre-SU5 and it's impossible to fly

It’s even funny to see that the last official plane (JU52) is affected (reverse axis)


Gettin’ more and more bizzare by the day :joy:

Tbf they said it will be fixed in SU6 which isn’t released yet, I doubt there will be any fix before that. It seems to be a more deeply rooted issue in the new controls to be fixed “quickly” in a hotfix, which they have to fix in the sim rather than the planes itself (which is why even the new Asobo planes are affected as well).

Might be time for X-plane 12. I’ve had about enough of this nonsense. They break the sim with every update and then its weeks before they fix it, just in time for another update that breaks it again for weeks and this continually repeats. It’s really hard to be kind to this type of ridiculousness.


I found this out as well. Trim to control aircraft level flight is locked. I sometimes wonder what on earth they do to this simulator when it is updated. I will place a vote.

I’m at the point where I just don’t want to use MSFS anymore. Every time there’s an update they break it! What’s the point?!? Certainly will not recommend this software to anyone. If the trim doesn’t work like it used to then simply can’t set for level hands-off flight. All hype about the new scenery updates but the flight model is compromised or something else is. STOP ALREADY!!!


Do they need 2 months to revert things back? ATM it’s unplayable and they still think about the eye-candy stuff


Good news. There are some trim related bugfixes in pre-release of Sim Update 6. Hopefully that will fix our issues

Where can I read about those fixes?

I can’t post links here. Please check latest facebook post of ms flight simulator page

1 Like

Here’s a link https://forums.flightsimulator.com/t/sim-update-6-flight-now-live/459829 where you can find a list.

1 Like

Thank you both.

After a week we have some more bad news:

Fix for trim is nowhere to be seen.

I’d like to remind to MSFS developers that this issue prevents people from using the simulator and it’s not like lights on AI aircraft for example.


Lol yeah, I just mapped mine to buttons and have given up. So, that’s fixed and then I run into the VFR flight planning “issues”. It is frustrating. I would appreciate more function over new content.

1 Like

I think it may have been fixed.

I haven’t tested all planes but the xcub was flyable with the buttons.

1 Like

Sorry for the late reply but if you haven’t found it yet, it’s in the flight_model.cfg file under the [FLIGHT_TUNING] section.

SU6: Tested xcub and the trim mapping is working correctly

range is again -100% to +100% :+1:

Just tested this in the C152 and both analog and digital trim settings are…better, but there are some caveats.

Analog trim now works very nicely, there’s just one full range binding, which of course you can adjust with the sensitivity curves to create a “50%” curve if you like.

Digital trim is much more “useful” now, but it behaves a lot more strangely than before. What they’ve done, I believe, is simulate your standard keyboard HID interface behavior, where you get a single input, then a pause, then repeated inputs at a set rate. This behaves like it used to, which was sort of a relic of how input was handled in the sim before they did the big xbox update with SU5, going back to probably FSX and before. Maybe something about standard windows HID vs Xinput? (all speculation here)

I suspect people with Bravo trim wheels will be very unhappy with how this works now. If you use trim keys or joystick buttons or hats, it’s great - you tap the trim, you get one “notch” of trim, just like before SU5, and unlike with SU5 when you got a bunch of presses based on how long you held the button. However, if you have an encoder wheel, you now get this really unpleasant behavior since the sim is back to ignoring your inputs if they don’t match up with this set repeat rate. On my encoder-based trim wheel, this manifests as a big apparent delay when you try to use it for larger adjustments. It’s very disconcerting, and somehow seems worse than it was pre-SU5 even though it should behave relatively similarly.

This is all a bit wonky but hopefully it helps some folks out. Maybe someone with a Bravo can report back - all I know is my arduino trim wheel is now basically useless for digital trim, but I’ll take it for working trim hats and analog trim wheels!

1 Like