[BUG] Reflections broken in VR since Update 5

Reflections (water and other reflective surfaces) jump around in VR since Update 5. From what I can tell, the reflections are recomputed with head movement (which in VR is all the time) and simply move around and dance around, completely changing position on the reflective surface.
A good example of that is the Fjord landing challenge: the terrain reflections in the water keep changing position at a wide scale level.

As this is highly distracting, the only workaround is to turn the reflections OFF.

The original thread is here: https://forums.flightsimulator.com/t/after-su5-shadows-in-vr-jumping-around

Overall, I have found SU5 and the Hotfix to be nothing short of spectacular for me - with 2 exceptions:

  1. The “dancing reflections” that you mention. I think this has been caused by lack of synchronization between the layer they are rendered on, and the layer the world is rendered on. I found it so annoying initially, that I too turned reflections off. I’ve now got used to that, and think in retrospect that reflections “as were” were a tad unrealistic anyway. They were always too sharp, and existed no matter what the water state or draw distance. With them turned off, I think the overall appearance is a bit closer to reality.

  2. Cloud “reflections”. Even with reflections turned off, some of the cloud reflections on water simply don’t match up with the clouds that are visible. They now (sometimes) appear as huge white “blobs” on the water surface unrelated to anything in the sky and - imho - can be annoyingly unrealistic. And I’ve found no way of turning those off, sadly.

But apart from those niggles, I found the overall sim experience to be eons ahead of any other sim I’ve ever had (most, since 2004). For comparison, I still turn to my P3D (with my $5, 000 or so of Orbx scenery) and what I see in MSFS knocks the socks off it visually, and performance-wise.

3 Likes

Absolutely. Exactly how I feel. I had to adjust the LODs to compensate, but that was no problem. Now running with LODs at 3. RS at 100% and am really happy with SU5 in VR (other than the items mentioned above and the aliased menus). So many people refusing to adjust LODs and wanting “proper fix”… Well, that may well be your proper fix!

1 Like

Until about 3 hours ago, I had my LODs at 2.00. I just changed them both to 4.00, and after about an hour’s flying tbh I can’t really see any noticeable difference. I didn’t have any disturbing pop-ins even at 2.00. There were (and still are) some, yes - but not enough to throw a tantrum about…pretty much what you’d expect in any sim where a huge amount of calculating is going on. I think it will ever be thus, and we just have to accept that. It’s a sim, not a flying Photoshop app…

Could you elaborate what you mean to “adjust LODs”?
What does this do? How to change it and where is that setting?
Thanks a lot

This problem applies to the standard mode too (perhaps it shouldn’t only be in the VR section) though indeed it’s much more noticeable in VR. Here another thread on this issue:

2 Likes

Oh my…so many issues with this update, I am so sad because this happened. As if our dear sim falling apart…the port to Xbox was a humongous task, and the team didn’t have enough time to finish the DX12 version for us, so they decided to give us the performance boost the best way they could.
I am just so sad that it didn’t turn out so well…I do not have the majority of issues that are trending, but I’ve seen others straggling with them and it is honestly heartbreaking…especially the silence form the dev team. They are probably in a full damage control mode, and people suffer there as well. :confused:

2 Likes

I’m sure I’ve had this from before SU5. Looking out over the wing of the silver Spitfire was what always really highlighted the issue for me.

Same for me

Seems like you are correct.
I think it is related to motion smooting / reprojection.
When this feature is activated certain layers seem not to be smoothed, hence start dencing. It also applies to plane shadows on the ground when flying low enough to see your own shadow, you see that its not smoothed like the terrain, instead its stuttering along with reflections.

I’m seeing this issue with the Quest 2 and ASW turned off. It might make it worse with re-projection on (I haven’t tried), but it is definitely not directly related to it.