Buildings much too high still in 1.9.5.0 Patch

My steps before the update so that it is not broken

  • delete the ROLLINGCACHE.CCC directly in MSFS Options > General > Data Scroll down to Rolling Cache Settings to delete
  • delete the MANUALCACHE.CCC in Windows Explorer
  • delete the community folder (do not forget backup) > Does not apply to me, I do not use
  • disable the developer mode (if switched on) > Does not apply to me, I do not use
  • delete under: C:\Users\<Username>\AppData\Roaming\Microsoft Flight Simulator all Files except subfolders
  • delete under: C:\Users\<Username>\AppData\Local\FlightSimulator all Files

My steps after Update

  • On all settings pages > reset all settings to Default (on all settings pages & at the bottom of each page)
  • Restart MSFS
  • Adjust everything according to your own wishes incl. creating new ROLLINGCACHE.CCC and MANUALCACHE.CCC
  • Check MFS Ingame Content Manager for updates (2 small Japan-Updates installed)
  • Restart MSFS
  • All options set as desired

  • Skyscrapers everywhere

  • now bf-pgg-folder deleted (bf-pgg downloaded again after start)

I never changed anything in the original files. I never installed any mods. Nevertheless at least the bf-pgg-folder was obviously not updated. This means that the updater does not check for faulty/non-up-to-date files and does not fix this.

Edit: I see only one solution to keep everything up to date > reinstall after each update :unamused:

I didn’t need to delete any folder so it’s kinda unsure why this happens.

Point being is that issue is resolved by Asobo. It’s on our end that it doesn’t work for some reason. For me it worked after udpating Japan Autogen and POI and restart.

I tried moving the bf-pgg-folder out of the FlightSimulatorPackages folder tree and let the game rebuild it, just to see what that would do.

Comparing the moved folder to the newly downloaded folder:

  • Total folder size is the same down to the byte level
  • manifest.json in the two folders are identical
  • pggmod_version_info.txt in the two folders are identical
  • File dates are different which confused me at first: The 1.9.5.0 patch install updated the dates on some of the files, apparently replacing them with identical files; deleting the folder of course updated the dates on all the files.

So at least on my system deleting that folder had not effect on the files themselves, yet for @AlexE75 it seems to have had an effect in the sim. No idea why that might be, seems something about our systems is different…

My system is from the Windows Store, is this a Windows Store vs. Steam issue?

Yup, that one is frustrating… surely this should happen automagically if its direct update to content from MS/Asobo. Anyhoooo, I’ll be watching for this in the future, in case other content doesn’t download

Good question?! In my bf-pgg - folder all files were outdated and had no current date. My MFS is the steam version of Microsoft Flight Simulator Premium Deluxe. Possibly the Launcher could be faulty in the Steam version and differ from the MS-Store version.

Well that is interesting. After the 1.9.5.0 update, before deleting the folder, my distribution.toml file date was 10/13/2020. I am not familiar with that file, but looking at it with a text editor it contains parameters that might be related to building height (e.g., “params.building_levels = [“2-5”]”). Before you deleted the folder did your distribution.toml have an older date?

Yes, none of the files and subfolders had today’s date. I have now deleted everything and will download everything again tomorrow. This seems to be the only reasonable thing to do if the updater does not reliably update all files. Now I am going to bed. Here it is equal to 03:00 o’clock. :woozy_face:

Yikes, yeah 3 am is too late for file debugging.

Think we got a lot closer to resolving the issue though, especially since you say your system is completely unmodded. Seems a good hypothesis is that it is related to the updater not performing correctly on a Steam system, or at least some Steam systems.

Yes, the updater absolutely needs an option “Check and verify all files”. Well, I’m off then, good night everyone.

My fix is no longer needed because v1.9.5 is correcting the tall building problem, in doing exactly what I’ve done in my fix!

2 Likes

To update all japan files in the content manager helped.

Congonhas (São Paulo) is not much better

It’s been already proven that this is how it was originally (with the fix and now without), so that’s unfortunetly it’s how it always was.

Yesterday I was surprised to receive the next patch from microsoft/asobo.

As far as I can see some top issues are fixed:

  • Big houses in small villages bug fixed

I checked that in the Northern Germany Flatlands ;-), that I knwow well (between Bremen and Hannover, Verden, Hoya, etc. ). The big houses that vieable in a lot of places are removed. There are bigger houses, but that may be supermarkets and litte industry spots, but that sems to be realistic.

Very important, as some others also reported: You have to update the Japan Scenery inside the contents menu. Than you have to restart (!) FS (otherwise it seems not to take effect).

I observe one problem:

I have a lot of bigger sceneries larger than 700 mb , especially photorealistic city data in my community folder. That makes the loading times of FS during very loooooooooong!!! And FS is searching inside the contents and that takes also time , in my case it shows nothing but the sandclock. Also I can*t open the market menü, also searching endless time.

Do some of you observe the same? So I had to rename the community folder and replace it by an emty one. Than FS loading time is very fast and I could open content manager and marketplace menu.
Now I delete all bigger scenery datamore than 700 mb and loading times are acceptable. Also I use a scenery manager, which is working with links (that also is possible with the windows dlink function, if you dont have enough space on you first drive, just place your whole communtiy folder to a second drive or use that scenery manager (f.e. MSFS Addon Linker) . Please only use the windows function if you are advanced PC user - but it is not to complicated, there are advises on you tube about it). Anyway - if there are to many bigger photorealitic scneries, FS seems to have long loadingtimes and the avove mentioned issues.

  • “Dolphin effect” - especially in Cessna Citation Longitude is fixed

I did a flight between KLAX and KLAS and the Autopilot worked fine.:-)Thats ver nice!!! Thanx!

  • Thunder and lightning when only view clouds - seems to be solved. But often there is thunder and lightning when overcast. But not always there should be thunder when overcast in the reality… so there maybe some finetuning possible?!

  • I have’t any CTD since I always open VFR map when starting FS. But that seems to be solved too.

No other problems reported but there may be other issues.

A big advice: Deactivate your community folder (rename the old one, create an emty community folder, no need to delete your addons) before you proceed an update by MS / Asobo. Later you can activate the folder again but first check if everything is working fine. Otherwise we don’t do good to the ASOBO team , because it may be users fault :wink:

2 Likes

I see what you did. You had installed some custom scenery for Wheymouth and forgot about re-installing it after the patch.
That’s why you couldn’t get it to look right. Not because the Asobo fix didn’t work.

What’s funny, when I fired up the sim yesterday after the patch tall buildings were gone. But just a couple of minutes ago I flew above the same area and there you have it - skyscrapers in a freaking mountain resort. Maybe this whole blackshark.ai took control over the sim and Asobo can do nothing about it? Don’t get me wrong, I love the sim, taking off today during a storm around Baltic Sea was an amazing experience, but when Asobo says they fixed something, it worked for an hour and now it’s broken again, I’m starting to loose faith in the developer :frowning:

Hi, you probably already found this out, but there are a few addons that will stop content manager from loading. In my case it was C152X, and in others it is a livery issue. Try removing liveries and updating them and see if that won’t help.
Best,
Mark

Thank you so much @fclem33 for this mod. Now Rabat looks very nice as it should be.
What lines did you edit please?
Thanks a lot

Best regards

Christophe

1 Like

hi,
yup it’s fixed for me now, I installed the 2 little patches in content manager. :slight_smile:

2 Likes

Yes I confirm, install the patch in content manager and it works !!

1 Like