Bush trip - not saving progress

Same problem with the Finland trip. It was saving the legs as long as you didn’t leave the game. Got to the last leg, and it didn’t complete the trip.


My goodness this saves me from continuing trying. I flew first 3 legs of Alaska, then I crashed. Had to start over from the first leg. After that I found out that when contunuing after a leg and only shutdown the XSX console you could unpause and go on. Except that I had a random engine failure in leg 5 and had to land on the steppes. To bad for me the plane turned over due to a bit to agressive braking and then… I had to start at the first airport again… that’s about 3 hours flying. And I had received the leg completion messages. Even tried to completely delete all the addons etc. but bo results. Real bummer… where can I vote for this?


For anyone also wanting this fixed please vote on this thread. Right now the bushtrip saving issue is getting zero attention.



@AHal please check the other topic that is posted earlier in the thread. Vote on that thread instead of a new one.


I saw that, but it is talking about some VFR map issue and POIs. My issue is you cannot even resume at the leg you completed. That said I’ve also voted for that one, but this seems to be a more specific issue in any case. It doesn’t specifically mention the legs not saving whatsoever even after getting leg completed.

Anyway like I said I also voted there.

Also, every single person should be submitting a zendesk ticket every single time they experience it. Not just the first time it happens; if any time you attempt a bushtrip and the leg doesn’t save, submit a new ticket each time.

The more tickets that get flooded the more attention it will get. I can’t believe an issue as glaring as this for one of the key features of the sim continues to be ignored, but please everyone, submit a ticket every single time. One is not enough, since each time is technically a new occurrence after all!



I found the same issue with bushtrips. Flew one for hours only to get a 0% as a result. Great job Microsoft.

I deleted all bushtrips from the content manager.

1 Like

Just to add more confusion, I’m in the process of re-flying the bush trips in VR. So far they’ve all been logged as they should be. Why are they working for some of us and not for others?

Even after returning to the menu?

No matter what I do, I get the leg completed pop ups and the saving circle in the corner, but returning to the menu it is not in the logbook and progress is at 0% for the trip and can only start at leg one.

I haven’t personally tested every single one, but many reports for different ones have been made. For me, Nevada and Alaska for sure do this.

Maybe the newer ones aren’t as bad? Not sure.

1 Like

I usually fly one leg at a time because I can’t deal with VR for more than about an hour (eyes get tired) . What I usually do is fly a leg, get out of VR, go to the main menu and exit the program. But even if I fly back-to-back legs it has been logging fine.

I haven’t re-flown Nevada or Alaska yet. I’m towards the end of the France flight.

I don’t know if it’s something similar but I tried completed the first leg of the Denmark bush trip but then started and completed the first leg of the Alaska one. I don’t know if that messed anything up but when I tried to do the second leg of the Denmark one and landed at the EKOD airport, the leg never completed.

1 Like

Stop doing bush trip for a while untill they fix it no point in wasting hrs and end nothing is saved. I haven’t touched bushtip just doing free flights

1 Like

Ok…I just tried the Alaska bush trip and it DIDN’T log the first leg. Well, it did in my logbook but not in the bush trip. When I went to fly the second leg, it started me off in the first leg.

The sim do not advance to the next leg when I land. The issue was existing from the start but it was happening occasionally but now it is persistent. No matter what I do after landing to the destination airport leg end menu never appears.

Yes, I have confirmed as well Alaska and Nevada save nothing for the bush trip lol

1 Like

I really really really want to do these Bush Trips, but like others have mentioned legs are not saving. I’m on Xbox and it seems like the issue is also affecting PC users too.

Hey at least we all have something in common these days :slight_smile: unlike the sheer amount of content available in the PC Marketplace --sigh-- I digress.

I’ve only tired the Alaska Bush Trip and that’s where I encountered the issue described in this post.

I’m not keen on sitting for 6+ hours to complete all the legs of this trip (besides the whole thing might not save anyway), nor I’m I ok with shutting the console down in between legs and then quick resuming. My experience has been quick resume on Xbox can introduce issues with GPS POIs waypoints not appearing correctly on the compass, etc. If I remember correctly, the POIs still appear on the GX3’s GPS map (again only have tried the Alaska trip) and you can use that as a guide to complete the legs; but something happens where the POI waypoints are broken on compass. Anyway, I can live with that.

Please someone, anyone, fix the “Bush trip - not saving progress” issue! :innocent:


Thank you!

i spend hours finishing all alaska bushtrips , and it gives me now 0 % completed !! i hate it sooo much :frowning:

1 Like

How in the heck do I get this game to save my progress on a bush trip? I like these and they are fun until I’m deflated when I want to fly a new session and discover I have to start all over again.

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Microsoft Store
Are you using Developer Mode or made changes in it?
Brief description of the issue:
Nevada Bush Trip will not show my progress even though it saves the progress in the filesystem
Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Fly the first leg and land come to a full stop. This saves and triggers the menu. You choose the only option being “next”. No matter what you choose after that “Continue, Main Menu, Bush Menu…” it will not save the progress.
PC specs and/or peripheral set up of relevant:
Windows 10 PC with thrustmeter flight controls
Build Version # when you first started experiencing this issue:

You don’t. But please vote on the bush trips thread so it’s fixed on the next update.

1 Like

Hello all,
I hope found the problem of incorrect saving trip.

I believe that this is the problem. The application cannot find the step description correctly. The pictures explain better what I mean.

I try more trip and, those who do not save, all have the same problem (incorrect description).

I tried on xbox (x series) and pc (same problem - incorrect description)
Latest build (1.20.6)

All languages have the same problem:


Just want to let you guys know I’m having the same issue. You’re not alone! Hope MS picks this op asap…