C152X Realism Mod

I know exactly what abuse they can take, I have well over 1000 hours in them. In Australia, they do generally keep the pants. Having the option can’t be a bad thing right?

Seeing the Carbon Cub and how they’ve modified that model, it seems like it is possible. I just need to get down and try to create some I guess.

How do you download this? I see a number of links on that git page but nothing that points to a zip for or anything.

On the Github page there is a green box called code click on it and then click download zip, then just save.

1 Like

Thank you. That was not obvious!

I just tried this mod out and noticed a couple of things:

  1. Tach doesn’t work. Stays at zero
  2. Yoke visibility doesn’t work. Cannot make yoke invisible
  3. Plane seems to zip through the air without stalling when landing. Seems I can barely get it to stall when 300 feet or so out from runway. It just doesn’t seem to slow down with engine at idle and 30 degrees of flaps. Seems to pretty much stay at 40or 50 IAS.

Are these known issues or am I unique in experiencing this? Thanks.

2 Likes

Check out the new MSFS_C152 V0.9.4 update!
We’ve changed a lot and made it compatible with the latest update which broke a lot!

It’s not possible to start the engine with that mod.

fuel on, mixture rich, throttle ~25%, bat,alt ON it’s not starting, nothing helps. Any advice? Is there some secret switch ?:slight_smile:

Try following the check list

Which mod are you using?
The newer 0.9.4 or the 0.17?

Using the 9.4 community mod

0.9.4

I was trying 30min to start the engine and I couldnt do it. When normal I know how to do it. Without mod there’s no problem.

I will try maybe today again.

Are you turning on the fuel cut off valve located between the seats?

Also move you mixture leaver back and forth a bit and then move it fully forward. That makes sure it’s in sync with the game otherwise it’s in the cutoff position

Both very good advices from GruesomeEight66.
Also, if you use a Honeycomb Yoke starter key, try using the cockpit starter key with the mouse instead (if it’s the problem, it’s easy to fix in a config file).

Ofcourse(fuel ON to the left), mixture leaver was moved many times 0-100, 0-80. Thrust 20%, 25%,30% and more nothing helps. I have HOTAS X and I was using a mouse to start the engine.

I will try today, and If there will be again problem I will make video.

Choke engine 3 times

This is a known issue, I should have it solved in the next release!

Have you tried holding the key for longer?
If you quick click it won’t start

I will try today.

1 Like

Oh there’s not need, I don’t have this issue anymore. I suggested it to help the troubleshooting because I used to have that issue a few months ago with an earlier version of the mod. Different PC, potentially different versions of mods … it was worth a check.