Can not run MSFS today, Press any button to start old screen appeared

Today it is impossible to run msfs for me.
After few seconds i’ve got an old (from the first version of msfs 2020) screen with Press any button to begin. After pressing, I’ve got and xbox window with welcome back… and Let’s go button. After pressing it i go back to the screen with Press any button to begin. And so on. Impossible to go further. Is it just me, or anybody else has such a birthday problem today ?
MS Store version, I’ve tried to logout from xbox and MS store, then log in. Still the same.


Sign out from (1)xbox app and (2)microsoft store

Restart PC

1 Launch xbox app and sign in
2 Launch microsoft store app and sign in.
3 Run msfs.


Personally, I’ve never had to sign out of the Store. It’s been well over six months since I had to sign out of anything FS-related, but when I did, I just signed out of my Xbox account via the Game Bar overlay. After restarting my rig, I went straight into MSFS and was prompted to sign in there and that was it.

Unfortunately that doesn’t help (signing out, restarting, signing in). What suprize me the most was that after screens with xbox, asobo and logos, I got starting screen such as we remember from the beginning of msfs, with “press any button” text.
But it seems that it is only my problem, so I’m affraid reinstallation is now my only option .

1 Like

I’ve been away a week, came back and getting this. New (old?) intro video, press any button, xbox sign in window, loop. It’s really tiring every time I have a break, come back there’s a new issue.

I got the same today, “Press any key” screen is back, without any obvious reason. MSFS started normally earlier this week, and boooooomm today can’t start the game. Sign out, restart, sign in, start MSFS, “Insert Microsoft Flight Simulator disk” message on the screen.

You have to be kidding me guys. I don’t even have an optical drive in my computer.

Ok, let’s try once again, sign out, restart, sign in, start MSFS, everything stars normally. What is happening here?

i have the same problem “Press any key” Sign out, restart, sign in. First time MSFS dont start for me, any help or info?

I had this exact issue last night.
Eventually tracked it down to suddenly having default settings with online disabled. All my general options settings were at default.

Setting online true cured the issue for me.

1 Like

A reinstall should not be necessary. It doesn’t think you have a license for some reason. @TenPatrol gave the most likely solution. Sometimes it’s deeper than that. Be that as it may, it has to do with your Xbox/store logins. Both of them.

Also, make sure you have all windows updates installed. It can be related to this.

I ran into an issue back in October where I had to uninstall, reboot, and reinstall the store and the Xbox apps to get it to recognize I was signed in. Both apps were reporting I was signed in, but, MSFS for some reason didn’t agree until I reinstalled both of those apps.

1 Like

I faced the same problem today. Here’s what I did and everything seems okay now.

  1. Exited MSFS
  2. Opened Xbox game bar to see if I could log out there. Didn’t find a logout option, and hence quit the app.
  3. Opened the Microsoft store and logged out of my account.
  4. Restarted the PC and ran MSFS. It gave me the “please insert disc” dialog.
  5. Exited MSFS and opened Store and logged in there.
  6. Opened MSFS and all was well!

Hope this helps.


This worked with me. Thanks! Maybe only loging out of MS Store might help as well. Then restart MS2020. Then end MS2020 at “please insert disc” window. Login MS STore and restart MS2020. Couldn´t test it afterwards…

I have the same issue as you descibed and I tried all solution mentioned in this post. But I still have the same result. It is very strange I was on holiday for one week and nobody touch the PC at that time. Since yesterday I am unable to start the game properly. I always came to the old "press any button to launch the game and the xbox window with the welcome back…appears…with the same result as you mentioned. Hope somebody can help to fix this strange issue.

As I mentioned I still have the same issue. Could you please explain how you solve it. What do you mean with “Setting online true cured the issue” ?

Thanks in advance for your assistance.

As I mentioned I still have the same issue. Could you please explain how you solve it. What do you mean with “Setting online true cured the issue” ?

Options/General Options/Data/Online Functionality → ON

did you already find a solution for this issue. I still fight to get my sim running, unfortunately all troubleshooting was not sucsessfull :unamused:

Yes, today I managed to run MSFS without reinstallation.
I followed steps allready described in this topic:

  1. I opened MS Store and signed out
  2. Restarted Windows
  3. I run MSFS, got “Insert Disk” message, so I exited MSFS
  4. I opened MS Store and signed in
  5. Run MSFS once more (without restarting PC)
    This time MSFS started OK.
1 Like

I did exactly that and it worked with me. But it does not work w/o restart of W10 as stated before.

Why this frequently happens, I do not know.

I had the same issue several times now. I simply restored the system to an earlier date where I knew the sim was working. Takes 5 minutes and works everytime.

EDIT: The issue seems to have been fixed after update on 2021-09-17. Either that or the fact that the KB update was reinstalled by Windows update. :grinning: :+1:

For me this was caused by KB5005565 that released on 2021-09-14.

I should add that I am running Steam version of MSFS 2020.

New topic with this issue can be found here: Press any button to start loop after installing KB5005565

1 Like

Huh ?? That tip deserves a separate topic.

1 Like