Cannot download mandatory update

I had the same issue as everyone else.

I had to install the xbox app and then launch flight simulator from inside the xbox app to get the update.

There is something far wrong when it takes a support call to apply an update

1 Like

Followed the procedure to install XBox App as described. It said already installed.
Went to it and get this screen shot but the option Microsoft Flight Simulator finished installing Click here to play does nothing. And No update option.
Go back to the normal launch of FltSim and get the Mandatory Update Message Go to Store.
Go to Store still no update option .
This is the worst update mess ever and you would think they would make this automatic on normal launch.
The amount of time wasted trying to update is unacceptable

Yesterday, 09/08/2021, I was finally able to see the 500-600 mb update in the Microsoft Store by clearing the stores cache and checking for updates after cache cleared and a reboot (there is a topic in the forums that tells you how to do this, but do not have the link currently). The store update downloaded fine. When I go to launch MSFS 2020 from the store, it tells me there is an update, and when it gets past the Blackshark intro, CTD. Tried this multiple times as administrator and always CTD. When I tried launching MSFS 2020 from XBox App, it asks me to insert a disc (?). I purchased MSFS from the Microsoft Store so I do not get the Disc thing. Tried several other times, safe mode and regular mode, to launch the sim and always CTD after the Blackshark intro screen. My Community folder was emptied well before I started the World Update 6 process.

Sorry to report, but the solutions offered above do not work for me to install the update. I have loaded the Xbox app and gone through the procedures, but FS still does not “update.” In fact, what happens is that FS actually loads using a 1.18 version but when I go to the market place to get the newest free materials, it says they are unavailable because my “version” should be a 1.19. With the moderator putting the word “solved” is wrong because this update problem has not been “solved” for users. By the way, this is the first time I can remember FS refusing to load updated materials because the “version” number is wrong. Any additional or other procedures are welcome. (The fact we are going through this mess is the best evidence that MS’s update procedure is flawed.)

Yes , same here, it somehow allowed me to get past the Mandatory Update Needed message on one attempt and it loaded the 1.18 version but with different screenshots to normal as though it had updated.
I thought it had worked but restarting caused it to be back in the same loop of Go to the Microsoft Store and still no update available.
It looked as though it had partially updated if that is possible ?

Same here. I can not update and the application fails to launch.

No Mandatory Update Message now but all I get is this screen message spinning for ever…

Moi aussi c’est reparti, merci RetiaryBrake 735

Install XBox app from MS Store:

Log out of MS Store, log out of XBox app, log into MS Store, log into XBox App, click Library in upper left of XBox app (little bookshelf icon):

Click on the MSFS2020 icon.

Then click “Play You Own This” in the app page:

An uppdate should run. Then launch the MSFS app from XBox app. The MSFS app should then check for updates and install some more.

At least, that’s what I remember doing. Tried MS Store numerous times, numerous app resets in Windows Setting, tried wsreset.exe numerous times, tried logging in and out of MS Store numerous times, tried re-booting numerous times, tried bitc**ng on the Feedback button–no joy.

But the XBox app got me the updates and let me run MSFS. Don’t forget to log out of XBox app, and back in.

Hope that helps. MS is a bummer. But the sim works pretty good nowadays.

I guess I needed the Xbox Companion app for my PC? :face_with_monocle:

Rodger dodger. I just added a pic of the app I’m talking about to my previous post–the app is in MS Store.

In xBox, try going to My Collection (icon that looks like books in upper left. Then click on Manage Installs tab upper right. Good luck.

1 Like

So I kind of followed the advice above going to the MS Store and downloading the XBox Console. That didn’t help. So bottom line I clicked on my downloaded games, FS11 and it said it wasn’t starting properly and indicated to download the game again. I’m doing that now, all 131.96GBs. I’ll update you when I’m up and running in a day or so. But that seems to be my only option as there is NO update available in any of MS stores Xbox or otherwise.

Hi, guys. Here we are again suffering from the awful work by Microsoft and partners.

So, like everybody I couldn’t find the update to MSFS2020 1.19.8.0 in the Microsoft Store.

Following and advice found in the web, I uninstalled the game, and tried to install again, as it worked for some.

But now the install manager keeps coming back to the beginning when it reaches the end of download, on an eternal disgraceful loop.

If anyone can help, would really appreciate.

It’s so sad that such a great product is accompainned with such bad “infrastructure”. An udpate is supposed to be a very basic thing. And even that Microsoft can’t deliver.

In the meantime, I will be forced to go back to X-Plane until I’m able to reinstall this mess.

Thanks in advance,
Leo.

2 Likes

I think the big issue was there are two Xbox apps in the Microsoft Store. One is the XBox Game Bar and the other is the Xbox app. It is the Xbox app that needs to be installed. I mistakenly installed the XBox Game Bar thinking that would work but of course it did not until I installed the Xbox app.

Thanks, man. Will try that. What a mess they have made.

Thank goodness for that sentence !
This showed the Fltsim Version I owned and clicking the icon to run and it at last downloaded the update
So 3 days of total frustration and it has now updated.
Why would a PC version buyer think you would need anything labelled X Box it is just not logical ?
I don’t know why they don’t put some effort into making this update process so much easier and automatic or at least some text telling you how to do it.

1 Like

Before seeing this post I uninstalled then reinstalled. This seems to have cured the problem for me. Yours is - no doubt - the quicker solution as I’m now waiting on 132GB download. At least I’m moving forward again.

2 Likes