Cannot download mandatory update

Confirm. XBox App installed. Refreshed some minutes the store updates… there it is… what a mess. But worxx

I installed the Xbox app from the Microsoft store and then the update for MSFS2020 appeared in the store and I was able to install it. However the download of the update when launching MSFS2020 gets stuck after a couple MB out of about 3.29GB, [2/53]. Keeps looping with “decompressing…” (I can’t read the whole filename, it disappears too quickly). No idea why.

This update process is getting worse and worse, a proper launcher is sorely needed to manage installs and updates. Thank you Microsoft and Adobo for providing me with the very worst install and updates management of all the apps and games I have ever experienced.

wow, this answer unlock my MFS’s mandatory update stuck issue and let me back to fly. It really works.

This worked for me too. Its so crazy that we have to install a new software title (XBox) to update a game through the Microsoft store.

I’m glad that the XBox app fixed this issue for some of you. Didn’t for me, after spending hours with CTDs during WU6 update, I opted to uninstall and reinstall. Got 6.5 hours and 66GB in, and another CTD. Same issue as before. Run/CTD/won’t-run/repair/runs-again/mandatory-update/CTD.

Very frustrating!!!

thank you weaselport :+1:

Does anyone know why we have to have XBOX installed on the PC? I dont want XBOX - based on teh settings it looks like it’s going to interfere with my complex audio setup - i produce radio shows on this machine. And i resent being peddled games all the time - i dont want more games. I just have the one simulator and that’s all I want.

Cheers
MikeK

unfortunately installing new X Box app and all possible updates on the PC did not resolve it.
Still in the loop to look for the manadatory update in the MS store

The same problem for me: An update to 1.19.xx / world update is not possible! So far I have tried everything that has been written here, without success. I deleted the entire “Official” and “Community” folder and reinstalled MSFS from the X-Box app store. I deleted and reinstalled the X-Box app. But the old version 1.18.xx appeared again, without the possibility to load the latest world update on the marketplace (requires a new version). MSFS is not listed under Updates in the Windows Store.
I have activated a box version (Premium Deluxe Edition) from the Microsoft Store. I don’t know what else to do …?!? It just sucks!

Discussion why the X-box app may be required should rather be done here,
so that this topic can focus on troubleshooting.

It is completely absurd. I cannot play the title i bought and they didn´t fixed it yet! it is nuts.
And they want me to throw more money via marketplace? No way.

@CeZeta85
Have you tried the workarounds?
e.g. https://flightsimulator.zendesk.com/hc/en-us/articles/4405345181202

1 Like

How long was your reinstall?

The total was about 140 GB. I think speed will depend on your Internet connection. Mine is pretty quick so the download required about 90 minutes.

Tanx! I went through all the points again. Only after the last point did the MSFS appear in the updates after restarting the computer … Very strange. But thanks for the hints!

1 Like

Thanks for the help. I did resolve the issue and it was just that @ArizonaEagle235

1 Like

Installing the Xbox app worked. I had to open/close the Microsoft Store app a couple times but it finally recognized the need for the FS update.

I have a Premium Deluxe box version for #PC
Last time I updated a few days ago and all was OK, but now:
Game doesn’t start - I get: “Get mandatory update from Micrososft Store.”
In the Store I need a code which I don’t have!
And that’s it :frowning:

Download and install xbox app
https://www.xbox.com/en-US/apps/xbox-app-for-windows-10

Restart PC

Launch xbox app and sign in.

Recheck for updates in microsoft store app

2 Likes

Thank you - it worked! :slight_smile:

P.S. I amd surprised that Microsoft doesn’t think about instructing customers of such procedures when they publish updates. It’s not professional…

2 Likes