Can't believe my poor VR performance on my system

Hi guys. My first post here. I’ll try not to sound too negative, but have to admit I’m extremely frustrated with my VR performance and very close to just give up on FS2020.

First my specs:
x570 Aourus Elite
Ryzen 9 3900X
G.Skill Trident Z 32GB 3600mhz CL16
MSI 3070 Suprim X
ADATA ASX8200PNP 1TB M.2
Win 10 with latest updates
GeForce 471.41 driver
65mbit internet connection
Quest 2
Link cable
(Anything else that is important?)

VR performance is terrible. I’ve tried almost every performance tips and tricks from various youtube channels to forum posts. Even with every settings in FS on low or off I can’t get smooth VR performance and it seems to vary every time I play. Sometimes it’s ALMOST playable, but most of the time it’s like my Quest 2 is possessed with some kind of demon. And I always test in the same area to try to get consistent results.

I was hoping for drastic improvements with sim update 5, but I still have problems that makes the experience more frustrating than enjoyable. It stutters ALL the time even if the fps counter seems to be stable at around 30 (without ASW). It’s a little bit better with OculusTrayTool with ASW 18, but it still have some stutters and fps drops. It’s better than before sim update 5, but still almost unplayable in VR.

I’m not an expert in computers and don’t know where to start troubleshooting or in what order I should troubleshoot. I just try a lot of different tips and tricks with almost never any noticable effect. I’ve probably tried 95% of all the different performance tips you can find online, but none have big effects on my system.

Other games runs fine both in VR and on my 4k monitor.

Where is my bottleneck? Is it my CPU? Or my M.2 drive?

I actually didn’t get much performance gain after upgrading from gtx 1080 ROG Strix Gaming to the 3070 I’m using now. But in other games it’s a totally different story (with lots of performance gains). I just don’t understand this.

I don’t know if anyone is able to help or even bother (understandable considering my negative take on this), but please let me know if some of you have had the same issues as me and was able to fix it (without being a noble price winner in computer science).

Cheers!

2 Likes

I have not played this in VR as sold my HMD a while back waiting for something better on the market so if it is Quest related I can’t help.
Otherwise get your 2D performance smooth and stable first and obviously make sure you have latest Nvidia drivers when doing so.
Turn off any frame capping or vertical sync if you have it enabled turn off live traffic and live weather and turn all your graphic settings up to ultra and check your fps, CPU usage and GPU usage in Xbox gamebar or use dev mode or whatever.
If you have res set to 4k take it down to 2k.

From here starting at default runway of same airport (do one that is tough on performance) you can change one setting at a time from ultra to low and recheck your GPU/CPU usage and fps.
Some settings are more CPU intensive others GPU.
You want to try and achieve a good balance between CPU and GPU usage by tweaking settings while looking to get the best fps as well.

Once you have played around working out what settings best balance your rig in 2D you can check out VR settings but since the Quest is not that high res I would also take terrain and object sliders down to 100, you can always slowly increase if you have a better experience.

If you can’t get good fps in 2D in 2k with that rig then something is wrong elsewhere but also there isa hotfix patch coming tomorrow so test with that as well.

Thanks for the reply BonniestManx065! Really appreciate you taking your time to try and help me.

When playing in 2D I get very good performance in 4K (ok not 100% 4k, but 3840x1600 on a 38" ultrawide) on high settings. I’ve not monitored the fps in 2D, but it’s totally playable for me with high settings in 4k. No stutters and everything seems to run smoothly.

Looking forward to the hotfix patch, but I guess the problem is with my system so my hopes are not very high anymore when it comes to drivers and updates.

Oculus had a beta update I noticed finally and it killed my VR. ii uninstalled it, (reverted back to non beta) and its better than ever now.

I second this observation. I rolled back from the Oculus beta as well. Stuttering fest with it.

No more problems when using the official version and make sure you run the debug tool as the ASW is known to enable itself every time.

1 Like

True dat. Good call

Also, if you set the FOV setting to .70 x .70 in the tray tool or ott; it helped me great deal.

For what it’s worth, I’m having pretty good performance (in my estimation) on my system with a Valve Index headset; under SU4 I was mostly following the configuration settings in CptLucky8’s thread on tuning the RTX 2070 Super for the Index. I’ve got a Ryzen 3700X and a 2070S.

Under SU5 performance has definitely improved (though to fix other things I ended up mostly reinstalling MSFS twice) and I’ve upped a bunch of settings from ‘medium’ to ‘high’ levels.

I don’t know if there’s anything different about the VR runtime for the Quest 2 that would make it worse on a faster system like yours (3900X and 3070).

1 Like

I am in the same boat my friend. You are describing my problem exactly!
I have a i5-9400F, 3070,32Gb RAM and SSD.
I was waiting for this update for months, I couldnt even sleep the night before. Now i don’t have much hopes left. I am blaming the quest 2 for this, but im not 100% sure.
Good luck and I hope something comes out for us.
cheers,
Jon.

1 Like

If you haven’t tested this yet, try switching to Steam’s OpenXR to see if it improves the stutter. I’m also using the Quest 2 and have always had issues with the Oculus version of OpenXR compared to Steam’s.

X570
32 GB 3200Mhz
Quest 2 72Hz (4704 x 2384) Link
OTT ASW 30HZ, Mirror FOV 0.8 x 0.8
RTX 2070S
Ryzen 5600x

I seem to be the only person that is having issues with Oculus’s OpenXR. When I enable it, performance appears to be a little higher than using Steam’s version, but there is a constant stutter I can’t get rid of. The performance graph shows it holding at 24fps but there is persistent stutter, as if the frame timing is off. When I switch to Steam’s version, all same settings, the stutter is gone.

How do you switch the OpenXR version?

Start Steam VR. From the Steam VR window open the menu and Select Settings → Developer. On the Developer tab there will be a button to enable Steam VR OpenXR if it is not already enabled.

2 Likes

I use the same setup, do this…

  1. Get rid of OTT
  2. Use Oculus Debug tool
  3. Set FOV Tangent Multiplier to 0.7;0.7, Set adaptive GPU Performance Scale to “off”, Set Asynchronous Spacewarp to Force 45FPS ON
  4. Start Oculus, Start Headset, set headset to 72HZ at max resolution (80,90 and 120 do nothing)
  5. In game set VR render scale to 100, Terrain detail to 200, Object detail to 150 or less
  6. Set everything else to high but you can go Ultra on a few, turn down the shadow numbers if you want.
  7. 2D GFX Settings do not matter

Play game, it will run smooth in any location with any plane (KLAX with everything on might be a push). You can set FOV to 0.8;0.8 and go 80% on render scale if you want. I do not fly airliners because they are terrible and they are boring but this works even for those things. When playing do not stare at minute objects to see if they are popping in or run some ridiculous calculations to work out precise draw distance of trees, because nobody cares.

Go in peace.

as an addendum, leave all NVIDIA settings as standard, they don’t do anything when you change them.

Steam does not play well with the OQ2, it never has and it probably never will. Steam does not recognise that FS is a VR capable game.

Same experience here on my Rift S. I was expecting perhaps a modest gain in performance and ended up with a massive one. Some settings upped from Medium to High, some disabled settings re-enabled, render scale upped from 80-100, LoD sliders from 75 to 200. And it still runs better than it did pre-patch while actually looking better to boot. Very surprised.

To be fair, SteamVR doesn’t work well with any Oculus products. It acts like a middle-man which means an instant drop in overall performance.

The thing that concerns me is the number of people complaining about Quest 2 performance while “older” Rift HMDs seems fine. (Not just in MSFS, but other games too.) I’m thinking the issue is with the Quest itself more than anything else, perhaps because it was designed primarily as a stand-alone headset rather than one connected to a PC? I don’t know.

The only real reason to use Steam VR for FS is the world scale option, which does work very well, but you lose smooth performance, even with SU5, so it’s not worth the hassle of trying to use it.

Yeah, that’s the one reason I considered using it myself… I don’t like the feeling of flying planes designed for an Ewok. But as you say, the performance loss just isn’t worth it. Small planes is the lesser issue.

Hi guys, thanks for all the feedback! I didn’t think I would get this many replies. I’ll read through each suggestion carefully and try the things you mention that I’ve not allready tried before. I really appreciate all your feedback!

There are soooo many variables to get this game to work ok and it’s not easy to understand what settings do what, and how each settings (in all the different apps, nvidia settings, in game settings etc. etc. etc.) affect each other. It’s almost like a lottery where you have to guess 7 correct settings in correct order for your specific system and than you’ll win the first price which is decent performance on your overpriced system :smile:

I regret trying VR in this game, because despite all the problems and frustration I can never go back to playing FS on a monitor. It’s like 2 totally different experiences. I’ve seen what nirvana potentially can be and it’s no going back.

7 Likes

I have 3900x/32gb/3080 ti.
GPU usage on my 4K monitor is 100% and I get 50fps.
But in my Quest 2, my GPU uses 60 to 80% to get 30 fps.
There must be a reason why GPU is not good at working when playing with VR.

There are some really good suggestions here, but sadly looks like things have not improved in the last few months/releases for Q2.
I got the Q2 in Dec when VR launched, and struggled to get a decent flight out of my humble i7 6700K +3070FE 32GB, NVME for Months! Tried everything but it was always stutter fest or completely blurry graphics. The only thing that was smooth was the Virtual Desktop option (perhaps it has to do with SteamVR) but the visuals were always turned down as expected vs link cable.
Switched over to Reverb G2 and world of a difference using the same setting in MSFS I get stutter free flights always. Don’t get me wrong G2 is not the magic bullet, and has its own issues, but thats what worked for me. just my three cents :slight_smile:
I think Q2 is a great headset for what it is, but not what I use for MSFS. I still use Q2 time to time to go wireless (via Virtual Desktop) and sharing the MSFS VR experience with family where they can walk around the plane, BUT I cant fly with it too many stutters/ low graphics and it breaks the immersion.
I totally agree with comments here, once you sat in the plane in VR there is no going back to pancake mode.
Good luck.